- Update ftgl to 2.1.3-rc5 (previous version was either 2.0.5 (from .pc file) or 2.1.2 (from distfile name), not 2.12), take maintainership
- Update dependent port (games/duel) - use LIB_DEPENDS for ftgl and bumb PORTREVISION Approved by: alepulver (games/duel maintainer), miwi (mentor)
This commit is contained in:
parent
7a292d3664
commit
4a0e10141c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=216709
7 changed files with 27 additions and 176 deletions
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= duel
|
||||
PORTVERSION= 0.98
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= alepulver
|
||||
|
@ -16,8 +16,8 @@ DISTNAME= lin${PORTNAME}
|
|||
MAINTAINER= alepulver@FreeBSD.org
|
||||
COMMENT= An overhead, OpenGL space shooter
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libftgl.a:${PORTSDIR}/graphics/ftgl
|
||||
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
|
||||
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
|
||||
ftgl.2:${PORTSDIR}/graphics/ftgl
|
||||
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_BZIP2= yes
|
||||
|
|
|
@ -6,47 +6,29 @@
|
|||
#
|
||||
|
||||
PORTNAME= ftgl
|
||||
PORTVERSION= 2.12
|
||||
PORTREVISION= 2
|
||||
DISTVERSION= 2.1.3-rc5
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://opengl.geek.nz/ftgl/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:C/([[:digit:]])$/.\1/}
|
||||
MASTER_SITES= SF
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= An OpenGL FreeType fonts rendering library
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
|
||||
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_GL= gl
|
||||
USE_GL= gl glu
|
||||
USE_XORG= x11 xext xmu
|
||||
GNU_CONFIGURE= yes
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME:U}
|
||||
CONFIGURE_WRKSRC= ${WRKSRC}/unix
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ARGS= --with-gl-inc=${LOCALBASE}/include --with-gl-lib=${LOCALBASE}/lib
|
||||
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
|
||||
INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
|
||||
MAKE_ENV= MKDIR="${MKDIR}"
|
||||
CONFIGURE_ARGS= --with-gl-inc="${LOCALBASE}/include" \
|
||||
--without-glut-inc
|
||||
USE_GNOME= gnomehack
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
.ifdef (NOPORTDOCS)
|
||||
DO_INSTALL_DOCS=\#
|
||||
.endif
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:S/-/~/}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%PORTDOCS%%|${DO_INSTALL_DOCS}|' \
|
||||
${BUILD_WRKSRC}/Makefile
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/demo/* ${EXAMPLESDIR}
|
||||
@${SED} -e 's|%%CC%%|${CC}|g; \
|
||||
s|%%CXX%%|${CXX}|g; \
|
||||
s|%%RM%%|${RM}|g; \
|
||||
s|%%CFLAGS%%|${CFLAGS}|g; \
|
||||
s|%%CXXFLAGS%%|${CXXFLAGS}|g; \
|
||||
s|%%PREFIX%%|${PREFIX}|g; \
|
||||
s|%%LOCALBASE%%|${LOCALBASE}|g' \
|
||||
<${FILESDIR}/makefile.ex >${EXAMPLESDIR}/makefile
|
||||
@${REINPLACE_CMD} -e '/SUBDIRS/ s|docs||; /SUBDIRS/ s|demo||' \
|
||||
${WRKSRC}/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (ftgl-2.1.2.tar.gz) = 3eabec9ad37371c4d139408c7ffd2429
|
||||
SHA256 (ftgl-2.1.2.tar.gz) = 83bf45ce03495bb0c0159a678144877b0dbc7d2f3d8e9f0aa006e72c5198d15f
|
||||
SIZE (ftgl-2.1.2.tar.gz) = 568497
|
||||
MD5 (ftgl-2.1.3-rc5.tar.gz) = fcf4d0567b7de9875d4e99a9f7423633
|
||||
SHA256 (ftgl-2.1.3-rc5.tar.gz) = 5458d62122454869572d39f8aa85745fc05d5518001bcefa63bd6cbb8d26565b
|
||||
SIZE (ftgl-2.1.3-rc5.tar.gz) = 841597
|
||||
|
|
|
@ -1,30 +0,0 @@
|
|||
# Make sure, that you have graphics/libglut installed
|
||||
# in order to build example program
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
CC= %%CC%%
|
||||
CXX= %%CXX%%
|
||||
RM= %%RM%%
|
||||
CFLAGS= %%CFLAGS%% -I. -I%%LOCALBASE%%/include -I%%PREFIX%%/include/FTGL
|
||||
CXXFLAGS= %%CXXFLAGS%% -I. -I%%LOCALBASE%%/include -I%%PREFIX%%/include/FTGL
|
||||
LDFLAGS= -L%%LOCALBASE%%/lib -L%%LOCALBASE%%/lib -lglut -lftgl
|
||||
|
||||
FREETYPE_CFLAGS!=%%LOCALBASE%%/bin/freetype-config --cflags
|
||||
FREETYPE_LFLAGS!=%%LOCALBASE%%/bin/freetype-config --libs
|
||||
|
||||
CFLAGS+= ${FREETYPE_CFLAGS}
|
||||
CXXFLAGS+= ${FREETYPE_CFLAGS}
|
||||
LDFLAGS+= ${FREETYPE_LFLAGS}
|
||||
|
||||
FTGLDemo: tb.o trackball.o FTGLDemo.o
|
||||
${CXX} $> -o $@ ${LDFLAGS}
|
||||
|
||||
.cpp.o:
|
||||
${CXX} -c ${CXXFLAGS} $*.cpp
|
||||
|
||||
.c.o:
|
||||
${CC} -c ${CFLAGS} $*.c
|
||||
|
||||
clean:
|
||||
${RM} -f FTGLDemo *.o
|
|
@ -1,11 +0,0 @@
|
|||
--- include/FTTextureGlyph.h.orig Tue May 29 21:42:13 2007
|
||||
+++ include/FTTextureGlyph.h Tue May 29 21:42:51 2007
|
||||
@@ -52,7 +52,7 @@
|
||||
* Reset the currently active texture to zero to get into a known state before
|
||||
* drawing a string. This is to get round possible threading issues.
|
||||
*/
|
||||
- static void FTTextureGlyph::ResetActiveTexture(){ activeTextureID = 0;}
|
||||
+ static void ResetActiveTexture(){ activeTextureID = 0;}
|
||||
|
||||
private:
|
||||
/**
|
|
@ -1,22 +0,0 @@
|
|||
--- unix/Makefile.orig Mon Jan 13 00:27:04 2003
|
||||
+++ unix/Makefile Thu Jun 17 17:20:29 2004
|
||||
@@ -1,7 +1,7 @@
|
||||
top_builddir=.
|
||||
-include $(top_builddir)/Make.conf
|
||||
|
||||
-SUBDIRS = src demo docs
|
||||
+SUBDIRS = src demo %%PORTDOCS%%docs
|
||||
|
||||
AUTOGEN = Make.conf config.log config.status libtool autom4te.cache ftgl.pc
|
||||
AUTOGEN_MAINT = aclocal.m4 acinclude.m4 config.guess config.sub configure ltmain.sh install-sh
|
||||
@@ -16,8 +16,8 @@
|
||||
./configure
|
||||
|
||||
install-local: ftgl.pc
|
||||
- $(INSTALL) -d -m 0755 $(libdir)/pkgconfig
|
||||
- $(INSTALL) -m 0644 ftgl.pc $(libdir)/pkgconfig/
|
||||
+ ${MKDIR} ${PREFIX}/libdata/pkgconfig
|
||||
+ $(INSTALL) -m 0644 ftgl.pc ${PREFIX}/libdata/pkgconfig/
|
||||
|
||||
maint-clean-local:
|
||||
$(RM) $(AUTOGEN_MAINT)
|
|
@ -1,12 +1,10 @@
|
|||
include/FTGL/FTBBox.h
|
||||
include/FTGL/FTBitmapGlyph.h
|
||||
include/FTGL/FTCharToGlyphIndexMap.h
|
||||
include/FTGL/FTCharmap.h
|
||||
include/FTGL/FTContour.h
|
||||
include/FTGL/FTBuffer.h
|
||||
include/FTGL/FTBufferFont.h
|
||||
include/FTGL/FTBufferGlyph.h
|
||||
include/FTGL/FTExtrdGlyph.h
|
||||
include/FTGL/FTFace.h
|
||||
include/FTGL/FTFont.h
|
||||
include/FTGL/FTGL.h
|
||||
include/FTGL/FTGLBitmapFont.h
|
||||
include/FTGL/FTGLExtrdFont.h
|
||||
include/FTGL/FTGLOutlineFont.h
|
||||
|
@ -14,83 +12,17 @@ include/FTGL/FTGLPixmapFont.h
|
|||
include/FTGL/FTGLPolygonFont.h
|
||||
include/FTGL/FTGLTextureFont.h
|
||||
include/FTGL/FTGlyph.h
|
||||
include/FTGL/FTGlyphContainer.h
|
||||
include/FTGL/FTLibrary.h
|
||||
include/FTGL/FTList.h
|
||||
include/FTGL/FTLayout.h
|
||||
include/FTGL/FTOutlineGlyph.h
|
||||
include/FTGL/FTPixmapGlyph.h
|
||||
include/FTGL/FTPoint.h
|
||||
include/FTGL/FTPolyGlyph.h
|
||||
include/FTGL/FTSize.h
|
||||
include/FTGL/FTSimpleLayout.h
|
||||
include/FTGL/FTTextureGlyph.h
|
||||
include/FTGL/FTVector.h
|
||||
include/FTGL/FTVectoriser.h
|
||||
include/FTGL/ftgl.h
|
||||
lib/libftgl.a
|
||||
lib/libftgl.la
|
||||
lib/libftgl.so
|
||||
lib/libftgl.so.2
|
||||
libdata/pkgconfig/ftgl.pc
|
||||
%%EXAMPLESDIR%%/makefile
|
||||
%%EXAMPLESDIR%%/tb.c
|
||||
%%EXAMPLESDIR%%/trackball.c
|
||||
%%EXAMPLESDIR%%/FTGLDemo.cpp
|
||||
%%EXAMPLESDIR%%/tb.h
|
||||
%%EXAMPLESDIR%%/trackball.h
|
||||
%%EXAMPLESDIR%%/README.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTBitmapGlyph_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTBitmapGlyph_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTCharmap_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTCharmap_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTContour_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTContour_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTExtrdGlyph_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTExtrdGlyph_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTFace_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTFace_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTFont_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTFont_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLBitmapFont_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLBitmapFont_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLExtrdFont_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLExtrdFont_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLOutlineFont_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLOutlineFont_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLPixmapFont_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLPixmapFont_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLPolygonFont_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLPolygonFont_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLTextureFont_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLTextureFont_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTGlyphContainer_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTGlyphContainer_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTGlyph_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTGlyph_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTLibrary_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTLibrary_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTOutlineGlyph_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTOutlineGlyph_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTPixmapGlyph_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTPixmapGlyph_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTPoint_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTPoint_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTPolyGlyph_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTPolyGlyph_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTSize_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTSize_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTTextureGlyph_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTTextureGlyph_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTVectoriser_8cpp-source.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/FTVectoriser_8cpp.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/files.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/globals.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/globals_func.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/globals_vars.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/tab_b.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/tab_l.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/tab_r.gif
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/tabs.css
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm include/FTGL
|
||||
@dirrm %%EXAMPLESDIR%%
|
||||
|
|
Loading…
Reference in a new issue