- Update to 2.4.0
- Cleanup and tweaks Submitted by: David Yeske <dyeske@gmail.com> (maintainer)
This commit is contained in:
parent
fc0340ec4d
commit
4a15af3b74
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=207016
4 changed files with 35 additions and 54 deletions
|
@ -6,14 +6,11 @@
|
|||
#
|
||||
|
||||
PORTNAME= goom
|
||||
PORTVERSION= 1.8.1
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 2.4.0
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= goom
|
||||
MASTER_SITES= SF
|
||||
PKGNAMEPREFIX= xmms-
|
||||
DISTNAME= xmms-goom_${PORTVERSION:S/.p/pre/}-2
|
||||
EXTRACT_SUFX= .tgz
|
||||
DISTNAME= ${PORTNAME}-2k4-0-src
|
||||
|
||||
MAINTAINER= dyeske@gmail.com
|
||||
COMMENT= A cool XMMS visualization
|
||||
|
@ -22,30 +19,18 @@ BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms \
|
|||
nasm:${PORTSDIR}/devel/nasm
|
||||
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
|
||||
|
||||
PLIST_FILES= lib/xmms/Visualization/libgoom.so
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gdkpixbuf
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_XORG= x11
|
||||
USE_GNOME+= gdkpixbuf gnomehack pkgconfig
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
USE_SDL= sdl
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME}_${PORTVERSION}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 700042
|
||||
BROKEN= Does not compile with GCC 4.2
|
||||
.endif
|
||||
|
||||
.if ${ARCH} != "i386"
|
||||
BROKEN= Does not compile on !i386
|
||||
.endif
|
||||
WRKSRC= ${WRKDIR}/goom2k4-0
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|gtk-config|${GTK_CONFIG}|g; \
|
||||
s|-lgtk|`${GTK_CONFIG} --libs`|g; \
|
||||
s|-O9||' \
|
||||
@${CHMOD} -R og+rx ${WRKSRC}
|
||||
@${REINPLACE_CMD} -e 's|gtk-config|${GTK_CONFIG}|g' \
|
||||
${BUILD_WRKSRC}/src/Makefile.in
|
||||
@${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/ltconfig
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (xmms-goom_1.8.1-2.tgz) = 26a4870c9a42ae33b5a5b48f262ce39b
|
||||
SHA256 (xmms-goom_1.8.1-2.tgz) = 782303bf308a9b9e787a665a6d04da4b77d2fcef80dd480d5f9d87fcb8acccf2
|
||||
SIZE (xmms-goom_1.8.1-2.tgz) = 181257
|
||||
MD5 (goom-2k4-0-src.tar.gz) = 8100dd07e0c6784fdf079eeaa53a5c7f
|
||||
SHA256 (goom-2k4-0-src.tar.gz) = d993c904c05faba87fd7f159291fa1cb7aadcff2edd28454d8e967880a8a0c85
|
||||
SIZE (goom-2k4-0-src.tar.gz) = 757058
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
--- ltmain.sh 2001/08/27 09:51:26 1.1
|
||||
+++ ltmain.sh 2001/08/27 09:51:42
|
||||
@@ -2408,6 +2408,9 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
+ *-*-freebsd*)
|
||||
+ # FreeBSD doesn't need this...
|
||||
+ ;;
|
||||
*)
|
||||
# Add libc to deplibs on all other systems if necessary.
|
||||
if test "$build_libtool_need_lc" = "yes"; then
|
||||
@@ -4175,10 +4178,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
21
graphics/xmms-goom/pkg-plist
Normal file
21
graphics/xmms-goom/pkg-plist
Normal file
|
@ -0,0 +1,21 @@
|
|||
bin/goom2
|
||||
include/goom/goom.h
|
||||
include/goom/goom_plugin_info.h
|
||||
include/goom/goom_typedefs.h
|
||||
include/goom/goom_graphic.h
|
||||
include/goom/goom_config_param.h
|
||||
include/goom/goom_visual_fx.h
|
||||
include/goom/goom_filters.h
|
||||
include/goom/goomsl.h
|
||||
include/goom/goomsl_hash.h
|
||||
include/goom/goomsl_heap.h
|
||||
include/goom/goom_tools.h
|
||||
include/goom/goom_config.h
|
||||
lib/libgoom2.so.0
|
||||
lib/libgoom2.a
|
||||
lib/libgoom2.la
|
||||
lib/xmms/Visualization/libxmmsgoom2.so
|
||||
lib/xmms/Visualization/libxmmsgoom2.la
|
||||
lib/xmms/Visualization/libxmmsgoom2.a
|
||||
libdata/pkgconfig/libgoom2.pc
|
||||
@dirrm include/goom
|
Loading…
Reference in a new issue