Update to version 2.4

PR:		ports/72324
Submitted by:	Ports Fury
This commit is contained in:
Kirill Ponomarev 2004-10-12 12:11:36 +00:00
parent a9901c7571
commit 4a280610aa
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=118972
5 changed files with 18 additions and 63 deletions

View file

@ -6,15 +6,26 @@
#
PORTNAME= whichman
PORTVERSION= 2.0
PORTVERSION= 2.4
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
http://www.linuxfocus.org/~guido.socher/
MASTER_SITE_SUBDIR= apps/doctools
MASTER_SITES= http://main.linuxfocus.org/~guido.socher/
MAINTAINER= ports@FreeBSD.org
COMMENT= Approximate matching utilities to search for manpages and files
MAN1= whichman.1 ftff.1 ftwhich.1
USE_REINPLACE= yes
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
MAN1= ftff.1 ftwhich.1 whichman.1
PLIST_FILES= bin/ftff bin/ftwhich bin/whichman
post-patch:
@${REINPLACE_CMD} -e 's|/usr/man:||g' ${WRKSRC}/whichman.c
do-install:
.for name in ftff ftwhich whichman
${INSTALL_PROGRAM} ${WRKSRC}/${name} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man1/${name}.1 ${MANPREFIX}/man/man1
.endfor
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
MD5 (whichman-2.0.tar.gz) = 9b4b17efc7390c4223836cc684cfd763
SIZE (whichman-2.0.tar.gz) = 17727
MD5 (whichman-2.4.tar.gz) = cc3d35f26bbd8bf99f4f16b276384333
SIZE (whichman-2.4.tar.gz) = 18379

View file

@ -1,13 +0,0 @@
--- whichman.c.orig Tue Jun 6 15:16:51 2000
+++ whichman.c Tue Jun 6 15:17:09 2000
@@ -399,8 +399,8 @@
mpath = (char *) getenv("MANPATH");
if (mpath == NULL || *mpath == '\0') {
- fprintf(stderr,"Warning: MANPATH not defined, using /usr/man\n");
- mpath="/usr/man";
+ fprintf(stderr,"Warning: MANPATH not defined, using /usr/share/man\n");
+ mpath="/usr/share/man";
}
/* make a copy that is static */
cmpath = (char *)malloc(sizeof(char)*(strlen(mpath) + 2));

View file

@ -1,40 +0,0 @@
--- Makefile.orig Tue Apr 11 23:04:09 2000
+++ Makefile Tue Jun 6 16:57:24 2000
@@ -1,9 +1,9 @@
# written by Guido Socher
-PREFIX=/usr
+#PREFIX=/usr/local
INSTALL=install
MANP=man1/whichman.1 man1/ftff.1 man1/ftwhich.1
-CC=gcc
-CFLAGS= -Wall -O2
+CC?=gcc
+CFLAGS?= -Wall -O2
#sun c/c++-compiler:
#CC=CC
#CFLAGS= -O
@@ -29,17 +29,17 @@
$(CC) $(CFLAGS) -c levdist.c
install: whichman ftff ftwhich $(MANP)
- strip whichman
- strip ftwhich
- strip ftff
+# strip whichman
+# strip ftwhich
+# strip ftff
[ -d "$(PREFIX)/bin" ] || $(INSTALL) -d $(PREFIX)/bin
[ -d "$(PREFIX)/man/man1" ] || $(INSTALL) -d $(PREFIX)/man/man1
- $(INSTALL) -m 755 whichman $(PREFIX)/bin
- $(INSTALL) -m 755 ftwhich $(PREFIX)/bin
- $(INSTALL) -m 755 ftff $(PREFIX)/bin
+ $(BSD_INSTALL_PROGRAM) whichman $(PREFIX)/bin
+ $(BSD_INSTALL_PROGRAM) ftwhich $(PREFIX)/bin
+ $(BSD_INSTALL_PROGRAM) ftff $(PREFIX)/bin
for p in $(MANP) ; do \
echo "installing $$p in $(PREFIX)/man/man1"; \
- $(INSTALL) -m 644 $$p $(PREFIX)/man/man1 ;\
+ $(BSD_INSTALL_MAN) $$p $(PREFIX)/man/man1 ;\
done
install_with_cp: whichman ftff ftwhich $(MANP)

View file

@ -1,3 +0,0 @@
bin/whichman
bin/ftwhich
bin/ftff