Disable a bizarre attempt to use both BSD and GNU make constructs
in parallel. Fixes build with gmake 3.82. While there, patch Variables.mk instead of running a substitution.
This commit is contained in:
parent
1b1b5b16d9
commit
4a48f57964
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=270788
4 changed files with 31 additions and 4 deletions
|
@ -26,8 +26,4 @@ PLIST_FILES= include/arena/align.h \
|
|||
lib/libarena.a
|
||||
PLIST_DIRS= include/arena
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -E 's|^(PREFIX.*):=|\1?=|' \
|
||||
${WRKSRC}/mk/Variables.mk
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
9
devel/libarena/files/patch-mk_Epilogue.mk
Normal file
9
devel/libarena/files/patch-mk_Epilogue.mk
Normal file
|
@ -0,0 +1,9 @@
|
|||
--- mk/Epilogue.mk.orig 2011-03-13 13:59:37.000000000 +0100
|
||||
+++ mk/Epilogue.mk 2011-03-13 13:59:59.000000000 +0100
|
||||
@@ -5,5 +5,5 @@
|
||||
d := $(dirstack_$(sp))
|
||||
|
||||
sp ?= $(shell basename "$(sp)")
|
||||
-sp != basename "$(sp)"
|
||||
+#sp != basename "$(sp)"
|
||||
|
9
devel/libarena/files/patch-mk_Prologue.mk
Normal file
9
devel/libarena/files/patch-mk_Prologue.mk
Normal file
|
@ -0,0 +1,9 @@
|
|||
--- mk/Prologue.mk.orig 2011-03-13 13:59:37.000000000 +0100
|
||||
+++ mk/Prologue.mk 2011-03-13 14:00:08.000000000 +0100
|
||||
@@ -9,5 +9,5 @@ d := $(dir)
|
||||
|
||||
# Our parent directory
|
||||
$(d)/.. ?= $(shell dirname "$(d)")
|
||||
-$(d)/.. != dirname "$(d)"
|
||||
+#$(d)/.. != dirname "$(d)"
|
||||
|
13
devel/libarena/files/patch-mk_Variables.mk
Normal file
13
devel/libarena/files/patch-mk_Variables.mk
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- mk/Variables.mk.orig 2011-03-13 13:59:37.000000000 +0100
|
||||
+++ mk/Variables.mk 2011-03-13 13:59:47.000000000 +0100
|
||||
@@ -3,8 +3,8 @@
|
||||
# PREFIX, EPREFIX, prefix and exec_prefix. Lower cases variants have higher
|
||||
# priority.
|
||||
#
|
||||
-PREFIX := $(prefix)
|
||||
-PREFIX := /usr/local
|
||||
+PREFIX ?= $(prefix)
|
||||
+PREFIX ?= /usr/local
|
||||
EPREFIX := $(exec_prefix)
|
||||
EPREFIX := $(PREFIX)
|
||||
prefix := $(PREFIX)
|
Loading…
Reference in a new issue