update to 2013-03-R1b
Feature safe: yes
This commit is contained in:
parent
354c0ee775
commit
4a613a348e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=316036
6 changed files with 40 additions and 37 deletions
|
@ -1,13 +1,8 @@
|
|||
# New ports collection makefile for: kismet
|
||||
# Date created: 3 May 2004
|
||||
# Whom: Thomas Spreng <spreng@socket.ch>
|
||||
#
|
||||
# Created by: Thomas Spreng <spreng@socket.ch>
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= kismet
|
||||
DISTVERSION= 2011-03-R2
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 2013-03-R1b
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net-mgmt
|
||||
MASTER_SITES= http://www.kismetwireless.net/code/:1 \
|
||||
|
@ -19,6 +14,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
|||
MAINTAINER= bf@FreeBSD.org
|
||||
COMMENT= 802.11 layer2 wireless network detector, sniffer, and IDS
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
|
@ -27,30 +24,32 @@ LDFLAGS+= -L${LOCALBASE}/lib
|
|||
MAN1= kismet.1 kismet_drone.1
|
||||
MAN5= kismet.conf.5 kismet_drone.conf.5
|
||||
|
||||
OPTIONS= PCRE "Build kismet with PCRE regex filters" on \
|
||||
PLUGINS "Build and install plugins" off \
|
||||
SETUID "Build kismet with privilege separation" on
|
||||
OPTIONS_DEFINE= PCRE PLUGINS SETUID
|
||||
OPTIONS_DEFAULT= PCRE PLUGINS SETUID
|
||||
SETUID_DESC= Use privilege separation
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:S/a$$//}
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.ifndef(NOPORTDOCS)
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
PORTDOCS= README manuf
|
||||
DISTFILES+= manuf:2
|
||||
IGNOREFILES= manuf
|
||||
.endif
|
||||
|
||||
.ifndef(NOPORTEXAMPLES)
|
||||
.if ${PORT_OPTIONS:MEXAMPLES}
|
||||
PORTEXAMPLES= *
|
||||
.endif
|
||||
|
||||
.ifdef(WITH_PCRE)
|
||||
.if ${PORT_OPTIONS:MPCRE}
|
||||
CONFIGURE_ARGS+=--enable-pcre
|
||||
LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-pcre
|
||||
.endif
|
||||
|
||||
.ifdef(WITH_SETUID)
|
||||
.if ${PORT_OPTIONS:MSETUID}
|
||||
GROUPS = kismet
|
||||
CONFIGURE_ARGS+=--with-suidgroup=${GROUPS}
|
||||
INSTALL_TARGET = suidinstall
|
||||
|
@ -63,9 +62,9 @@ CONFIGURE_ARGS+=--without-suidgroup
|
|||
PLIST_SUB+= SUID="@comment "
|
||||
.endif
|
||||
|
||||
.ifdef(WITH_PLUGINS)
|
||||
ALL_TARGET= depend all-with-plugins
|
||||
INSTALL_TARGET+= plugins-install
|
||||
.if ${PORT_OPTIONS:MPLUGINS}
|
||||
ALL_TARGET= depend all all-plugins
|
||||
INSTALL_TARGET+= all-plugins-install
|
||||
PLIST_SUB+= PLUGINS=""
|
||||
.else
|
||||
PLIST_SUB+= PLUGINS="@comment "
|
||||
|
@ -80,16 +79,19 @@ post-patch:
|
|||
-e "s/make/${GMAKE}/" \
|
||||
-e "s/\$$(MAKE)/${GMAKE}/" \
|
||||
${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e "/PLUGINLDFLAGS/d" \
|
||||
${WRKSRC}/Makefile.inc.in
|
||||
@${REINPLACE_CMD} -e "s/CXXFLAGS/CPPFLAGS/" \
|
||||
${WRKSRC}/plugin-alertsyslog/Makefile
|
||||
@${FIND} ${WRKSRC} -type f -name 'Makefile' -print0 | ${XARGS} -0 \
|
||||
${REINPLACE_CMD} -E \
|
||||
'/C(XX)?FLAGS[[:blank:]]*\+=/s/ -g / /'
|
||||
|
||||
post-install:
|
||||
.ifndef(NOPORTDOCS)
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/manuf ${DOCSDIR}
|
||||
.endif
|
||||
.ifndef(NOPORTEXAMPLES)
|
||||
.if ${PORT_OPTIONS:MEXAMPLES}
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/ruby/* ${EXAMPLESDIR}
|
||||
.endif
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
SHA256 (kismet/kismet-2011-03-R2.tar.gz) = 71a099fb724951cdd55c28e492432ca21657534c91a536c206f3e0a8686d2a64
|
||||
SIZE (kismet/kismet-2011-03-R2.tar.gz) = 924988
|
||||
SHA256 (kismet/kismet-2013-03-R1b.tar.gz) = c0bb8a8f47061e2ffc965b0557bab9a1b3d63b5a50b744663f66518aec7fbc77
|
||||
SIZE (kismet/kismet-2013-03-R1b.tar.gz) = 935437
|
||||
SHA256 (kismet/manuf) = IGNORE
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- plugin-autowep/Makefile.orig 2010-09-04 12:31:22.000000000 -0400
|
||||
+++ plugin-autowep/Makefile 2010-09-04 12:32:10.000000000 -0400
|
||||
--- restricted-plugin-autowep/Makefile.orig 2013-03-25 13:29:11.000000000 -0400
|
||||
+++ restricted-plugin-autowep/Makefile 2013-04-04 15:37:44.000000000 -0400
|
||||
@@ -22,7 +22,7 @@
|
||||
|
||||
install: $(PLUGOUT)
|
||||
mkdir -p $(DESTDIR)$(prefix)/lib/kismet/
|
||||
- install -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)$(prefix)/lib/kismet/$^
|
||||
+ install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(PLUGOUT) $(DESTDIR)$(prefix)/lib/kismet/$(PLUGOUT)
|
||||
mkdir -p $(DESTDIR)/$(plugindir)
|
||||
- $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)/$(plugindir)/$^
|
||||
+ $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) -m 644 $(PLUGOUT) $(DESTDIR)/$(plugindir)/$(PLUGOUT)
|
||||
|
||||
userinstall: $(PLUGOUT)
|
||||
mkdir -p ${HOME}/.kismet/plugins/
|
||||
|
|
|
@ -1,12 +1,11 @@
|
|||
--- plugin-ptw/Makefile.orig 2010-05-24 19:53:16.000000000 +0200
|
||||
+++ plugin-ptw/Makefile 2010-05-24 19:53:19.000000000 +0200
|
||||
@@ -22,8 +22,7 @@
|
||||
--- restricted-plugin-ptw/Makefile.orig 2013-04-04 15:43:05.000000000 -0400
|
||||
+++ restricted-plugin-ptw/Makefile 2013-04-04 15:44:50.000000000 -0400
|
||||
@@ -22,7 +22,7 @@
|
||||
|
||||
install: $(PLUGOUT)
|
||||
mkdir -p $(DESTDIR)$(prefix)/lib/kismet/
|
||||
-
|
||||
- install -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)$(prefix)/lib/kismet/$^
|
||||
+ install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(PLUGOUT) $(DESTDIR)$(prefix)/lib/kismet/$(PLUGOUT)
|
||||
mkdir -p $(DESTDIR)/$(plugindir)
|
||||
- $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)/$(plugindir)/$^
|
||||
+ $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) -m 644 $(PLUGOUT) $(DESTDIR)/$(plugindir)/$(PLUGOUT)
|
||||
|
||||
userinstall: $(PLUGOUT)
|
||||
mkdir -p ${HOME}/.kismet/plugins/
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- plugin-ptw/aircrack-crypto.cc.orig 2010-05-24 11:40:15.000000000 +0200
|
||||
+++ plugin-ptw/aircrack-crypto.cc 2010-05-24 11:39:34.000000000 +0200
|
||||
--- restricted-plugin-ptw/aircrack-crypto.cc.orig 2010-05-24 11:40:15.000000000 +0200
|
||||
+++ restricted-plugin-ptw/aircrack-crypto.cc 2010-05-24 11:39:34.000000000 +0200
|
||||
@@ -21,6 +21,7 @@
|
||||
#include <string.h>
|
||||
#include <arpa/inet.h>
|
||||
|
|
|
@ -8,7 +8,9 @@ etc/kismet.conf.sample
|
|||
@unexec if cmp -s %D/etc/kismet_drone.conf %D/etc/kismet_drone.conf.sample; then rm -f %D/etc/kismet_drone.conf; fi
|
||||
etc/kismet_drone.conf.sample
|
||||
%%PLUGINS%%lib/kismet/aircrack-kismet.so
|
||||
%%PLUGINS%%lib/kismet/alertsyslog.so
|
||||
%%PLUGINS%%lib/kismet/autowep-kismet.so
|
||||
%%PLUGINS%%lib/kismet/kismet-syslog.so
|
||||
%%PLUGINS%%lib/kismet/spectool_net.so
|
||||
%%PLUGINS%%lib/kismet_client/spectools_ui.so
|
||||
%%DATADIR%%/wav/alert.wav
|
||||
|
|
Loading…
Reference in a new issue