Fix the build in the WITH_PGSQL=yes case.

When the databases/postgresql7 port was updated from postgresql-7.1.x to
postgresql-7.2, libpq-fe.h moved from PREFIX/include/pgsql to
PREFIX/include for reasons I can't figure out.

This applies a band-aid until I can get clarification from the postgresql
port maintainer <girgen@partitur.se>, but I think the port might be
"broken" in its placement of some header files.

Reported by:	kris
This commit is contained in:
Sheldon Hearn 2002-04-02 11:40:49 +00:00
parent d5cc2f7d80
commit 4a765861a7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=57189
3 changed files with 22 additions and 19 deletions

View file

@ -35,18 +35,19 @@
# Many sites define a user called "exim", with an appropriate default group,
# and use
@@ -269,8 +269,8 @@
@@ -269,8 +269,9 @@
# don't need to set LOOKUP_INCLUDE if the relevant directories are already
# specified in INCLUDE.
-# LOOKUP_INCLUDE=-I /usr/local/ldap/include -I /usr/local/mysql/include -I /usr/local/pgsql/include
-# LOOKUP_LIBS=-L/usr/local/lib -lldap -llber -lmysqlclient -lpq
+INCLUDE=-I XX_PREFIX_XX/include
+LOOKUP_INCLUDE=XX_MYSQL_INCLUDE_XX XX_PGSQL_INCLUDE_XX XX_LDAP_INCLUDE_XX
+LOOKUP_LIBS=XX_MYSQL_LIBS_XX XX_PGSQL_LIBS_XX XX_LDAP_LIBS_XX
#------------------------------------------------------------------------------
@@ -281,7 +281,7 @@
@@ -281,7 +282,7 @@
# files are defaulted in the OS/Makefile-Default file, but can be overridden in
# local OS-specific make files.
@ -55,7 +56,7 @@
@@ -316,7 +316,7 @@
@@ -316,7 +317,7 @@
# settings commented out.
# SUPPORT_TLS=yes
@ -64,7 +65,7 @@
# If you are running Exim as a server, note that just building it with TLS
# support is not all you need to do. You also need to set up a suitable
@@ -358,7 +358,7 @@
@@ -358,7 +359,7 @@
# Once you have done this, "make install" will build the info files and
# install them in the directory you have defined.
@ -73,7 +74,7 @@
#------------------------------------------------------------------------------
@@ -371,7 +371,7 @@
@@ -371,7 +372,7 @@
# %s. This will be replaced by one of the strings "main", "panic", or "reject"
# to form the final file names. Some installations may want something like this:
@ -82,7 +83,7 @@
# which results in files with names /var/log/exim_mainlog, etc. The directory
# in which the log files are placed must exist; Exim does not try to create
@@ -459,7 +459,7 @@
@@ -459,7 +460,7 @@
# USE_TCP_WRAPPERS=yes
# CFLAGS=-O -I/usr/local/include
@ -91,7 +92,7 @@
# but of course there may need to be other things in CFLAGS and EXTRALIBS_EXIM
# as well.
@@ -678,7 +678,7 @@
@@ -678,7 +679,7 @@
# (process id) to a file so that it can easily be identified. The path of the
# file can be specified here. Some installations may want something like this:

View file

@ -72,16 +72,17 @@
# which results in files with names /var/log/exim_mainlog, etc. The directory
# in which the log files are placed must exist; Exim does not try to create
@@ -352,6 +352,8 @@
@@ -352,6 +352,9 @@
# LOOKUP_INCLUDE=-I /usr/local/ldap/include -I /usr/local/mysql/include -I /usr/local/pgsql/include
# LOOKUP_LIBS=-L/usr/local/lib -lldap -llber -lmysqlclient -lpq
+INCLUDE=-I XX_PREFIX_XX/include
+LOOKUP_INCLUDE=XX_MYSQL_INCLUDE_XX XX_PGSQL_INCLUDE_XX XX_LDAP_INCLUDE_XX
+LOOKUP_LIBS=XX_MYSQL_LIBS_XX XX_PGSQL_LIBS_XX XX_LDAP_LIBS_XX
# If you have set LDAP=yes, you should set LDAP_LIB_TYPE to indicate which LDAP
# library you have. Unfortunately, though most of their functions are the
@@ -365,6 +367,7 @@
@@ -365,6 +368,7 @@
# LDAP_LIB_TYPE=OPENLDAP2
# LDAP_LIB_TYPE=NETSCAPE
# LDAP_LIB_TYPE=SOLARIS
@ -89,7 +90,7 @@
# If you don't set any of these, Exim assumes the original University of
# Michigan (OpenLDAP 1) library.
@@ -411,7 +414,7 @@
@@ -411,7 +415,7 @@
# the file name, allowing sites that run two separate daemons to distinguish
# them. Some installations may want something like this
@ -98,7 +99,7 @@
# If PID_FILE_PATH is not defined, Exim writes a file in its spool directory
# (see SPOOL_DIRECTORY below) with the name "exim-daemon.pid" for the standard
@@ -460,7 +463,7 @@
@@ -460,7 +464,7 @@
# uid and gid.
# Many installations will want something like this:
@ -107,7 +108,7 @@
# Others may prefer to keep all Exim things under one directory:
# SPOOL_DIRECTORY=/usr/exim/spool
@@ -525,7 +528,7 @@
@@ -525,7 +529,7 @@
# with TLS support.
# SUPPORT_TLS=yes
@ -116,7 +117,7 @@
# If you are running Exim as a server, note that just building it with TLS
# support is not usually all you need to do. You normally need to set up a
@@ -575,5 +578,14 @@
@@ -575,5 +579,14 @@
# chapter on building and installing Exim.
# USE_TCP_WRAPPERS=yes

View file

@ -72,16 +72,17 @@
# which results in files with names /var/log/exim_mainlog, etc. The directory
# in which the log files are placed must exist; Exim does not try to create
@@ -352,6 +352,8 @@
@@ -352,6 +352,9 @@
# LOOKUP_INCLUDE=-I /usr/local/ldap/include -I /usr/local/mysql/include -I /usr/local/pgsql/include
# LOOKUP_LIBS=-L/usr/local/lib -lldap -llber -lmysqlclient -lpq
+INCLUDE=-I XX_PREFIX_XX/include
+LOOKUP_INCLUDE=XX_MYSQL_INCLUDE_XX XX_PGSQL_INCLUDE_XX XX_LDAP_INCLUDE_XX
+LOOKUP_LIBS=XX_MYSQL_LIBS_XX XX_PGSQL_LIBS_XX XX_LDAP_LIBS_XX
# If you have set LDAP=yes, you should set LDAP_LIB_TYPE to indicate which LDAP
# library you have. Unfortunately, though most of their functions are the
@@ -365,6 +367,7 @@
@@ -365,6 +368,7 @@
# LDAP_LIB_TYPE=OPENLDAP2
# LDAP_LIB_TYPE=NETSCAPE
# LDAP_LIB_TYPE=SOLARIS
@ -89,7 +90,7 @@
# If you don't set any of these, Exim assumes the original University of
# Michigan (OpenLDAP 1) library.
@@ -411,7 +414,7 @@
@@ -411,7 +415,7 @@
# the file name, allowing sites that run two separate daemons to distinguish
# them. Some installations may want something like this
@ -98,7 +99,7 @@
# If PID_FILE_PATH is not defined, Exim writes a file in its spool directory
# (see SPOOL_DIRECTORY below) with the name "exim-daemon.pid" for the standard
@@ -460,7 +463,7 @@
@@ -460,7 +464,7 @@
# uid and gid.
# Many installations will want something like this:
@ -107,7 +108,7 @@
# Others may prefer to keep all Exim things under one directory:
# SPOOL_DIRECTORY=/usr/exim/spool
@@ -525,7 +528,7 @@
@@ -525,7 +529,7 @@
# with TLS support.
# SUPPORT_TLS=yes
@ -116,7 +117,7 @@
# If you are running Exim as a server, note that just building it with TLS
# support is not usually all you need to do. You normally need to set up a
@@ -575,5 +578,14 @@
@@ -575,5 +579,14 @@
# chapter on building and installing Exim.
# USE_TCP_WRAPPERS=yes