Update to Ogg Vorbis 1.0.1.
Major user-visible change: vorbis-tools now integrates some support for flac and speex files.
This commit is contained in:
parent
325e1c0c01
commit
4a8a94afaf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=96268
22 changed files with 152 additions and 108 deletions
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= flac
|
||||
PORTVERSION= 1.1.0
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -16,7 +16,7 @@ MAINTAINER= naddy@FreeBSD.org
|
|||
COMMENT= Free lossless audio codec
|
||||
|
||||
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
|
||||
ogg.4:${PORTSDIR}/audio/libogg
|
||||
ogg.5:${PORTSDIR}/audio/libogg
|
||||
|
||||
.if ${MACHINE_ARCH} == "i386"
|
||||
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
|
||||
|
|
|
@ -6,19 +6,16 @@
|
|||
#
|
||||
|
||||
PORTNAME= libogg
|
||||
PORTVERSION= 1.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.1
|
||||
PORTEPOCH= 3
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.vorbis.com/files/1.0/unix/ \
|
||||
ftp://ftp.wiles.org/pub/mirrors/Vorbis/unix/ \
|
||||
http://www.casterclub.com/vorbis/unix/ \
|
||||
http://www.math.utoledo.edu/~chaese/Vorbis/unix/
|
||||
MASTER_SITES= http://www.vorbis.com/files/1.0.1/unix/
|
||||
|
||||
MAINTAINER= naddy@FreeBSD.org
|
||||
COMMENT= Ogg bitstream library
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
USE_GNOME= gnomehack
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.if defined(NOPORTDOCS)
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (libogg-1.0.tar.gz) = 382a7089f42e6f82e7d658c1cb8ee236
|
||||
MD5 (libogg-1.1.tar.gz) = 461d7097bf47864b872085a94ff94e10
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- configure.orig Fri Jul 19 16:13:10 2002
|
||||
+++ configure Sat Oct 5 17:51:53 2002
|
||||
@@ -5363,6 +5363,7 @@
|
||||
--- configure.orig Mon Nov 17 17:34:08 2003
|
||||
+++ configure Mon Nov 24 18:26:28 2003
|
||||
@@ -7793,6 +7793,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
|
@ -11,25 +11,23 @@ $FreeBSD$
|
|||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
||||
@@ -5388,7 +5389,7 @@
|
||||
@@ -7818,7 +7819,7 @@
|
||||
;;
|
||||
*)
|
||||
DEBUG="-g"
|
||||
- CFLAGS="-O"
|
||||
+ CFLAGS=""
|
||||
PROFILE="-g -p"
|
||||
PROFILE="-g -p"
|
||||
;;
|
||||
esac
|
||||
@@ -5410,9 +5411,9 @@
|
||||
PROFILE="-fno-common -O4 -Wall -pg -g -fsigned-char -ffast-math"
|
||||
@@ -7841,8 +7842,8 @@
|
||||
;;
|
||||
*)
|
||||
- DEBUG="-g -Wall -fsigned-char"
|
||||
DEBUG="-g -Wall -fsigned-char"
|
||||
- CFLAGS="-O20 -fsigned-char"
|
||||
- PROFILE="-O20 -g -pg -fsigned-char"
|
||||
+ DEBUG="-g -Wall"
|
||||
+ CFLAGS=""
|
||||
+ PROFILE="-g -pg"
|
||||
- PROFILE="-O20 -g -pg -fsigned-char"
|
||||
+ CFLAGS="-fsigned-char"
|
||||
+ PROFILE="-g -pg -fsigned-char"
|
||||
;;
|
||||
esac
|
||||
fi
|
||||
|
|
43
audio/libogg/files/patch-src_bitwise.c
Normal file
43
audio/libogg/files/patch-src_bitwise.c
Normal file
|
@ -0,0 +1,43 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- src/bitwise.c.orig Mon Nov 10 14:06:08 2003
|
||||
+++ src/bitwise.c Sun Dec 7 02:36:26 2003
|
||||
@@ -251,7 +251,8 @@
|
||||
/* Read in bits without advancing the bitptr; bits <= 32 */
|
||||
long oggpackB_look(oggpack_buffer *b,int bits){
|
||||
unsigned long ret;
|
||||
- int m=32-bits;
|
||||
+ unsigned long m=mask[bits];
|
||||
+ int s=32-bits;
|
||||
|
||||
bits+=b->endbit;
|
||||
|
||||
@@ -272,7 +273,7 @@
|
||||
}
|
||||
}
|
||||
}
|
||||
- return (ret>>(m>>1))>>((m+1)>>1);
|
||||
+ return ((ret>>(s>>1))>>((s+1)>>1)&m);
|
||||
}
|
||||
|
||||
long oggpack_look1(oggpack_buffer *b){
|
||||
@@ -347,7 +348,8 @@
|
||||
/* bits <= 32 */
|
||||
long oggpackB_read(oggpack_buffer *b,int bits){
|
||||
unsigned long ret;
|
||||
- long m=32-bits;
|
||||
+ unsigned long m=mask[bits];
|
||||
+ long s=32-bits;
|
||||
|
||||
bits+=b->endbit;
|
||||
|
||||
@@ -369,7 +371,7 @@
|
||||
}
|
||||
}
|
||||
}
|
||||
- ret=(ret>>(m>>1))>>((m+1)>>1);
|
||||
+ ret=((ret>>(s>>1))>>((s+1)>>1)&m);
|
||||
|
||||
overflow:
|
||||
|
|
@ -4,7 +4,8 @@ include/ogg/ogg.h
|
|||
include/ogg/os_types.h
|
||||
lib/libogg.a
|
||||
lib/libogg.so
|
||||
lib/libogg.so.4
|
||||
lib/libogg.so.5
|
||||
libdata/pkgconfig/ogg.pc
|
||||
share/aclocal/ogg.m4
|
||||
%%PORTDOCS%%%%DOCSDIR%%/framing.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.html
|
||||
|
@ -33,9 +34,11 @@ share/aclocal/ogg.m4
|
|||
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_init.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_packetin.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_packetout.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_packetpeek.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_pagein.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_pageout.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_reset.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_reset_serialno.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_stream_state.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_sync_buffer.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/ogg_sync_clear.html
|
||||
|
@ -59,15 +62,21 @@ share/aclocal/ogg.m4
|
|||
%%PORTDOCS%%%%DOCSDIR%%/ogg/oggpack_readinit.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/oggpack_reset.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/oggpack_write.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/oggpack_writealign.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/oggpack_writeclear.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/oggpack_writecopy.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/oggpack_writeinit.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/oggpack_writetrunc.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/overview.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/reference.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/style.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/vorbis_comment.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ogg/vorbis_info.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/oggstream.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rfc3533.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rfc3534.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/stream.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisword2.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/white-ogg.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/white-xifish.png
|
||||
@dirrm include/ogg
|
||||
|
|
|
@ -6,21 +6,18 @@
|
|||
#
|
||||
|
||||
PORTNAME= libvorbis
|
||||
PORTVERSION= 1.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.0.1
|
||||
PORTEPOCH= 3
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.vorbis.com/files/1.0/unix/ \
|
||||
ftp://ftp.wiles.org/pub/mirrors/Vorbis/unix/ \
|
||||
http://www.casterclub.com/vorbis/unix/ \
|
||||
http://www.math.utoledo.edu/~chaese/Vorbis/unix/
|
||||
MASTER_SITES= http://www.vorbis.com/files/1.0.1/unix/
|
||||
|
||||
MAINTAINER= naddy@FreeBSD.org
|
||||
COMMENT= Audio compression codec library
|
||||
|
||||
LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg
|
||||
LIB_DEPENDS= ogg.5:${PORTSDIR}/audio/libogg
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
USE_GNOME= gnomehack
|
||||
CONFIGURE_ARGS= --with-ogg=${LOCALBASE}
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (libvorbis-1.0.tar.gz) = d1ad94fe8e240269c790e18992171e53
|
||||
MD5 (libvorbis-1.0.1.tar.gz) = 4d6726fd02ce02f6e24824e594b0949a
|
||||
|
|
|
@ -1,12 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
--- Makefile.in.orig Tue Jul 17 02:38:23 2001
|
||||
+++ Makefile.in Tue Jul 17 02:40:02 2001
|
||||
@@ -87,7 +87,7 @@ pthread_lib = @pthread_lib@
|
||||
|
||||
--- Makefile.in.orig Sun Dec 7 04:04:51 2003
|
||||
+++ Makefile.in Sun Dec 7 04:08:24 2003
|
||||
@@ -106,7 +106,7 @@
|
||||
|
||||
AUTOMAKE_OPTIONS = foreign dist-zip
|
||||
|
||||
-SUBDIRS = lib include doc examples win32 debian vq
|
||||
+SUBDIRS = lib include $(DOC) examples win32 debian vq
|
||||
+SUBDIRS = lib include $(DOC)
|
||||
|
||||
m4datadir = $(datadir)/aclocal
|
||||
m4datadir = $(prefix)/share/aclocal
|
||||
m4data_DATA = vorbis.m4
|
||||
|
|
|
@ -18,4 +18,4 @@ This package contains:
|
|||
- libvorbisenc, a BSD-license library that provides a simple,
|
||||
programmatic encoding setup interface.
|
||||
|
||||
WWW: http://www.xiph.org/ogg/
|
||||
WWW: http://www.xiph.org/ogg/vorbis/
|
||||
|
|
|
@ -4,16 +4,19 @@ include/vorbis/vorbisenc.h
|
|||
include/vorbis/vorbisfile.h
|
||||
lib/libvorbis.a
|
||||
lib/libvorbis.so
|
||||
lib/libvorbis.so.2
|
||||
lib/libvorbis.so.3
|
||||
lib/libvorbisenc.a
|
||||
lib/libvorbisenc.so
|
||||
lib/libvorbisenc.so.2
|
||||
lib/libvorbisfile.a
|
||||
lib/libvorbisfile.so
|
||||
lib/libvorbisfile.so.3
|
||||
lib/libvorbisfile.so.4
|
||||
libdata/pkgconfig/vorbis.pc
|
||||
libdata/pkgconfig/vorbisenc.pc
|
||||
libdata/pkgconfig/vorbisfile.pc
|
||||
share/aclocal/vorbis.m4
|
||||
%%PORTDOCS%%%%DOCSDIR%%/components.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/draft-moffitt-vorbis-rtp-00.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/draft-kerr-avt-vorbis-rtp-02.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/eightphase.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/evenlsp.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/floor1-1.png
|
||||
|
@ -41,14 +44,6 @@ share/aclocal/vorbis.m4
|
|||
%%PORTDOCS%%%%DOCSDIR%%/vorbis-clip.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbis-errors.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbis-fidelity.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbis-ogg.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbis-spec-bitpack.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbis-spec-codebook.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbis-spec-floor0.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbis-spec-floor1.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbis-spec-intro.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbis-spec-ref.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbis-spec-res.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbis.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisenc/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisenc/overview.html
|
||||
|
@ -59,8 +54,10 @@ share/aclocal/vorbis.m4
|
|||
%%PORTDOCS%%%%DOCSDIR%%/vorbisenc/vorbis_encode_init_vbr.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisenc/vorbis_info.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/OggVorbis_File.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/callbacks.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/chaining_example_c.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/chainingexample.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/crosslap.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/datastructures.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/decoding.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/example.html
|
||||
|
@ -73,13 +70,18 @@ share/aclocal/vorbis.m4
|
|||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_callbacks.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_clear.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_comment.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_crosslap.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_info.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_open.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_open_callbacks.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_pcm_seek.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_pcm_seek_lap.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_pcm_seek_page.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_pcm_seek_page_lap.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_pcm_tell.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_pcm_total.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_raw_seek.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_raw_seek_lap.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_raw_tell.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_raw_total.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_read.html
|
||||
|
@ -91,15 +93,21 @@ share/aclocal/vorbis.m4
|
|||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_test_callbacks.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_test_open.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_time_seek.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_time_seek_lap.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_time_seek_page.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_time_seek_page_lap.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_time_tell.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/ov_time_total.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/overview.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/reference.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/return.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/seekexample.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/seeking.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/seeking_example_c.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/seeking_test_c.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/style.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/seekingexample.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/style.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/threads.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/vorbis_comment.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/vorbis_info.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/vorbisfile/vorbisfile_example_c.html
|
||||
|
|
|
@ -8,6 +8,7 @@
|
|||
|
||||
PORTNAME= speex
|
||||
PORTVERSION= 1.0.3
|
||||
PORTREVISION= 1
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.speex.org/download/
|
||||
|
@ -16,7 +17,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
|
|||
MAINTAINER= jre@vineyard.net
|
||||
COMMENT= An open-source patent-free voice codec
|
||||
|
||||
LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg
|
||||
LIB_DEPENDS= ogg.5:${PORTSDIR}/audio/libogg
|
||||
|
||||
USE_GETOPT_LONG= yes
|
||||
USE_REINPLACE= yes
|
||||
|
|
|
@ -8,6 +8,7 @@
|
|||
|
||||
PORTNAME= speex
|
||||
PORTVERSION= 1.0.3
|
||||
PORTREVISION= 1
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.speex.org/download/
|
||||
|
@ -16,7 +17,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
|
|||
MAINTAINER= jre@vineyard.net
|
||||
COMMENT= An open-source patent-free voice codec
|
||||
|
||||
LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg
|
||||
LIB_DEPENDS= ogg.5:${PORTSDIR}/audio/libogg
|
||||
|
||||
USE_GETOPT_LONG= yes
|
||||
USE_REINPLACE= yes
|
||||
|
|
|
@ -6,22 +6,20 @@
|
|||
#
|
||||
|
||||
PORTNAME= vorbis-tools
|
||||
PORTVERSION= 1.0
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 1.0.1
|
||||
PORTEPOCH= 3
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.vorbis.com/files/1.0/unix/ \
|
||||
ftp://ftp.wiles.org/pub/mirrors/Vorbis/unix/ \
|
||||
http://www.casterclub.com/vorbis/unix/ \
|
||||
http://www.math.utoledo.edu/~chaese/Vorbis/unix/
|
||||
MASTER_SITES= http://www.vorbis.com/files/1.0.1/unix/
|
||||
|
||||
MAINTAINER= naddy@FreeBSD.org
|
||||
COMMENT= Play, encode, and manage Ogg Vorbis files
|
||||
|
||||
LIB_DEPENDS= ao.3:${PORTSDIR}/audio/libao \
|
||||
curl.2:${PORTSDIR}/ftp/curl \
|
||||
FLAC.5:${PORTSDIR}/audio/flac \
|
||||
intl.5:${PORTSDIR}/devel/gettext \
|
||||
vorbis.2:${PORTSDIR}/audio/libvorbis
|
||||
speex.2:${PORTSDIR}/audio/speex \
|
||||
vorbis.3:${PORTSDIR}/audio/libvorbis
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (vorbis-tools-1.0.tar.gz) = c0a9fee54835e9c5b32d1f42c02964c9
|
||||
MD5 (vorbis-tools-1.0.1.tar.gz) = 80d3ae3bbae2a488d433d86b8fd64777
|
||||
|
|
|
@ -1,14 +1,23 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- ogg123/Makefile.in.orig Tue Aug 14 19:42:20 2001
|
||||
+++ ogg123/Makefile.in Tue Aug 14 19:42:31 2001
|
||||
@@ -323,7 +323,7 @@
|
||||
install-exec-am: install-binPROGRAMS
|
||||
install-exec: install-exec-am
|
||||
--- ogg123/Makefile.in.orig Mon Nov 17 17:50:56 2003
|
||||
+++ ogg123/Makefile.in Sun Dec 14 00:27:38 2003
|
||||
@@ -135,7 +135,7 @@
|
||||
|
||||
-install-data-am: install-man install-docDATA
|
||||
AUTOMAKE_OPTIONS = foreign
|
||||
localedir = $(datadir)/locale
|
||||
-DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
|
||||
+DEFS = -DSYSCONFDIR=\"$(sysconfdir)\" -DLOCALEDIR=\"$(localedir)\" @DEFS@
|
||||
|
||||
docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
|
||||
|
||||
@@ -486,7 +486,7 @@
|
||||
|
||||
info-am:
|
||||
|
||||
-install-data-am: install-docDATA install-man
|
||||
+install-data-am: install-man
|
||||
install-data: install-data-am
|
||||
|
||||
install-am: all-am
|
||||
install-exec-am: install-binPROGRAMS
|
||||
|
||||
|
|
14
audio/vorbis-tools/files/patch-ogg123_cfgfile__options.c
Normal file
14
audio/vorbis-tools/files/patch-ogg123_cfgfile__options.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- ogg123/cfgfile_options.c.orig Sun Dec 14 00:26:21 2003
|
||||
+++ ogg123/cfgfile_options.c Sun Dec 14 00:26:41 2003
|
||||
@@ -441,7 +441,7 @@
|
||||
char filename[FILENAME_MAX];
|
||||
char *homedir = getenv("HOME");
|
||||
|
||||
- parse_config_file(opts, "/etc/ogg123rc");
|
||||
+ parse_config_file(opts, SYSCONFDIR "/ogg123rc");
|
||||
if (homedir && strlen(homedir) < FILENAME_MAX - 10) {
|
||||
/* Try ~/.ogg123 */
|
||||
strncpy(filename, homedir, FILENAME_MAX);
|
|
@ -1,13 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- oggdec/oggdec.c.orig Mon Sep 23 13:20:52 2002
|
||||
+++ oggdec/oggdec.c Mon Sep 23 13:21:04 2002
|
||||
@@ -99,6 +99,7 @@
|
||||
break;
|
||||
case 'o':
|
||||
outfilename = strdup(optarg);
|
||||
+ break;
|
||||
case 'R':
|
||||
raw = atoi(optarg);
|
||||
break;
|
|
@ -1,14 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- ogginfo/ogginfo2.c.orig Tue Jun 17 01:19:29 2003
|
||||
+++ ogginfo/ogginfo2.c Tue Jun 17 01:20:35 2003
|
||||
@@ -27,7 +27,7 @@
|
||||
#ifdef _WIN32
|
||||
#define INT64FORMAT "%I64d"
|
||||
#else
|
||||
-#define INT64FORMAT "%Ld"
|
||||
+#define INT64FORMAT "%lld"
|
||||
#endif
|
||||
|
||||
struct vorbis_release {
|
|
@ -1,14 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- vcut/vcut.c.orig Tue Jun 17 01:19:13 2003
|
||||
+++ vcut/vcut.c Tue Jun 17 01:20:27 2003
|
||||
@@ -26,7 +26,7 @@
|
||||
#ifdef _WIN32
|
||||
#define FORMAT_INT64 "%I64d"
|
||||
#else
|
||||
-#define FORMAT_INT64 "%Ld"
|
||||
+#define FORMAT_INT64 "%lld"
|
||||
#endif
|
||||
|
||||
static vcut_packet *save_packet(ogg_packet *packet)
|
|
@ -10,4 +10,4 @@ patent concerns.
|
|||
This package contains utilities to encode, decode, and cut vorbis
|
||||
streams, and to add comments to them.
|
||||
|
||||
WWW: http://www.vorbis.com/
|
||||
WWW: http://www.xiph.org/ogg/vorbis/
|
||||
|
|
|
@ -6,7 +6,15 @@ bin/ogginfo
|
|||
bin/vcut
|
||||
bin/vorbiscomment
|
||||
share/examples/vorbis-tools/ogg123rc
|
||||
share/locale/be/LC_MESSAGES/vorbis-tools.mo
|
||||
share/locale/cs/LC_MESSAGES/vorbis-tools.mo
|
||||
share/locale/da/LC_MESSAGES/vorbis-tools.mo
|
||||
share/locale/es/LC_MESSAGES/vorbis-tools.mo
|
||||
share/locale/fr/LC_MESSAGES/vorbis-tools.mo
|
||||
share/locale/hr/LC_MESSAGES/vorbis-tools.mo
|
||||
share/locale/hu/LC_MESSAGES/vorbis-tools.mo
|
||||
share/locale/nl/LC_MESSAGES/vorbis-tools.mo
|
||||
share/locale/ro/LC_MESSAGES/vorbis-tools.mo
|
||||
share/locale/ru/LC_MESSAGES/vorbis-tools.mo
|
||||
share/locale/sv/LC_MESSAGES/vorbis-tools.mo
|
||||
@dirrm share/examples/vorbis-tools
|
||||
|
|
Loading…
Reference in a new issue