Depend on sqlite3
Not found by: port test Find a more general way to determine the python path. Approved by: edwin@ (mentor) MFC after: 3 weeks
This commit is contained in:
parent
e572f8e2db
commit
4a9e8bde3c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=402471
2 changed files with 4 additions and 3 deletions
|
@ -3,7 +3,7 @@
|
|||
|
||||
PORTNAME= hugin
|
||||
PORTVERSION= 2015.0.0
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
|
||||
|
||||
|
@ -16,6 +16,7 @@ LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
|
|||
libexiv2.so:${PORTSDIR}/graphics/exiv2 \
|
||||
liblensfun.so:${PORTSDIR}/graphics/lensfun \
|
||||
libpano13.so:${PORTSDIR}/graphics/libpano13 \
|
||||
libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
|
||||
libvigraimpex.so:${PORTSDIR}/graphics/vigra \
|
||||
libpng.so:${PORTSDIR}/graphics/png \
|
||||
libtiff.so:${PORTSDIR}/graphics/tiff
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- src/hugin_script_interface/CMakeLists.txt~ 2015-07-18 02:44:01.000000000 +1000
|
||||
+++ src/hugin_script_interface/CMakeLists.txt 2015-11-23 13:02:39.000000000 +1100
|
||||
+++ src/hugin_script_interface/CMakeLists.txt 2015-11-24 12:49:59.000000000 +1100
|
||||
@@ -201,7 +201,7 @@
|
||||
# Linux/MacOS
|
||||
# install Python related files into folder depending on used Python version
|
||||
|
||||
- EXECUTE_PROCESS( COMMAND ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))"
|
||||
+ EXECUTE_PROCESS( COMMAND ${PYTHON_EXECUTABLE} -c "import string; from distutils.sysconfig import get_python_lib; print(string.replace (get_python_lib(1), \"/usr/local/\", \"\"))"
|
||||
+ EXECUTE_PROCESS( COMMAND ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1).replace(\"/usr/local/\", \"\"))"
|
||||
OUTPUT_VARIABLE pyinstalldir
|
||||
OUTPUT_STRIP_TRAILING_WHITESPACE)
|
||||
|
||||
|
|
Loading…
Reference in a new issue