- Update to version 0.3.3
PR: 58620 Submitted by: Ports Fury
This commit is contained in:
parent
ff7e1738b0
commit
4aa2131924
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=92481
9 changed files with 104 additions and 26 deletions
|
@ -7,8 +7,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= libcomprex
|
||||
PORTVERSION= 0.3.2
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.3.3
|
||||
CATEGORIES= archivers
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= gnupdate
|
||||
|
@ -17,18 +16,19 @@ MAINTAINER= ports@FreeBSD.org
|
|||
COMMENT= Transparently handles automatic compression and decompression of files
|
||||
|
||||
LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
|
||||
curl.2:${PORTSDIR}/ftp/curl \
|
||||
ltdl.4:${PORTSDIR}/devel/libltdl
|
||||
|
||||
ltdl.4:${PORTSDIR}/devel/libltdl \
|
||||
curl.2:${PORTSDIR}/ftp/curl
|
||||
.if !exists(/usr/bin/bzip2)
|
||||
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
|
||||
.endif
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNOME= gnomehack gnometarget pkgconfig
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
|
||||
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lintl"
|
||||
LIBTOOLFLAGS= # none
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -lintl"
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.include "Makefile.man"
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,13 +1,14 @@
|
|||
MAN1+= comprex-config.1
|
||||
MAN3+= cxApplyFsNodeInfo.3
|
||||
MAN3+= cxCleanup.3
|
||||
MAN3+= cxCleanupModules.3
|
||||
MAN3+= cxClearErr.3
|
||||
MAN3+= cxClose.3
|
||||
MAN3+= cxCloseArchive.3
|
||||
MAN3+= cxCloseFile.3
|
||||
MAN3+= cxDestroyArchive.3
|
||||
MAN3+= cxDestroyDirectory.3
|
||||
MAN3+= cxDestroyFile.3
|
||||
MAN3+= cxDestroyFsIterator.3
|
||||
MAN3+= cxDestroyFsNode.3
|
||||
MAN3+= cxDirAddFile.3
|
||||
MAN3+= cxDirAddSubDir.3
|
||||
|
@ -15,8 +16,11 @@ MAN3+= cxDirRemoveFile.3
|
|||
MAN3+= cxDirRemoveSubDir.3
|
||||
MAN3+= cxEof.3
|
||||
MAN3+= cxError.3
|
||||
MAN3+= cxExtractArchive.3
|
||||
MAN3+= cxExtractFile.3
|
||||
MAN3+= cxFixPath.3
|
||||
MAN3+= cxGetArchiveAccessMode.3
|
||||
MAN3+= cxGetArchiveFileCount.3
|
||||
MAN3+= cxGetArchiveFileName.3
|
||||
MAN3+= cxGetArchiveFileSize.3
|
||||
MAN3+= cxGetArchiveModule.3
|
||||
|
@ -28,8 +32,14 @@ MAN3+= cxGetArchiveType.3
|
|||
MAN3+= cxGetBaseName.3
|
||||
MAN3+= cxGetBasePath.3
|
||||
MAN3+= cxGetDirArchive.3
|
||||
MAN3+= cxGetDirDate.3
|
||||
MAN3+= cxGetDirGid.3
|
||||
MAN3+= cxGetDirMode.3
|
||||
MAN3+= cxGetDirName.3
|
||||
MAN3+= cxGetDirParent.3
|
||||
MAN3+= cxGetDirPath.3
|
||||
MAN3+= cxGetDirPhysicalPath.3
|
||||
MAN3+= cxGetDirUid.3
|
||||
MAN3+= cxGetDirectory.3
|
||||
MAN3+= cxGetFile.3
|
||||
MAN3+= cxGetFileArchive.3
|
||||
|
@ -43,12 +53,14 @@ MAN3+= cxGetFileParent.3
|
|||
MAN3+= cxGetFilePath.3
|
||||
MAN3+= cxGetFilePhysicalPath.3
|
||||
MAN3+= cxGetFileSize.3
|
||||
MAN3+= cxGetFileType.3
|
||||
MAN3+= cxGetFileUid.3
|
||||
MAN3+= cxGetFirstFile.3
|
||||
MAN3+= cxGetFirstModule.3
|
||||
MAN3+= cxGetFirstSubDir.3
|
||||
MAN3+= cxGetFpAccessMode.3
|
||||
MAN3+= cxGetFsIterFirst.3
|
||||
MAN3+= cxGetFsIterNext.3
|
||||
MAN3+= cxGetFsIterPrev.3
|
||||
MAN3+= cxGetFsNodeArchive.3
|
||||
MAN3+= cxGetFsNodeDate.3
|
||||
MAN3+= cxGetFsNodeGid.3
|
||||
|
@ -62,18 +74,26 @@ MAN3+= cxGetFullFilePath.3
|
|||
MAN3+= cxGetModule.3
|
||||
MAN3+= cxGetNextDir.3
|
||||
MAN3+= cxGetNextFile.3
|
||||
MAN3+= cxGetNextFsNode.3
|
||||
MAN3+= cxGetPreviousDir.3
|
||||
MAN3+= cxGetPreviousFile.3
|
||||
MAN3+= cxGetPreviousFsNode.3
|
||||
MAN3+= cxGetSubDirCount.3
|
||||
MAN3+= cxGets.3
|
||||
MAN3+= cxIsArchiveLocal.3
|
||||
MAN3+= cxIsDirLocal.3
|
||||
MAN3+= cxIsFileLocal.3
|
||||
MAN3+= cxIsFsNodeLocal.3
|
||||
MAN3+= cxLinkModule.3
|
||||
MAN3+= cxLoadModule.3
|
||||
MAN3+= cxMakeFile.3
|
||||
MAN3+= cxMakePhysDirs.3
|
||||
MAN3+= cxMkDir.3
|
||||
MAN3+= cxNewArchive.3
|
||||
MAN3+= cxNewDirectory.3
|
||||
MAN3+= cxNewFile.3
|
||||
MAN3+= cxNewFp.3
|
||||
MAN3+= cxNewFsIterator.3
|
||||
MAN3+= cxNewFsNode.3
|
||||
MAN3+= cxOpenArchive.3
|
||||
MAN3+= cxOpenArchiveBuffer.3
|
||||
|
@ -89,6 +109,7 @@ MAN3+= cxRewind.3
|
|||
MAN3+= cxSaveArchive.3
|
||||
MAN3+= cxSeek.3
|
||||
MAN3+= cxSetArchiveAccessMode.3
|
||||
MAN3+= cxSetArchiveExtractCallback.3
|
||||
MAN3+= cxSetArchiveFileName.3
|
||||
MAN3+= cxSetArchiveFileSize.3
|
||||
MAN3+= cxSetArchiveLocal.3
|
||||
|
@ -99,8 +120,14 @@ MAN3+= cxSetArchiveSize.3
|
|||
MAN3+= cxSetArchiveType.3
|
||||
MAN3+= cxSetCloseFunc.3
|
||||
MAN3+= cxSetDirArchive.3
|
||||
MAN3+= cxSetDirDate.3
|
||||
MAN3+= cxSetDirGid.3
|
||||
MAN3+= cxSetDirLocal.3
|
||||
MAN3+= cxSetDirMode.3
|
||||
MAN3+= cxSetDirName.3
|
||||
MAN3+= cxSetDirParent.3
|
||||
MAN3+= cxSetDirPhysicalPath.3
|
||||
MAN3+= cxSetDirUid.3
|
||||
MAN3+= cxSetError.3
|
||||
MAN3+= cxSetFileArchive.3
|
||||
MAN3+= cxSetFileCompressedSize.3
|
||||
|
@ -110,10 +137,8 @@ MAN3+= cxSetFileLocal.3
|
|||
MAN3+= cxSetFileMode.3
|
||||
MAN3+= cxSetFileName.3
|
||||
MAN3+= cxSetFileParent.3
|
||||
MAN3+= cxSetFilePath.3
|
||||
MAN3+= cxSetFilePhysicalPath.3
|
||||
MAN3+= cxSetFileSize.3
|
||||
MAN3+= cxSetFileType.3
|
||||
MAN3+= cxSetFileUid.3
|
||||
MAN3+= cxSetFpAccessMode.3
|
||||
MAN3+= cxSetFsNodeArchive.3
|
||||
|
@ -123,7 +148,6 @@ MAN3+= cxSetFsNodeLocal.3
|
|||
MAN3+= cxSetFsNodeMode.3
|
||||
MAN3+= cxSetFsNodeName.3
|
||||
MAN3+= cxSetFsNodeParent.3
|
||||
MAN3+= cxSetFsNodePath.3
|
||||
MAN3+= cxSetFsNodeType.3
|
||||
MAN3+= cxSetFsNodeUid.3
|
||||
MAN3+= cxSetReadFunc.3
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (libcomprex-0.3.2.tar.gz) = 638c41d7e41d9e5b0f9e1a58c2e8dadd
|
||||
MD5 (libcomprex-0.3.3.tar.gz) = f29e364600251420114b31d7dd3e47fe
|
||||
|
|
11
archivers/libcomprex/files/patch-Makefile.in
Normal file
11
archivers/libcomprex/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.in.orig Thu Mar 6 13:30:58 2003
|
||||
+++ Makefile.in Tue Oct 28 13:55:01 2003
|
||||
@@ -126,7 +126,7 @@
|
||||
modlibdir = @modlibdir@
|
||||
sedpath = @sedpath@
|
||||
|
||||
-@DYNAMIC_MODS_TRUE@LIBLTDLDIR = libltdl
|
||||
+@DYNAMIC_MODS_TRUE@LIBLTDLDIR =
|
||||
|
||||
SUBDIRS = debian docs intl $(LIBLTDLDIR) modules libcomprex po tests
|
||||
|
|
@ -1,10 +0,0 @@
|
|||
--- configure.orig Tue Jul 2 18:02:18 2002
|
||||
+++ configure Sat Jan 18 20:21:09 2003
|
||||
@@ -7334,6 +7334,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
21
archivers/libcomprex/files/patch-libcomprex::Makefile.in
Normal file
21
archivers/libcomprex/files/patch-libcomprex::Makefile.in
Normal file
|
@ -0,0 +1,21 @@
|
|||
--- libcomprex/Makefile.in.orig Thu Mar 6 13:33:01 2003
|
||||
+++ libcomprex/Makefile.in Tue Oct 28 13:56:41 2003
|
||||
@@ -161,7 +161,7 @@
|
||||
utils.c
|
||||
|
||||
|
||||
-libcomprex_la_LIBADD = @DLLDFLAGS@ $(LIBLTDL) $(STATIC_LINK_LIBS)
|
||||
+libcomprex_la_LIBADD = @DLLDFLAGS@ -lltdl $(STATIC_LINK_LIBS)
|
||||
|
||||
libcomprex_la_LDFLAGS = \
|
||||
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
|
||||
@@ -169,8 +169,7 @@
|
||||
|
||||
INCLUDES = \
|
||||
-I$(top_srcdir) \
|
||||
- -DCOMPREX_LIBDIR=\""$(libdir)/comprex"\" \
|
||||
- $(INCLTDL)
|
||||
+ -DCOMPREX_LIBDIR=\""$(libdir)/comprex"\"
|
||||
|
||||
subdir = libcomprex
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
15
archivers/libcomprex/files/patch-ltmain.sh
Normal file
15
archivers/libcomprex/files/patch-ltmain.sh
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- ltmain.sh.orig Tue Oct 28 22:12:34 2003
|
||||
+++ ltmain.sh Tue Oct 28 22:13:50 2003
|
||||
@@ -4330,10 +4330,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
13
archivers/libcomprex/files/patch-tests::extractarchive.c
Normal file
13
archivers/libcomprex/files/patch-tests::extractarchive.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- tests/extractarchive.c.orig Fri Dec 20 08:03:40 2002
|
||||
+++ tests/extractarchive.c Mon Jun 23 13:16:14 2003
|
||||
@@ -37,7 +37,9 @@
|
||||
void
|
||||
__extractprogress(CxArchive *archive, CxFile *file, size_t onFile, size_t fileCount)
|
||||
{
|
||||
- static int first_file = 0, last_file = 1;
|
||||
+ static int first_file, last_file;
|
||||
+ first_file = 0;
|
||||
+ last_file = 1;
|
||||
if (first_file++ == 0)
|
||||
fprintf(stdout, "Extracting archive: %s\n", cxGetArchiveFileName(archive));
|
||||
|
|
@ -1,5 +1,4 @@
|
|||
bin/comprex-config
|
||||
include/comprex.h
|
||||
include/libcomprex/archive.h
|
||||
include/libcomprex/archive_io.h
|
||||
include/libcomprex/comprex.h
|
||||
|
@ -14,13 +13,18 @@ include/libcomprex/types.h
|
|||
include/libcomprex/utils.h
|
||||
lib/comprex/archive/libar.so
|
||||
lib/comprex/archive/libbzip2.so
|
||||
lib/comprex/archive/libcab.so
|
||||
lib/comprex/archive/libcpio.so
|
||||
lib/comprex/archive/libtar.so
|
||||
lib/comprex/archive/libzip.so
|
||||
lib/comprex/archive/libzlib.so
|
||||
lib/comprex/scheme/libcurlscm.so
|
||||
lib/libcomprex.a
|
||||
lib/libcomprex.so
|
||||
lib/libcomprex.so.3
|
||||
libdata/pkgconfig/libcomprex.pc
|
||||
share/aclocal/libcomprex.m4
|
||||
share/locale/it/LC_MESSAGES/libcomprex.mo
|
||||
share/locale/nl/LC_MESSAGES/libcomprex.mo
|
||||
@dirrm lib/comprex/scheme
|
||||
@dirrm lib/comprex/archive
|
||||
|
|
Loading…
Reference in a new issue