Add fontconfig, an XML-based font configuration API for X.

This commit is contained in:
Joe Marcus Clarke 2002-10-06 20:56:30 +00:00
parent b11013ef42
commit 4aa34c64c5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=67502
9 changed files with 102 additions and 0 deletions

View file

@ -12,6 +12,7 @@
SUBDIR += bdfresize
SUBDIR += bitmap-fonts
SUBDIR += etlfonts
SUBDIR += fontconfig
SUBDIR += freefonts
SUBDIR += geminifonts
SUBDIR += getbdf

View file

@ -0,0 +1,35 @@
# New ports collection makefile for: fontconfig
# Date created: 06 October 2002
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= fontconfig
PORTVERSION= 2.0
CATEGORIES= x11-fonts
MASTER_SITES= http://fontconfig.org/release/
DISTNAME= fcpackage.${PORTVERSION:S/./_/}
MAINTAINER= gnome@FreeBSD.org
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
expat.4:${PORTSDIR}/textproc/expat2
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
USE_GMAKE= yes
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
CONFIGURE_ARGS= --with-confdir=${PREFIX}/etc/fonts \
--with-expat=${LOCALBASE} \
--with-default-fonts=${X11BASE}/lib/fonts
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${DISTNAME}/fontconfig
pre-patch:
@${REINPLACE_CMD} -e 's|[(]LIBDIR[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (fcpackage.2_0.tar.gz) = 5ef5c58e501b0cb873ee2b2a04ed74e3

View file

@ -0,0 +1,11 @@
--- config/Makedefs.in.orig Sun Oct 6 16:43:39 2002
+++ config/Makedefs.in Sun Oct 6 16:43:47 2002
@@ -65,7 +65,7 @@
CFLAGS=$(CDEBUGFLAGS) @DEFS@ $(FCPATH_DEF) $(INCLUDES)
LIBBASE=libfontconfig.so
-LIBFILE=$(LIBBASE).@PACKAGE_MAJOR@.@PACKAGE_MINOR@
+LIBFILE=$(LIBBASE).@PACKAGE_MAJOR@
LIBMAJOR=$(LIBBASE).@PACKAGE_MAJOR@
LIBFONTCONFIG=-L$(SRCDIR) -lfontconfig

View file

@ -0,0 +1,10 @@
--- fonts.conf.in.orig Sun Oct 6 16:37:34 2002
+++ fonts.conf.in Sun Oct 6 16:37:41 2002
@@ -21,7 +21,6 @@
-->
<dir>/usr/X11R6/lib/X11/fonts</dir>
- <dir>/usr/share/fonts</dir>
<dir>~/.fonts</dir>
<!-- FONTPATH_END -->

View file

@ -0,0 +1,13 @@
--- src/Makefile.in.orig Sun Oct 6 16:42:26 2002
+++ src/Makefile.in Sun Oct 6 16:42:42 2002
@@ -80,10 +80,6 @@
rm -f $@
$(MKSHLIB) $(OBJS) $(LIBS)
-$(LIBMAJOR): $(LIBFILE)
- rm -f $@
- $(LN_S) $(LIBFILE) $(LIBMAJOR)
-
$(LIBBASE): $(LIBMAJOR)
rm -f $@
$(LN_S) $(LIBMAJOR) $(LIBBASE)

View file

@ -0,0 +1 @@
An XML-based font configuration API for X Windows

View file

@ -0,0 +1,17 @@
Fontconfig does the following:
* discover new fonts when installed automatically, removing a common source of configuration problems.
* perform font name substitution, so that appropriate alternative fonts can
be selected if fonts are missing.
* identify the set of fonts required to completely cover a set of languages.
* have GUI configuration tools built as it uses an XML-based configuration
file (though with autodiscovery, we believe this need is minimized).
* efficiently and quickly find the fonts you need among the set of fonts
you have installed, even if you have installed thousands of fonts, while
minimzing memory usage.
* be used in concert with the X Render Extension and FreeType to implement
high quality, anti-aliased and subpixel rendered text on a display.
-- keithp
WWW: http://fontconfig.org/

View file

@ -0,0 +1,13 @@
bin/fc-cache
bin/fc-list
bin/fontconfig-config
etc/fonts/fonts.conf
etc/fonts/fonts.dtd
include/fontconfig/fcfreetype.h
include/fontconfig/fcprivate.h
include/fontconfig/fontconfig.h
lib/libfontconfig.so
lib/libfontconfig.so.1
libdata/pkgconfig/fontconfig.pc
@dirrm include/fontconfig
@dirrm etc/fonts