Remove expired leaf port:
2006-12-01 net-im/ymessenger: is a dynamically linked binary linked to old version of gtkhtml no longer in ports
This commit is contained in:
parent
a317e71b75
commit
4ac9184af2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=179727
8 changed files with 1 additions and 113 deletions
1
MOVED
1
MOVED
|
@ -2616,3 +2616,4 @@ multimedia/gstreamer-plugins-dirac80||2006-12-13|Has expired: Obsolete version,
|
|||
devel/ruby-pcsc-lite||2006-12-14|Has expired: Does not compile with new pcsc-lite. Port is broken since 2005/04/20.
|
||||
audio/alsaplayer||2006-12-14|Has expired: Remote code execution: http://vuxml.FreeBSD.org/9855ac8e-2aec-11db-a6e2-000e0c2e438a.html. Last version 0.99.76 is more than 3 years old.
|
||||
sysutils/kdar||2006-12-14|Has expired: Does not compile with dar-2.3.0
|
||||
net-im/ymessenger||2006-12-14|Has expired: is a dynamically linked binary linked to old version of gtkhtml no longer in ports
|
||||
|
|
|
@ -125,7 +125,6 @@
|
|||
SUBDIR += vicq
|
||||
SUBDIR += vqcc-gtk
|
||||
SUBDIR += wildfire
|
||||
SUBDIR += ymessenger
|
||||
SUBDIR += ysm
|
||||
|
||||
.include <bsd.port.subdir.mk>
|
||||
|
|
|
@ -1,66 +0,0 @@
|
|||
# ex:ts=8
|
||||
# Ports collection makefile for: yahoo-messenger
|
||||
# Date created: Sat Dec 16, 2000
|
||||
# Whom: David O'Brien (obrien@NUXI.com)
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= ymessenger
|
||||
PORTVERSION= 1.0.4
|
||||
PORTREVISION= 5
|
||||
PORTEPOCH= 20020902
|
||||
CATEGORIES= net-im
|
||||
MASTER_SITES= http://public.yahoo.com/~mmk/
|
||||
DISTNAME= fbsd5.${PORTNAME}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= sethk@meowfishies.com
|
||||
COMMENT= Yahoo! Messenger - Instant messaging client
|
||||
|
||||
IGNORE= is a dynamically linked binary linked to old version of gtkhtml no longer in ports
|
||||
DEPRECATED= ${IGNORE}
|
||||
EXPIRATION_DATE=2006-12-01
|
||||
|
||||
USE_GNOME= gtk12 gdkpixbuf
|
||||
NO_BUILD= yes
|
||||
NO_WRKSUBDIR= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 600000
|
||||
LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
IGNORE= does not run on FreeBSD 4.x
|
||||
.endif
|
||||
|
||||
ONLY_FOR_ARCHS= i386
|
||||
|
||||
GETTEXT_MAJOR= 6
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's:%%PREFIX%%:${PREFIX}:g' ${WRKDIR}/bin/ymessenger
|
||||
@${CHMOD} +w ${WRKDIR}/share/ymessenger/ymessenger.bin
|
||||
${ECHO} ${GETTEXT_MAJOR} | dd bs=1 count=1 conv=notrunc seek=43202 \
|
||||
of=${WRKDIR}/share/ymessenger/ymessenger.bin
|
||||
|
||||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKDIR}/bin/ymessenger ${PREFIX}/bin
|
||||
${MKDIR} ${PREFIX}/libexec/ymessenger
|
||||
${INSTALL_PROGRAM} ${WRKDIR}/share/ymessenger/ymessenger.bin \
|
||||
${PREFIX}/libexec/ymessenger
|
||||
@(set -x; for i in yahoo_gnome.png yahoo_kde.xpm \
|
||||
ymessenger.desktop ymessenger.kdelnk; do \
|
||||
${INSTALL_DATA} ${WRKDIR}/share/ymessenger/$$i \
|
||||
${PREFIX}/libexec/ymessenger; \
|
||||
done)
|
||||
${MKDIR} ${PREFIX}/lib/ymessenger
|
||||
${INSTALL_DATA} ${WRKDIR}/lib/libgtkhtml.so.6 \
|
||||
${PREFIX}/lib/ymessenger/
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,4 +0,0 @@
|
|||
MD5 (fbsd5.ymessenger.tgz) = d46390ff26cf5d01767d92efabecfc7e
|
||||
SHA256 (fbsd5.ymessenger.tgz) = 5a9b5d1fcc854b83567402ff67ad6dad0000c4c912d72f68c30352447578ef15
|
||||
SIZE (fbsd5.ymessenger.tgz) = 686647
|
||||
SIZE (fbsd4.ymessenger.tgz) = 933244
|
|
@ -1,10 +0,0 @@
|
|||
--- bin/ymessenger.orig Fri Oct 3 21:02:12 2003
|
||||
+++ bin/ymessenger Sat Jan 7 14:42:37 2006
|
||||
@@ -1,4 +1,4 @@
|
||||
#!/bin/sh
|
||||
-LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH
|
||||
-export LD_LIBRARY_PATH
|
||||
-exec /usr/local/share/ymessenger/ymessenger.bin $@
|
||||
+LD_LIBRARY_PATH=%%PREFIX%%/lib:$LD_LIBRARY_PATH
|
||||
+export LD_LIBRARY_PATH LD_PRELOAD
|
||||
+exec %%PREFIX%%/libexec/ymessenger/ymessenger.bin $@
|
|
@ -1,13 +0,0 @@
|
|||
Yahoo! Messenger for FreeBSD
|
||||
|
||||
Features:
|
||||
|
||||
Friend List - See when your friends are online and ready to talk.
|
||||
Instant Messages - Send private, instant messages to all your friends.
|
||||
Conferencing - Invite your friends to have private conversations
|
||||
Ignore List - Ignore any unwanted messages that you receive.
|
||||
Invisible Mode - Check your alerts and no one will know you're online!
|
||||
|
||||
For firewall support through SOCKS, use "runsocks" from the socks5 package.
|
||||
|
||||
WWW: http://messenger.yahoo.com/
|
|
@ -1,10 +0,0 @@
|
|||
****** Post-installation instructions: How to run Yahoo Messenger ******
|
||||
|
||||
In order to run ymessenger, you must add the following entries
|
||||
to /etc/libmap.conf:
|
||||
|
||||
[ymessenger.bin]
|
||||
libgtkhtml.so.6 ymessenger/libgtkhtml.so.6
|
||||
libintl.so.4 libintl.so.6
|
||||
|
||||
************************************************************************
|
|
@ -1,9 +0,0 @@
|
|||
bin/ymessenger
|
||||
libexec/ymessenger/ymessenger.bin
|
||||
libexec/ymessenger/yahoo_gnome.png
|
||||
libexec/ymessenger/yahoo_kde.xpm
|
||||
libexec/ymessenger/ymessenger.desktop
|
||||
libexec/ymessenger/ymessenger.kdelnk
|
||||
lib/ymessenger/libgtkhtml.so.6
|
||||
@dirrm lib/ymessenger
|
||||
@dirrm libexec/ymessenger
|
Loading…
Reference in a new issue