add rexx-wrapper 2.1

A tool that wraps Rexx source or tokenised code into an executable
This commit is contained in:
Ying-Chieh Liao 2003-11-09 17:18:50 +00:00
parent 372714d740
commit 4b0a82c391
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=93563
6 changed files with 108 additions and 0 deletions

View file

@ -182,6 +182,7 @@
SUBDIR += ratfor
SUBDIR += rexx-imc
SUBDIR += rexx-regina
SUBDIR += rexx-wrapper
SUBDIR += rscheme
SUBDIR += ruby-js
SUBDIR += ruby-lua

View file

@ -0,0 +1,27 @@
# ex:ts=8
# Ports collection makefile for: rexx-wrapper
# Date created: Nov 11, 2003
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= wrapper
PORTVERSION= 2.1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= rexx${PORTNAME}
PKGNAMEPREFIX= rexx-
DISTNAME= RexxWrapper-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A tool that wraps Rexx source or tokenised code into an executable
BUILD_DEPENDS= rexx:${PORTSDIR}/lang/rexx-regina
RUN_DEPENDS= rexx:${PORTSDIR}/lang/rexx-regina
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-rexx=regina
DATADIR= ${PREFIX}/share/rexx${PORTNAME}
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (RexxWrapper-2.1.tar.gz) = 7d7726e7fe42e34b9d960890dc2ef83b

View file

@ -0,0 +1,11 @@
--- Makefile.in.orig Mon Nov 10 01:14:00 2003
+++ Makefile.in Mon Nov 10 01:14:12 2003
@@ -213,7 +213,7 @@
install: all
$(INSTALL) -m 755 -d $(bindir)
- $(INSTALL) -m 755 -d $(prefix)/share/rexxwraper
+ $(INSTALL) -m 755 -d $(prefix)/share/rexxwrapper
$(INSTALL) -m 755 -c $(srcdir)/rexxwrapper-config $(bindir)/rexxwrapper-config
$(INSTALL) -m 755 -c rexxwrapper $(bindir)/rexxwrapper
@for distfile in $(BASEFILES) $(DESFILES) $(ZLIBFILES) $(COMMONFILES); do \

View file

@ -0,0 +1,10 @@
Rexx/Wrapper is a tool that wraps Rexx source or tokenised code into an
executable. The Rexx source code can be optionally compressed and encoded to
ensure that the original Rexx code cannot be viewed (unless you have the
original encryption key).
To use Rexx/Wrapper you need two extra bits of software:
1. A supported Rexx interpreter
2. A supported C compiler
WWW: http://rexxwrapper.sourceforge.net/

View file

@ -0,0 +1,58 @@
bin/rexxwrapper
bin/rexxwrapper-config
%%DATADIR%%/common/accommon.m4
%%DATADIR%%/common/defines.h
%%DATADIR%%/common/getopt.c
%%DATADIR%%/common/loader.c
%%DATADIR%%/common/rxdef.h
%%DATADIR%%/common/rxpack.c
%%DATADIR%%/common/rxpack.h
%%DATADIR%%/config.guess
%%DATADIR%%/config.h.in
%%DATADIR%%/config.sub
%%DATADIR%%/configur
%%DATADIR%%/defined_values.in
%%DATADIR%%/des/cbc_cksm.c
%%DATADIR%%/des/des.h
%%DATADIR%%/des/des_enc.c
%%DATADIR%%/des/des_locl.h
%%DATADIR%%/des/ecb_enc.c
%%DATADIR%%/des/podd.h
%%DATADIR%%/des/rand_key.c
%%DATADIR%%/des/set_key.c
%%DATADIR%%/des/sk.h
%%DATADIR%%/des/spr.h
%%DATADIR%%/des/str2key.c
%%DATADIR%%/install-sh
%%DATADIR%%/intbuild.c
%%DATADIR%%/rexxtok.c
%%DATADIR%%/rexxwrap.c
%%DATADIR%%/rexxwrap.cmd
%%DATADIR%%/rxdefines.h
%%DATADIR%%/zlib/adler32.c
%%DATADIR%%/zlib/compress.c
%%DATADIR%%/zlib/deflate.c
%%DATADIR%%/zlib/deflate.h
%%DATADIR%%/zlib/infblock.c
%%DATADIR%%/zlib/infblock.h
%%DATADIR%%/zlib/infcodes.c
%%DATADIR%%/zlib/infcodes.h
%%DATADIR%%/zlib/inffast.c
%%DATADIR%%/zlib/inffast.h
%%DATADIR%%/zlib/inffixed.h
%%DATADIR%%/zlib/inflate.c
%%DATADIR%%/zlib/inftrees.c
%%DATADIR%%/zlib/inftrees.h
%%DATADIR%%/zlib/infutil.c
%%DATADIR%%/zlib/infutil.h
%%DATADIR%%/zlib/trees.c
%%DATADIR%%/zlib/trees.h
%%DATADIR%%/zlib/uncompr.c
%%DATADIR%%/zlib/zconf.h
%%DATADIR%%/zlib/zlib.h
%%DATADIR%%/zlib/zutil.c
%%DATADIR%%/zlib/zutil.h
@dirrm %%DATADIR%%/common
@dirrm %%DATADIR%%/des
@dirrm %%DATADIR%%/zlib
@dirrm %%DATADIR%%