coWPAtty is designed to audit the security of pre-shared keys
(PSK) selected in WiFi Protected Access (WPA) networks. WWW: http://www.willhackforsushi.com/Cowpatty.html PR: ports/121931 Submitted by: Dennis Herrmann <adox at mcx2.org>
This commit is contained in:
parent
7371ee9d20
commit
4b0b09f4fd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=209576
6 changed files with 88 additions and 0 deletions
|
@ -47,6 +47,7 @@
|
|||
SUBDIR += clog
|
||||
SUBDIR += collectd
|
||||
SUBDIR += confregdecode
|
||||
SUBDIR += cowpatty
|
||||
SUBDIR += cricket
|
||||
SUBDIR += darkstat
|
||||
SUBDIR += disco
|
||||
|
|
36
net-mgmt/cowpatty/Makefile
Normal file
36
net-mgmt/cowpatty/Makefile
Normal file
|
@ -0,0 +1,36 @@
|
|||
# New ports collection makefile for: cowpatty
|
||||
# Date created: March 20, 2008
|
||||
# Whom: Dennis Herrmann <adox@mcx2.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= cowpatty
|
||||
PORTVERSION= 4.3
|
||||
CATEGORIES= net-mgmt security
|
||||
MASTER_SITES= http://www.willhackforsushi.com/code/cowpatty/4.3/ \
|
||||
http://mcx2.org/files/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= adox@mcx2.org
|
||||
COMMENT= Brute-force dictionary attack against WPA-PSK
|
||||
|
||||
PORTDOCS= FAQ README
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
USE_OPENSSL= yes
|
||||
|
||||
PLIST_FILES= bin/cowpatty bin/genpmk
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${ECHO_MSG} "Installing additional documentation to ${DOCSDIR}"
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
@${ECHO_MSG} ""
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
@${ECHO_MSG} ""
|
||||
|
||||
.include <bsd.port.mk>
|
3
net-mgmt/cowpatty/distinfo
Normal file
3
net-mgmt/cowpatty/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (cowpatty-4.3.tgz) = deccac0763a05ef7014107d347bf9190
|
||||
SHA256 (cowpatty-4.3.tgz) = b82154c9183fed3c26226c124f5e50ef38adaaafc84c5a13d9256b1ebd489bca
|
||||
SIZE (cowpatty-4.3.tgz) = 103720
|
36
net-mgmt/cowpatty/files/patch-Makefile
Normal file
36
net-mgmt/cowpatty/files/patch-Makefile
Normal file
|
@ -0,0 +1,36 @@
|
|||
--- Makefile.orig 2008-03-20 21:36:01.000000000 +0100
|
||||
+++ Makefile 2008-03-20 21:40:39.000000000 +0100
|
||||
@@ -1,21 +1,11 @@
|
||||
-##################################
|
||||
-# <jwright> Well, I may be doing stupid things with make
|
||||
-# <jwright> OK, it was Makefile stupid'ness
|
||||
-# <jwright> I don't really understand what the hell I am doing with Make, I'm
|
||||
-# just copying other files and seeing what works.
|
||||
-# <dragorn> heh
|
||||
-# <dragorn> i think thats all anyone does
|
||||
-# <dragorn> make is a twisted beast
|
||||
-##################################
|
||||
LDLIBS = -lpcap
|
||||
CFLAGS = -pipe -Wall -DOPENSSL
|
||||
CFLAGS += -O2
|
||||
LDLIBS += -lcrypto
|
||||
CFLAGS += -g3 -ggdb
|
||||
-#CFLAGS += -static
|
||||
PROGOBJ = md5.o sha1.o utils.o cowpatty.o genpmk.o
|
||||
PROG = cowpatty genpmk
|
||||
-BINDIR = /usr/local/bin
|
||||
+PREFIX?= /usr/local
|
||||
|
||||
all: $(PROGOBJ) $(PROG)
|
||||
|
||||
@@ -44,8 +34,5 @@
|
||||
@ls -l $(PROG)
|
||||
|
||||
install: all
|
||||
- install -d $(DESTDIR)$(BINDIR)
|
||||
- install -m 755 $(PROG) $(BINDIR)$(DESTDIR)
|
||||
-
|
||||
-love:
|
||||
- @echo "Not right now, I have a headache."
|
||||
+ install -d $(DESTDIR)$(PREFIX)/bin
|
||||
+ install -m 755 $(PROG) $(PREFIX)/bin
|
8
net-mgmt/cowpatty/files/pkg-message.in
Normal file
8
net-mgmt/cowpatty/files/pkg-message.in
Normal file
|
@ -0,0 +1,8 @@
|
|||
###########################################################################
|
||||
cowpatty has been installed
|
||||
|
||||
If you have questions read %%DOCSDIR%%/FAQ
|
||||
For more information about coWPAtty visit:
|
||||
|
||||
http://www.willhackforsushi.com/Cowpatty.html
|
||||
###########################################################################
|
4
net-mgmt/cowpatty/pkg-descr
Normal file
4
net-mgmt/cowpatty/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
coWPAtty is designed to audit the security of pre-shared keys
|
||||
(PSK) selected in WiFi Protected Access (WPA) networks.
|
||||
|
||||
WWW: http://www.willhackforsushi.com/Cowpatty.html
|
Loading…
Reference in a new issue