Update to 1.005 the latest stable release. While I am there, do some

clean ups to make portlint(1) happy, and reduce unnecessray code.
This commit is contained in:
Xin LI 2008-01-28 08:49:43 +00:00
parent f4be34c3e1
commit 4b0e9129ec
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=206309
7 changed files with 25 additions and 34 deletions

View file

@ -6,13 +6,12 @@
#
PORTNAME= gps
PORTVERSION= 0.93
PORTREVISION= 3
PORTVERSION= 1.005
CATEGORIES= mail security
MASTER_SITES= http://mimo.gn.apc.org/gps/
MASTER_SITES= SF
MASTER_SITE_SUBDIR=greylist
PKGNAMEPREFIX= postfix-
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
DISTNAME= gps-${PORTVERSION}-bugfix
MAINTAINER= delphij@FreeBSD.org
COMMENT= Greylist Policy Service for postfix
@ -21,23 +20,29 @@ LIB_DEPENDS= dbi.0:${PORTSDIR}/databases/libdbi
RUN_DEPENDS= ${LOCALBASE}/lib/dbd:${PORTSDIR}/databases/libdbi-drivers
SCRIPT_FILES= gps-maintain.pl gps-db-update.pl
PLIST_FILES= etc/gps.conf-dist libexec/gps libexec/gps-maintain.pl libexec/gps-db-update.pl
SUB_FILES= pkg-message
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
WRKSRC= ${WRKDIR}/release-${PORTVERSION}
USE_AUTOTOOLS= automake:19 autoconf:261
AUTOMAKE_ARGS= --add-missing
USE_GCC= 3.4+
CONFIGURE_ARGS= --bindir=${PREFIX}/libexec --includedir=${PREFIX}/include
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${PREFIX}/include" \
CXXFLAGS="${CXXFLAGS} -I${PREFIX}/include" \
LDFLAGS="${LDFLAGS} -L${PREFIX}/lib"
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib"
pre-configure:
@cd ${WRKSRC} && ${ACLOCAL}
post-install:
@${INSTALL_DATA} ${WRKSRC}/etc/gps.conf ${PREFIX}/etc/gps.conf-dist
.for f in ${SCRIPT_FILES}
@${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/libexec
.endfor
.if !defined(BATCH)
@${CAT} ${PKGMESSAGE}
.endif
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
MD5 (gps-0.93.tar.gz) = cd12ea6ca4b4bea06690a3356aabd7b2
SHA256 (gps-0.93.tar.gz) = 8ec562fc4017c8a926ce6264aa0a6f96b80417cc3fd49781dc51a432483f441a
SIZE (gps-0.93.tar.gz) = 338790
MD5 (gps-1.005-bugfix.tar.gz) = e791679e05c9dd22ed255d262a0ea918
SHA256 (gps-1.005-bugfix.tar.gz) = 42473432028587dc3a403a23484baaa32beada8e4726caadbe693a0dd496740d
SIZE (gps-1.005-bugfix.tar.gz) = 260085

View file

@ -1,5 +1,5 @@
--- configure.in.orig Fri Sep 17 07:55:55 2004
+++ configure.in Mon Sep 20 01:48:31 2004
--- ./configure.in.orig 2007-04-25 05:08:13.000000000 -0700
+++ ./configure.in 2008-01-27 23:50:41.970446154 -0800
@@ -20,9 +20,6 @@
AC_LANG_CPLUSPLUS
@ -9,4 +9,4 @@
-AM_PROG_LD
dnl AC_CHECK_LIB(dbi, libdbi)
AC_HAVE_HEADERS(syslog.h)
dnl freebsd compile requires AF_INET from sys/sockets.h

View file

@ -1,9 +0,0 @@
--- src/Makefile.am.orig Sun Nov 21 01:41:36 2004
+++ src/Makefile.am Sun Jan 9 16:45:10 2005
@@ -9,5 +9,5 @@
noinst_HEADERS = configreader.h db.h read.h triplet.h defs.h strtrim.h cfg.h \
wlmodule.h wldb.h tmplwlmod.h dbdefs.h doxygen.h wlcacheddb.h dbiquote.h \
regexcpp.h pmatcher.h action.h
-gps_LDADD = -lpthread -ldbi -ldl
+gps_LDADD = -ldbi ${PTHREAD_LIBS}
METASOURCES = AUTO

View file

@ -1,5 +1,5 @@
--- src/pmatcher.h.orig Sun Nov 21 05:37:49 2004
+++ src/pmatcher.h Sun Jan 9 16:50:54 2005
--- ./src/pmatcher.h.orig 2007-04-25 05:08:10.000000000 -0700
+++ ./src/pmatcher.h 2008-01-27 23:50:41.973446276 -0800
@@ -24,6 +24,7 @@
#include <string>
//getnameinfo

View file

@ -13,7 +13,7 @@ since this can be used even within a jail(8) environment. An example
entry is:
policy unix - n n - - spawn
user=nobody argv=/usr/local/libexec/gps -v /usr/local/etc/gps.conf
user=nobody argv=%%PREFIX%%/libexec/gps -v %%PREFIX%%/etc/gps.conf
In order to make policy server effect on your postfix installation,
you should add something like:
@ -25,7 +25,6 @@ Into your smtpd_sender_restrictions configuration in postfix's main.cf.
Also, you may want to include the following line into your crontab so
system will automatically do daily cleanup of the greylist table:
27 * * * * /usr/local/libexec/gps-maintain.pl -delete -eq 0 -age 86400 /usr/local/etc/gps.conf
55 3 * * * /usr/local/libexec/gps-maintain.pl -delete -age 3110400 /usr/local/etc/gps.conf
27 * * * * %%PREFIX%%/libexec/gps-maintain.pl -delete -eq 0 -age 86400 %%PREFIX%%/etc/gps.conf
55 3 * * * %%PREFIX%%/libexec/gps-maintain.pl -delete -age 3110400 %%PREFIX%%/etc/gps.conf
========================================================================

View file

@ -1,4 +0,0 @@
etc/gps.conf-dist
libexec/gps
libexec/gps-maintain.pl
libexec/gps-db-update.pl