New ports required for gitlab-ce 13.6 upgrade.

This commit is contained in:
Matthias Fechner 2020-11-21 08:07:20 +00:00
parent b00059884b
commit 4b27333610
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=555813
15 changed files with 170 additions and 0 deletions

View file

@ -159,6 +159,7 @@
SUBDIR += libnvpair
SUBDIR += libodbc++
SUBDIR += libpbl
SUBDIR += libpg_query
SUBDIR += libpqtypes
SUBDIR += libsdb
SUBDIR += libzdb
@ -930,6 +931,7 @@
SUBDIR += rubygem-flipper-active_record
SUBDIR += rubygem-flipper-active_record017
SUBDIR += rubygem-gdbm
SUBDIR += rubygem-gitlab-pg_query
SUBDIR += rubygem-globalid
SUBDIR += rubygem-globalid-rails5
SUBDIR += rubygem-globalid-rails50

View file

@ -0,0 +1,27 @@
# Created by: Matthias Fechner <mfechner@FreeBSD.org>
# $FreeBSD$
PORTNAME= libpg_query
DISTVERSION= 10-1.0.3
CATEGORIES= databases devel
MAINTAINER= mfechner@FreeBSD.org
COMMENT= C library for accessing the PostgreSQL parser outside of the server
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= gmake pgsql
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= lfittl
do-install:
${INSTALL_LIB} ${WRKSRC}/libpg_query.a ${STAGEDIR}${PREFIX}/lib/
${INSTALL_DATA} ${WRKSRC}/pg_query.h ${STAGEDIR}${PREFIX}/include/
PLIST_FILES= include/pg_query.h \
lib/libpg_query.a
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1605911735
SHA256 (lfittl-libpg_query-10-1.0.3_GH0.tar.gz) = 1332761f31c198cb9825e6ccccda0b6a0e57daeb824870e8524df77f1592d149
SIZE (lfittl-libpg_query-10-1.0.3_GH0.tar.gz) = 1507832

View file

@ -0,0 +1,6 @@
C library for accessing the PostgreSQL parser outside of the server.
This library uses the actual PostgreSQL server source to parse SQL
queries and return the internal PostgreSQL parse tree.
WWW: https://github.com/lfittl/libpg_query

View file

@ -0,0 +1,24 @@
# Created by: Matthias Fechner <mfechner@FreeBSD.org>
# $FreeBSD$
PORTNAME= gitlab-pg_query
PORTVERSION= 1.3.0
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= mfechner@FreeBSD.org
COMMENT= Parses SQL queries using a copy of the PostgreSQL server query parser
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/lib/libpg_query.a:databases/libpg_query
USES= gem
USE_RUBY= yes
#CONFIGURE_ARGS= --with-pgsql-include-dir=`${PG_CONFIG} --includedir` \
# --with-pgsql-lib-dir=`${PG_CONFIG} --libdir`
#PG_CONFIG= ${LOCALBASE}/bin/pg_config
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1605910010
SHA256 (rubygem/gitlab-pg_query-1.3.0.gem) = 98c66602fdf054dc57dff8b91925e57fa7b43015c9c699dc6f6d6de31fd27f77
SIZE (rubygem/gitlab-pg_query-1.3.0.gem) = 35328

View file

@ -0,0 +1,39 @@
--- ext/pg_query/extconf.rb.orig 2020-11-20 23:41:38 UTC
+++ ext/pg_query/extconf.rb
@@ -10,22 +10,22 @@ libdir = File.join(workdir, 'libpg_query-' + LIB_PG_QU
gemdir = File.join(__dir__, '../..')
libfile = libdir + '/libpg_query.a'
-unless File.exist?("#{workdir}/libpg_query.tar.gz")
- File.open("#{workdir}/libpg_query.tar.gz", 'wb') do |target_file|
- open("https://gitlab.com/gitlab-org/libpg_query/-/archive/#{LIB_PG_QUERY_TAG}/libpg_query-#{LIB_PG_QUERY_TAG}.tar.gz", 'rb') do |read_file|
- target_file.write(read_file.read)
- end
- end
-end
+#unless File.exist?("#{workdir}/libpg_query.tar.gz")
+# File.open("#{workdir}/libpg_query.tar.gz", 'wb') do |target_file|
+# open("https://gitlab.com/gitlab-org/libpg_query/-/archive/#{LIB_PG_QUERY_TAG}/libpg_query-#{LIB_PG_QUERY_TAG}.tar.gz", 'rb') do |read_file|
+# target_file.write(read_file.read)
+# end
+# end
+#end
-unless Dir.exist?(libdir)
- system("tar -xzf #{workdir}/libpg_query.tar.gz") || raise('ERROR')
-end
+#unless Dir.exist?(libdir)
+# system("tar -xzf #{workdir}/libpg_query.tar.gz") || raise('ERROR')
+#end
-unless Dir.exist?(libfile)
- # Build libpg_query (and parts of PostgreSQL)
- system("cd #{libdir}; #{ENV['MAKE'] || (RUBY_PLATFORM =~ /bsd/ ? 'gmake' : 'make')} build")
-end
+#unless Dir.exist?(libfile)
+# # Build libpg_query (and parts of PostgreSQL)
+# system("cd #{libdir}; #{ENV['MAKE'] || (RUBY_PLATFORM =~ /bsd/ ? 'gmake' : 'make')} build")
+#end
# Copy test files (this intentionally overwrites existing files!)
system("cp #{libdir}/testdata/* #{gemdir}/spec/files/")

View file

@ -0,0 +1,7 @@
This Ruby extension uses the actual PostgreSQL server source
to parse SQL queries and return the internal PostgreSQL parsetree.
In addition the extension allows you to normalize queries (replacing constant
values with ?) and parse these normalized queries into a parsetree again.
WWW: https://github.com/lfittl/pg_query

View file

@ -6107,7 +6107,9 @@
SUBDIR += rubygem-grape140
SUBDIR += rubygem-grape_logging
SUBDIR += rubygem-graphiql-rails
SUBDIR += rubygem-graphlient
SUBDIR += rubygem-graphql
SUBDIR += rubygem-graphql-client
SUBDIR += rubygem-graphql-docs
SUBDIR += rubygem-grit
SUBDIR += rubygem-grpc-google-iam-v1

View file

@ -0,0 +1,23 @@
# Created by: Matthias Fechner <mfechner@FreeBSD.org>
# $FreeBSD$
PORTNAME= graphlient
PORTVERSION= 0.4.0
CATEGORIES= devel rubygems
MASTER_SITES= RG
MAINTAINER= mfechner@FreeBSD.org
COMMENT= Friendlier Ruby client for consuming GraphQL-based APIs
LICENSE= MIT
RUN_DEPENDS= rubygem-faraday>=1.0:www/rubygem-faraday \
rubygem-faraday_middleware>=0:www/rubygem-faraday_middleware \
rubygem-graphql-client>=0:devel/rubygem-graphql-client
USES= gem
USE_RUBY= yes
NO_ARCH= yes
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1605909016
SHA256 (rubygem/graphlient-0.4.0.gem) = ca04bd7818458b4b3748ee5c7d9776f17664bf6b93a601a0468dc86159168311
SIZE (rubygem/graphlient-0.4.0.gem) = 217600

View file

@ -0,0 +1,3 @@
A friendlier Ruby client for consuming GraphQL-based APIs.
WWW: http://github.com/ashkan18/graphlient

View file

@ -0,0 +1,22 @@
# Created by: Matthias Fechner <mfechner@FreeBSD.org>
# $FreeBSD$
PORTNAME= graphql-client
PORTVERSION= 0.16.0
CATEGORIES= devel rubygems
MASTER_SITES= RG
MAINTAINER= mfechner@FreeBSD.org
COMMENT= Ruby library for declaring, composing and executing GraphQL queries
LICENSE= MIT
RUN_DEPENDS= rubygem-activesupport60>=3.0:devel/rubygem-activesupport60 \
rubygem-graphql>=1.8<2:devel/rubygem-graphql
USES= gem
USE_RUBY= yes
NO_ARCH= yes
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1605909223
SHA256 (rubygem/graphql-client-0.16.0.gem) = 244fac646bbb86f1be5eac3d4baa310f894bca57268b80d0cc4367cf580e273d
SIZE (rubygem/graphql-client-0.16.0.gem) = 26112

View file

@ -0,0 +1,3 @@
A Ruby library for declaring, composing and executing GraphQL queries.
WWW: https://github.com/github/graphql-client