security/*: Move man pages to share/man
Approved by: portmgr (blanket)
This commit is contained in:
parent
32bc3e78b0
commit
4b36bba2e5
8 changed files with 32 additions and 9 deletions
|
@ -1,5 +1,6 @@
|
|||
PORTNAME= kc
|
||||
PORTVERSION= 2.5.3
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= security
|
||||
|
||||
MAINTAINER= leva@ecentrum.hu
|
||||
|
@ -33,8 +34,10 @@ USES+= pkgconfig ncurses ssl uidfix
|
|||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= levaidaniel
|
||||
|
||||
PLIST_FILES= bin/kc man/man1/kc.1.gz share/doc/kc/Changelog.md
|
||||
PLIST_FILES= bin/kc share/doc/kc/Changelog.md share/man/man1/kc.1.gz
|
||||
|
||||
MAKE_ARGS= BINDIR="${PREFIX}/bin" \
|
||||
MANDIR="${PREFIX}/share/man/man"
|
||||
MAKE_ENV+= BUNDLED_BCRYPT=y
|
||||
|
||||
post-patch:
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
PORTNAME= pam_mkhomedir
|
||||
PORTVERSION= 0.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://portal-to-web.de/pam_mkhomedir/
|
||||
|
||||
|
@ -11,7 +12,9 @@ SUB_FILES= pkg-message
|
|||
|
||||
PLIST_FILES= lib/pam_mkhomedir.so \
|
||||
lib/pam_mkhomedir.so.2 \
|
||||
man/man8/pam_mkhomedir.8.gz
|
||||
share/man/man8/pam_mkhomedir.8.gz
|
||||
|
||||
MAKE_ARGS= MANDIR="${PREFIX}/share/man/man"
|
||||
|
||||
.if defined(WITH_PROFILE)
|
||||
PLIST_FILES+= lib/libpam_mkhomedir_p.a
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
PORTNAME= pam_ocra
|
||||
DISTVERSION= 1.6
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= security
|
||||
|
||||
MAINTAINER= sg2342@googlemail.com
|
||||
|
@ -16,11 +17,13 @@ GH_ACCOUNT= sg2342
|
|||
CFLAGS+= -I${OPENSSLINC}
|
||||
LDFLAGS+= -L${OPENSSLLIB}
|
||||
|
||||
MAKE_ARGS= MANDIR="${PREFIX}/share/man/man"
|
||||
|
||||
PLIST_FILES= lib/pam_ocra.so \
|
||||
lib/pam_ocra.so.0 \
|
||||
sbin/ocra_tool \
|
||||
man/man8/pam_ocra.8.gz \
|
||||
man/man8/ocra_tool.8.gz
|
||||
share/man/man8/pam_ocra.8.gz \
|
||||
share/man/man8/ocra_tool.8.gz
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
PORTNAME= pam_search_list
|
||||
PORTVERSION= 0.1
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= SF/${PORTNAME:S/_/-/g}
|
||||
DISTNAME= ${PORTNAME:S/_/-/g}-${PORTVERSION}
|
||||
|
@ -11,10 +11,12 @@ WWW= https://sourceforge.net/projects/pam-search-list/
|
|||
|
||||
USES= tar:xz uidfix
|
||||
|
||||
MAKE_ARGS= MANDIR="${PREFIX}/share/man/man"
|
||||
|
||||
PLIST_FILES= lib/libpam_search_list.a \
|
||||
lib/pam_search_list.so \
|
||||
lib/pam_search_list.so.0 \
|
||||
man/man8/pam_search_list.8.gz
|
||||
share/man/man8/pam_search_list.8.gz
|
||||
|
||||
OPTIONS_DEFINE= PROFILE
|
||||
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
PORTNAME= rndpassw
|
||||
PORTVERSION= 0.2.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= security
|
||||
|
||||
MAINTAINER= melanhit@gmail.com
|
||||
|
@ -15,6 +16,6 @@ GH_ACCOUNT= melanhit
|
|||
USES= cmake
|
||||
|
||||
PLIST_FILES= bin/rndpassw \
|
||||
man/man1/rndpassw.1.gz
|
||||
share/man/man1/rndpassw.1.gz
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
10
security/rndpassw/files/patch-doc_man_CMakeLists.txt
Normal file
10
security/rndpassw/files/patch-doc_man_CMakeLists.txt
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- doc/man/CMakeLists.txt.orig 2024-03-21 08:25:18 UTC
|
||||
+++ doc/man/CMakeLists.txt
|
||||
@@ -16,6 +16,6 @@ foreach(manpage ${man1_src})
|
||||
|
||||
foreach(manpage ${man1_src})
|
||||
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${manpage}.gz
|
||||
- DESTINATION man/man1)
|
||||
+ DESTINATION share/man/man1)
|
||||
endforeach()
|
||||
|
|
@ -1,5 +1,6 @@
|
|||
PORTNAME= sst
|
||||
PORTVERSION= 1.26
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://utcc.utoronto.ca/~pkern/stuff/sst/
|
||||
|
||||
|
@ -15,6 +16,6 @@ MAKEFILE= ${FILESDIR}/Makefile
|
|||
USES= uidfix ssl tar:xz
|
||||
|
||||
PLIST_FILES= sbin/sst \
|
||||
man/man1/sst.1.gz
|
||||
share/man/man1/sst.1.gz
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
PROG=sst
|
||||
|
||||
BINDIR=${PREFIX}/sbin
|
||||
MANDIR=${PREFIX}/man/man
|
||||
MANDIR=${PREFIX}/share/man/man
|
||||
|
||||
CFLAGS+= -DCONFDIR='"${OPENSSLDIR}"' -DCERTF='"certs/sst.pem"' \
|
||||
-I${OPENSSLINC} -Wno-comment
|
||||
|
|
Loading…
Reference in a new issue