databases/mysq56-{client, server}: Update to latest release 5.7.27
This update includes security fixes on issues that are mentioned on upstream critical patch report. Further info: https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html#AppendixMSQL PR: 239271 Submitted by: Greg Veldman <freebsd@gregv.net> Reported by: Markus Kohlmeyer <rootservice@gmail.com> Sponsored by: Platform.sh
This commit is contained in:
parent
a7b0878922
commit
4b382c759b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=508220
5 changed files with 25 additions and 25 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= mysql
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 0
|
||||
PKGNAMESUFFIX= 57-client
|
||||
|
||||
COMMENT= Multithreaded SQL database (client)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- scripts/CMakeLists.txt.orig 2016-03-28 18:06:12 UTC
|
||||
+++ scripts/CMakeLists.txt
|
||||
@@ -43,6 +43,7 @@ ELSE()
|
||||
--- scripts/CMakeLists.txt.orig 2019-06-10 10:43:20.000000000 -0400
|
||||
+++ scripts/CMakeLists.txt 2019-08-01 10:59:24.177559000 -0400
|
||||
@@ -46,6 +46,7 @@
|
||||
MESSAGE(FATAL_ERROR "Cannot concatenate files")
|
||||
ENDIF()
|
||||
|
||||
|
@ -8,7 +8,7 @@
|
|||
# Build mysql_fix_privilege_tables.c
|
||||
ADD_CUSTOM_COMMAND(
|
||||
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/mysql_fix_privilege_tables_sql.c
|
||||
@@ -63,6 +64,7 @@ ADD_CUSTOM_TARGET(GenFixPrivs
|
||||
@@ -66,6 +67,7 @@
|
||||
DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/mysql_fix_privilege_tables_sql.c
|
||||
${CMAKE_CURRENT_BINARY_DIR}/sql_commands_sys_schema.h
|
||||
)
|
||||
|
@ -16,7 +16,7 @@
|
|||
|
||||
# If we do not have performance schema compiled in then sys will not work,
|
||||
# so only create an empty sys database with an auto-generated file,
|
||||
@@ -143,6 +145,7 @@ IF(NOT WITHOUT_SERVER)
|
||||
@@ -146,6 +148,7 @@
|
||||
)
|
||||
ENDIF()
|
||||
|
||||
|
@ -24,7 +24,7 @@
|
|||
IF(UNIX)
|
||||
FILE(WRITE ${CMAKE_CURRENT_BINARY_DIR}/make_binary_distribution
|
||||
"cd ${CMAKE_BINARY_DIR} && '${CMAKE_CPACK_COMMAND}' -G TGZ --config CPackConfig.cmake\n" )
|
||||
@@ -150,6 +153,7 @@ IF(UNIX)
|
||||
@@ -153,6 +156,7 @@
|
||||
COMMAND chmod +x ${CMAKE_CURRENT_BINARY_DIR}/make_binary_distribution
|
||||
)
|
||||
ENDIF()
|
||||
|
@ -32,16 +32,16 @@
|
|||
|
||||
IF(NOT WITHOUT_SERVER)
|
||||
INSTALL(FILES
|
||||
@@ -347,6 +351,8 @@ MACRO(EXTRACT_LINK_LIBRARIES target var)
|
||||
@@ -326,6 +330,8 @@
|
||||
GET_FILENAME_COMPONENT(lib "${lib}" NAME_WE)
|
||||
STRING(REGEX REPLACE "^lib" "" lib "${lib}")
|
||||
SET(${var} "${${var}}-l${lib} " )
|
||||
SET(${var} "${${var}}-l${lib} " )
|
||||
+ ELSEIF(lib STREQUAL "-pthread")
|
||||
+ SET(${var} "${${var}}-pthread " )
|
||||
+ SET(${var} "${${var}}-pthread " )
|
||||
ELSE()
|
||||
SET(${var} "${${var}}-l${lib} " )
|
||||
SET(${var} "${${var}}-l${lib} " )
|
||||
ENDIF()
|
||||
@@ -430,19 +436,7 @@ ELSE()
|
||||
@@ -411,19 +417,7 @@
|
||||
# On Unix, most of the files end up in the bin directory
|
||||
SET(mysql_config_COMPONENT COMPONENT Development)
|
||||
|
||||
|
|
|
@ -2,8 +2,8 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME?= mysql
|
||||
PORTVERSION= 5.7.26
|
||||
PORTREVISION?= 5
|
||||
PORTVERSION= 5.7.27
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES= databases ipv6
|
||||
MASTER_SITES= MYSQL/MySQL-5.7
|
||||
PKGNAMESUFFIX?= 57-server
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1556318914
|
||||
SHA256 (mysql-boost-5.7.26.tar.gz) = effca6d3aceebc286a9fb046257330d125cc2f4def87081c286bfc4df3d974d1
|
||||
SIZE (mysql-boost-5.7.26.tar.gz) = 51098338
|
||||
TIMESTAMP = 1565043969
|
||||
SHA256 (mysql-boost-5.7.27.tar.gz) = 036ab46a8a1216cfc1e87374bd1cba12e2208c02cf328a31851be7e1c7f57a2b
|
||||
SIZE (mysql-boost-5.7.27.tar.gz) = 51436383
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
--- scripts/CMakeLists.txt.orig 2016-03-28 18:06:12 UTC
|
||||
+++ scripts/CMakeLists.txt
|
||||
@@ -347,6 +347,8 @@ MACRO(EXTRACT_LINK_LIBRARIES target var)
|
||||
--- scripts/CMakeLists.txt.orig 2019-06-10 10:43:20.000000000 -0400
|
||||
+++ scripts/CMakeLists.txt 2019-08-01 10:10:16.206052000 -0400
|
||||
@@ -326,6 +326,8 @@
|
||||
GET_FILENAME_COMPONENT(lib "${lib}" NAME_WE)
|
||||
STRING(REGEX REPLACE "^lib" "" lib "${lib}")
|
||||
SET(${var} "${${var}}-l${lib} " )
|
||||
SET(${var} "${${var}}-l${lib} " )
|
||||
+ ELSEIF(lib STREQUAL "-pthread")
|
||||
+ SET(${var} "${${var}}-pthread " )
|
||||
+ SET(${var} "${${var}}-pthread " )
|
||||
ELSE()
|
||||
SET(${var} "${${var}}-l${lib} " )
|
||||
SET(${var} "${${var}}-l${lib} " )
|
||||
ENDIF()
|
||||
@@ -430,14 +432,13 @@ ELSE()
|
||||
@@ -411,14 +413,13 @@
|
||||
# On Unix, most of the files end up in the bin directory
|
||||
SET(mysql_config_COMPONENT COMPONENT Development)
|
||||
|
||||
|
@ -25,7 +25,7 @@
|
|||
mysqldumpslow
|
||||
mysqld_multi
|
||||
mysqld_safe
|
||||
@@ -471,7 +472,7 @@ ELSE()
|
||||
@@ -452,7 +453,7 @@
|
||||
FOREACH(file ${BIN_SCRIPTS})
|
||||
IF(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${file}.sh)
|
||||
CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/${file}.sh
|
||||
|
|
Loading…
Reference in a new issue