Fix once and for all cups support in postfix.
Add BSD printing support to samba and default it to /etc/printcap Bump PORTREVISION PR: 33803 Submitted by: ports@geeksrus.net
This commit is contained in:
parent
d2b9fedd8b
commit
4b46071702
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=53280
3 changed files with 21 additions and 53 deletions
|
@ -7,7 +7,7 @@
|
|||
|
||||
PORTNAME= samba
|
||||
PORTVERSION= 2.2.2
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.samba.org/pub/samba/%SUBDIR%/ \
|
||||
ftp://samba.anu.edu.au/pub/samba/%SUBDIR%/ \
|
||||
|
@ -18,9 +18,7 @@ MASTER_SITE_SUBDIR= . old-versions old
|
|||
|
||||
MAINTAINER= dwcjr@FreeBSD.org
|
||||
|
||||
.if defined(WITH_CUPS)
|
||||
LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base
|
||||
.endif
|
||||
|
||||
.if defined(WITH_RECYCLE)
|
||||
PATCH_SITES+= http://www.amherst.edu/~bbstone/recycle_bin/2.2.2/
|
||||
|
@ -46,15 +44,14 @@ CONFIGURE_ARGS= --libdir=${SAMBA_CONFDIR} \
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
# to find CUPS libs, includes
|
||||
CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
|
||||
LDFLAGS=-L${LOCALBASE}/lib
|
||||
|
||||
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
|
||||
CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME}
|
||||
.endif
|
||||
|
||||
.if defined(WITH_CUPS)
|
||||
# This enables CUPS printing support in Samba.
|
||||
CONFIGURE_ARGS+= --with-cups=${LOCALBASE}
|
||||
.endif
|
||||
|
||||
.if defined(WITH_ACL_SUPPORT)
|
||||
.if ${OSVERSION} < 500018
|
||||
BROKEN= "Requires a recent FreeBSD 5.0-CURRENT"
|
||||
|
|
|
@ -1,27 +1,5 @@
|
|||
--- configure.in.orig Sat Oct 13 22:09:16 2001
|
||||
+++ configure.in Tue Oct 16 17:21:21 2001
|
||||
@@ -406,21 +406,6 @@
|
||||
AC_CHECK_TYPE(ssize_t, int)
|
||||
AC_CHECK_TYPE(wchar_t, unsigned short)
|
||||
|
||||
-############################################
|
||||
-# for cups support we need libcups, and a handful of header files
|
||||
-
|
||||
-AC_CHECK_LIB(cups,httpConnect)
|
||||
-
|
||||
-# I wonder if there is a nicer way of doing this?
|
||||
-
|
||||
-if test x"$ac_cv_lib_cups_httpConnect" = x"yes"; then
|
||||
- AC_CHECK_HEADERS(cups/cups.h cups/language.h)
|
||||
- if test x"$ac_cv_header_cups_cups_h" = x"yes"; then
|
||||
- if test x"$ac_cv_header_cups_language_h" = x"yes"; then
|
||||
- AC_DEFINE(HAVE_CUPS)
|
||||
- fi
|
||||
- fi
|
||||
-fi
|
||||
|
||||
############################################
|
||||
# we need libdl for PAM and the new VFS code
|
||||
--- configure.in.orig Sat Oct 13 17:09:16 2001
|
||||
+++ configure.in Fri Jan 11 19:58:14 2002
|
||||
@@ -1622,7 +1607,7 @@
|
||||
yes)
|
||||
AC_MSG_RESULT(yes)
|
||||
|
@ -31,24 +9,3 @@
|
|||
CFLAGS="$CFLAGS -I$withval/include"
|
||||
LDFLAGS="$LDFLAGS -L$withval/lib"
|
||||
;;
|
||||
@@ -1961,6 +1946,20 @@
|
||||
;;
|
||||
esac ],
|
||||
AC_MSG_RESULT(no)
|
||||
+)
|
||||
+
|
||||
+#################################################
|
||||
+# check for CUPS printing support
|
||||
+AC_MSG_CHECKING(whether to use CUPS printing)
|
||||
+AC_ARG_WITH(cups,
|
||||
+[ --with-cups=base-dir Include CUPS printing support
|
||||
+ --without-cups Don't include CUPS printing support (default)],
|
||||
+[ AC_MSG_RESULT(yes)
|
||||
+ LIBS="$LIBS -lcups"
|
||||
+ CFLAGS="$CFLAGS -I$withval/include"
|
||||
+ LDFLAGS="$LDFLAGS -L$withval/lib"
|
||||
+ AC_CHECK_LIB(cups,httpConnect)],
|
||||
+ AC_MSG_RESULT(no)
|
||||
)
|
||||
|
||||
|
||||
|
|
14
net/samba/files/patch-include-includes.h
Normal file
14
net/samba/files/patch-include-includes.h
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- include/includes.h.orig Sat Oct 13 17:09:21 2001
|
||||
+++ include/includes.h Fri Jan 11 22:12:06 2002
|
||||
@@ -27,6 +27,11 @@
|
||||
|
||||
#include "local.h"
|
||||
|
||||
+#ifdef __FreeBSD__
|
||||
+#define DEFAULT_PRINTING PRINT_BSD
|
||||
+#define PRINTCAP_NAME "/etc/printcap"
|
||||
+#endif /* __FreeBSD__ */
|
||||
+
|
||||
#ifdef AIX
|
||||
#define DEFAULT_PRINTING PRINT_AIX
|
||||
#define PRINTCAP_NAME "/etc/qconfig"
|
Loading…
Reference in a new issue