Update to 1.2.5i-jp0.

PR:		ports/20871
Submitted by:	IWASHITA Yoji <shuna@pop16.odn.ne.jp> (MAINTAINER)
This commit is contained in:
Akinori MUSHA 2000-08-28 18:21:02 +00:00
parent f45284bcf6
commit 4b7f9c06ec
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=32060
11 changed files with 138 additions and 102 deletions

View file

@ -8,13 +8,14 @@
PORTNAME= mutt
PORTVERSION= ${VERSION}.j${JP_VERSION}
CATEGORIES= japanese mail
MASTER_SITES= ftp://ftp.gbnet.net/pub/mutt-international/ \
MASTER_SITES= ftp://ftp.mutt.org/pub/mutt/ \
ftp://ftp.gbnet.net/pub/mutt-international/ \
ftp://ftp.guug.de/pub/mutt/ \
ftp://ftp.guug.de/pub/mutt/historic/ \
http://www.hiei.kit.ac.jp/~hitomi/mutt/
DISTNAME= ${PORTNAME}-${VERSION}i
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
manual_ja-${VERSION:R}i-0.tar.gz
manual_ja-${VERSION:R}i-1.tar.gz
PATCH_SITES= http://www.geocities.co.jp/SiliconValley-PaloAlto/2594/ \
http://www2.odn.ne.jp/~aab27060/ports/distfiles/
@ -24,36 +25,38 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= shuna@pop16.odn.ne.jp
LIB_DEPENDS= slang.2:${PORTSDIR}/japanese/libslang
BUILD_DEPENDS= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext \
autoconf:${PORTSDIR}/devel/autoconf \
automake:${PORTSDIR}/devel/automake
.if !defined(WITH_GETTEXT)
LIB_DEPENDS+= intl.1:${PORTSDIR}/devel/gettext
.endif
.if defined(WITH_GETTEXT)
BUILD_DEPENDS= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext
.endif
RUN_DEPENDS= urlview:${PORTSDIR}/textproc/urlview
VERSION= 1.2.4
VERSION= 1.2.5
JP_VERSION= 0
DIST_SUBDIR= mutt
GNU_CONFIGURE= yes
USE_AUTOCONF= yes
USE_GMAKE= yes
USE_AUTOMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${VERSION}
ALL_TARGET= all
CONFIGURE_ARGS= --with-slang --enable-locales-fix --with-included-gettext \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-slang --enable-locales-fix \
--enable-flock --disable-fcntl \
--sysconfdir=${PREFIX}/etc \
--with-docdir=${PREFIX}/share/doc/mutt \
--enable-pop --enable-imap
.if defined(WITH_GETTEXT)
CONFIGURE_ARGS+= --with-included-gettext
.endif
MAN1= mutt.1 mutt_dotlock.1
MAN5= muttrc.5
pre-configure:
(cd ${WRKSRC}; autoconf)
(cd ${WRKSRC}; aclocal -I m4)
post-install:
strip ${PREFIX}/bin/mutt
strip ${PREFIX}/bin/mutt_dotlock
strip ${PREFIX}/bin/pgpring
${INSTALL_DATA} ${WRKDIR}/manual_ja.txt ${PREFIX}/share/doc/mutt
${INSTALL_DATA} ${WRKDIR}/manual_ja.tex ${PREFIX}/share/doc/mutt
${INSTALL_DATA} ${WRKDIR}/manual_ja.html ${PREFIX}/share/doc/mutt

View file

@ -1,3 +1,3 @@
MD5 (mutt/mutt-1.2.4i.tar.gz) = 30968eeb985c074d03078a3d6ae982c9
MD5 (mutt/manual_ja-1.2i-0.tar.gz) = 809121b8baa58906fba7422de9c2b236
MD5 (mutt/mutt-1.2.4i-jp0-diff.gz) = 9def4822cb3f152e89488e66df1ea2fc
MD5 (mutt/mutt-1.2.5i.tar.gz) = 0ba5367059abdd55daceb82dce6be42f
MD5 (mutt/manual_ja-1.2i-1.tar.gz) = 709f021985530045ccb17601a6ac361b
MD5 (mutt/mutt-1.2.5i-jp0-diff.gz) = b720222e1d8e9128af1ba3f8edfea271

View file

@ -1,25 +0,0 @@
--- configure.in.orig Wed Jul 19 03:25:03 2000
+++ configure.in Wed Jul 19 03:25:35 2000
@@ -119,18 +119,11 @@
AC_MSG_CHECKING(for S-Lang)
if test $withval = yes; then
- if test -d $srcdir/../slang; then
- mutt_cv_slang=$srcdir/../slang/src
- CPPFLAGS="$CPPFLAGS -I${mutt_cv_slang}"
- LDFLAGS="$LDFLAGS -L${mutt_cv_slang}/objs"
- else
- if test -d $mutt_cv_prefix/include/slang; then
- CPPFLAGS="$CPPFLAGS -I$mutt_cv_prefix/include/slang"
- elif test -d /usr/include/slang; then
- CPPFLAGS="$CPPFLAGS -I/usr/include/slang"
- fi
- mutt_cv_slang=yes
+ if test -d $mutt_cv_prefix/include/slang; then
+ CPPFLAGS="$CPPFLAGS -I$mutt_cv_prefix/include/slang"
+ LDFLAGS="$LDFLAGS -L$mutt_cv_prefix/lib"
fi
+ mutt_cv_slang=yes
else
dnl ---Check to see if $withval is a source directory
if test -f $withval/src/slang.h; then

View file

@ -1,11 +0,0 @@
--- muttlib.c.orig Wed Jul 19 03:25:03 2000
+++ muttlib.c Wed Jul 19 03:26:06 2000
@@ -1103,7 +1103,7 @@
void mutt_display_sanitize (char *s)
{
#ifdef KANJI
- if (strcmp(Charset, "iso-2022-jp") == 0)
+ if (strcmp(Charset, "iso-2022-jp") == 0 || strcmp(Charset, "euc-jp") == 0)
return;
#endif

View file

@ -1,26 +0,0 @@
--- handler.c.orig Wed Jul 19 13:37:07 2000
+++ handler.c Wed Jul 19 13:42:28 2000
@@ -187,7 +187,11 @@
if(ch != EOF)
{
mutt_decoder_push_one (dec, ch);
+#ifdef KANJI
+ if (ch == '\n' || l++ == 1024)
+#else
if (l++ == 1024)
+#endif
{
mutt_decoder_pop_to_state (dec, s);
l = 0;
@@ -270,7 +274,11 @@
else
mutt_decoder_push_one (dec, ch);
+#ifdef KANJI
+ if (ch == '\n' || (l += 3) >= 1024)
+#else
if ((l += 3) >= 1024)
+#endif
{
mutt_decoder_pop_to_state (dec, s);
l = 0;

View file

@ -1,5 +1,5 @@
--- Makefile.am.orig Wed Jul 19 14:29:18 2000
+++ Makefile.am Wed Jul 19 14:31:11 2000
--- Makefile.am.orig Sat Jul 29 20:11:33 2000
+++ Makefile.am Sat Jul 29 20:15:54 2000
@@ -122,7 +122,6 @@
fi

View file

@ -0,0 +1,46 @@
--- khenkan.c.orig Tue Aug 1 02:28:27 2000
+++ khenkan.c Tue Aug 1 03:13:51 2000
@@ -1045,6 +1045,7 @@
{
char *p = (char *)s, ch, *beg, *end=NULL, *to_ascii=NULL, *to_kanji=NULL;
int len = 0, count, beg_kanji, end_kanji=0;
+ char *enc_end = NULL, *prev_brk = NULL;
/* check if buffer 'd' has a enough length */
if (dmax - d < strlen((char *)s) * 4 / 3) return (-1);
@@ -1064,11 +1065,23 @@
if (d == dmax) return (-1);
if (len > 75) { /* line break(in text) */
- p = beg; /* search previous word's end */
- while(beg > (char *)s && *beg != ' ') beg--;
- while(beg > (char *)s && *beg == ' ') beg--;
+ if (enc_end == NULL) {
+ enc_end = s;
+ }
+ while(beg >= enc_end && *beg != ' ') beg--;
+ while(beg >= enc_end && *beg == ' ') beg--;
++beg;
- d -= p - beg + 1;
+ if (prev_brk != NULL && beg <= prev_brk) {
+ beg = p;
+ while(beg > prev_brk && isalnum(*beg)) beg--;
+ }
+ if (prev_brk == NULL || beg > prev_brk) {
+ d -= p - beg;
+ p = beg;
+ prev_brk = beg;
+ } else {
+ prev_brk = p;
+ }
*d++ = '\n';
*d++ = ' ';
len = 0;
@@ -1181,6 +1194,7 @@
new_d = encode_base64(d, jtmp_str, jtmp_str + count);
len += new_d - d;
d = new_d;
+ enc_end = p;
beg_kanji = end_kanji;
beg = p;

View file

@ -8,13 +8,14 @@
PORTNAME= mutt
PORTVERSION= ${VERSION}.j${JP_VERSION}
CATEGORIES= japanese mail
MASTER_SITES= ftp://ftp.gbnet.net/pub/mutt-international/ \
MASTER_SITES= ftp://ftp.mutt.org/pub/mutt/ \
ftp://ftp.gbnet.net/pub/mutt-international/ \
ftp://ftp.guug.de/pub/mutt/ \
ftp://ftp.guug.de/pub/mutt/historic/ \
http://www.hiei.kit.ac.jp/~hitomi/mutt/
DISTNAME= ${PORTNAME}-${VERSION}i
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
manual_ja-${VERSION:R}i-0.tar.gz
manual_ja-${VERSION:R}i-1.tar.gz
PATCH_SITES= http://www.geocities.co.jp/SiliconValley-PaloAlto/2594/ \
http://www2.odn.ne.jp/~aab27060/ports/distfiles/
@ -24,36 +25,38 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= shuna@pop16.odn.ne.jp
LIB_DEPENDS= slang.2:${PORTSDIR}/japanese/libslang
BUILD_DEPENDS= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext \
autoconf:${PORTSDIR}/devel/autoconf \
automake:${PORTSDIR}/devel/automake
.if !defined(WITH_GETTEXT)
LIB_DEPENDS+= intl.1:${PORTSDIR}/devel/gettext
.endif
.if defined(WITH_GETTEXT)
BUILD_DEPENDS= ${LOCALBASE}/bin/msgfmt:${PORTSDIR}/devel/gettext
.endif
RUN_DEPENDS= urlview:${PORTSDIR}/textproc/urlview
VERSION= 1.2.4
VERSION= 1.2.5
JP_VERSION= 0
DIST_SUBDIR= mutt
GNU_CONFIGURE= yes
USE_AUTOCONF= yes
USE_GMAKE= yes
USE_AUTOMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${VERSION}
ALL_TARGET= all
CONFIGURE_ARGS= --with-slang --enable-locales-fix --with-included-gettext \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-slang --enable-locales-fix \
--enable-flock --disable-fcntl \
--sysconfdir=${PREFIX}/etc \
--with-docdir=${PREFIX}/share/doc/mutt \
--enable-pop --enable-imap
.if defined(WITH_GETTEXT)
CONFIGURE_ARGS+= --with-included-gettext
.endif
MAN1= mutt.1 mutt_dotlock.1
MAN5= muttrc.5
pre-configure:
(cd ${WRKSRC}; autoconf)
(cd ${WRKSRC}; aclocal -I m4)
post-install:
strip ${PREFIX}/bin/mutt
strip ${PREFIX}/bin/mutt_dotlock
strip ${PREFIX}/bin/pgpring
${INSTALL_DATA} ${WRKDIR}/manual_ja.txt ${PREFIX}/share/doc/mutt
${INSTALL_DATA} ${WRKDIR}/manual_ja.tex ${PREFIX}/share/doc/mutt
${INSTALL_DATA} ${WRKDIR}/manual_ja.html ${PREFIX}/share/doc/mutt

View file

@ -1,3 +1,3 @@
MD5 (mutt/mutt-1.2.4i.tar.gz) = 30968eeb985c074d03078a3d6ae982c9
MD5 (mutt/manual_ja-1.2i-0.tar.gz) = 809121b8baa58906fba7422de9c2b236
MD5 (mutt/mutt-1.2.4i-jp0-diff.gz) = 9def4822cb3f152e89488e66df1ea2fc
MD5 (mutt/mutt-1.2.5i.tar.gz) = 0ba5367059abdd55daceb82dce6be42f
MD5 (mutt/manual_ja-1.2i-1.tar.gz) = 709f021985530045ccb17601a6ac361b
MD5 (mutt/mutt-1.2.5i-jp0-diff.gz) = b720222e1d8e9128af1ba3f8edfea271

View file

@ -1,5 +1,5 @@
--- Makefile.am.orig Wed Jul 19 14:29:18 2000
+++ Makefile.am Wed Jul 19 14:31:11 2000
--- Makefile.am.orig Sat Jul 29 20:11:33 2000
+++ Makefile.am Sat Jul 29 20:15:54 2000
@@ -122,7 +122,6 @@
fi

View file

@ -0,0 +1,46 @@
--- khenkan.c.orig Tue Aug 1 02:28:27 2000
+++ khenkan.c Tue Aug 1 03:13:51 2000
@@ -1045,6 +1045,7 @@
{
char *p = (char *)s, ch, *beg, *end=NULL, *to_ascii=NULL, *to_kanji=NULL;
int len = 0, count, beg_kanji, end_kanji=0;
+ char *enc_end = NULL, *prev_brk = NULL;
/* check if buffer 'd' has a enough length */
if (dmax - d < strlen((char *)s) * 4 / 3) return (-1);
@@ -1064,11 +1065,23 @@
if (d == dmax) return (-1);
if (len > 75) { /* line break(in text) */
- p = beg; /* search previous word's end */
- while(beg > (char *)s && *beg != ' ') beg--;
- while(beg > (char *)s && *beg == ' ') beg--;
+ if (enc_end == NULL) {
+ enc_end = s;
+ }
+ while(beg >= enc_end && *beg != ' ') beg--;
+ while(beg >= enc_end && *beg == ' ') beg--;
++beg;
- d -= p - beg + 1;
+ if (prev_brk != NULL && beg <= prev_brk) {
+ beg = p;
+ while(beg > prev_brk && isalnum(*beg)) beg--;
+ }
+ if (prev_brk == NULL || beg > prev_brk) {
+ d -= p - beg;
+ p = beg;
+ prev_brk = beg;
+ } else {
+ prev_brk = p;
+ }
*d++ = '\n';
*d++ = ' ';
len = 0;
@@ -1181,6 +1194,7 @@
new_d = encode_base64(d, jtmp_str, jtmp_str + count);
len += new_d - d;
d = new_d;
+ enc_end = p;
beg_kanji = end_kanji;
beg = p;