Hashcat is an advanced CPU-based password recovery utility for FreeBSD,
Windows 7/8/10, Apple OS X, and GNU/Linux, supporting seven unique modes of attack for over 100 optimized hashing algorithms. WWW: https://hashcat.net/hashcat/ PR: 205160 Submitted by: lifanov@mail.lifanov.com
This commit is contained in:
parent
e109535adf
commit
4b7fb061eb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=404760
6 changed files with 312 additions and 0 deletions
|
@ -182,6 +182,7 @@
|
|||
SUBDIR += gwee
|
||||
SUBDIR += hackbot
|
||||
SUBDIR += hamachi
|
||||
SUBDIR += hashcat
|
||||
SUBDIR += heimdal
|
||||
SUBDIR += hitch
|
||||
SUBDIR += hlfl
|
||||
|
|
36
security/hashcat/Makefile
Normal file
36
security/hashcat/Makefile
Normal file
|
@ -0,0 +1,36 @@
|
|||
# Created by: Nikolai Lifanov <lifanov@mail.lifanov.com>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= hashcat
|
||||
PORTVERSION= 2.00
|
||||
CATEGORIES= security
|
||||
|
||||
MAINTAINER= lifanov@mail.lifanov.com
|
||||
COMMENT= Advanced CPU-based password recovery utility
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/docs/license.txt
|
||||
|
||||
BROKEN_FreeBSD_9= does not build
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= hashcat
|
||||
|
||||
USE_GCC= any
|
||||
|
||||
USES= gmake
|
||||
|
||||
ONLY_FOR_ARCHS= amd64
|
||||
ONLY_FOR_ARCHS_REASON= uses amd64 instructions
|
||||
|
||||
ALL_TARGET= posix64 posixXOP
|
||||
|
||||
do-install:
|
||||
.for v in 64 XOP
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/hashcat-cli${v}.bin ${STAGEDIR}${LOCALBASE}/bin
|
||||
.endfor
|
||||
(cd ${WRKSRC} && ${COPYTREE_SHARE} "charsets rules tables salts" ${STAGEDIR}${DATADIR})
|
||||
(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
|
||||
(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
|
||||
|
||||
.include <bsd.port.mk>
|
2
security/hashcat/distinfo
Normal file
2
security/hashcat/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (hashcat-hashcat-2.00_GH0.tar.gz) = 6325e6d75a4df3485adec00f74e5887326809c15ed31bfe74a12b62943245444
|
||||
SIZE (hashcat-hashcat-2.00_GH0.tar.gz) = 3463012
|
95
security/hashcat/files/patch-src_hashcat-cli.c
Normal file
95
security/hashcat/files/patch-src_hashcat-cli.c
Normal file
|
@ -0,0 +1,95 @@
|
|||
--- src/hashcat-cli.c.orig 2015-12-04 15:35:08 UTC
|
||||
+++ src/hashcat-cli.c
|
||||
@@ -17,14 +17,14 @@
|
||||
|
||||
// for interactive status prompt
|
||||
#ifdef POSIX
|
||||
-#ifndef OSX
|
||||
+#if defined(OSX) || defined(__FreeBSD__)
|
||||
|
||||
-#include <termio.h>
|
||||
+#include <termios.h>
|
||||
+#include <sys/ioctl.h>
|
||||
|
||||
#else
|
||||
|
||||
-#include <termios.h>
|
||||
-#include <sys/ioctl.h>
|
||||
+#include <termio.h>
|
||||
|
||||
#endif
|
||||
#endif
|
||||
@@ -2836,16 +2836,16 @@ void save_hash ()
|
||||
|
||||
#ifdef POSIX
|
||||
|
||||
-#ifndef OSX
|
||||
+#if defined(OSX) || defined(__FreeBSD__)
|
||||
|
||||
-static struct termio savemodes;
|
||||
+static struct termios savemodes;
|
||||
static int havemodes = 0;
|
||||
|
||||
int tty_break ()
|
||||
{
|
||||
- struct termio modmodes;
|
||||
+ struct termios modmodes;
|
||||
|
||||
- if (ioctl (fileno (stdin), TCGETA, &savemodes) < 0) return -1;
|
||||
+ if (ioctl (fileno (stdin), TIOCGETA, &savemodes) < 0) return -1;
|
||||
|
||||
havemodes = 1;
|
||||
|
||||
@@ -2854,7 +2854,7 @@ int tty_break ()
|
||||
modmodes.c_cc[VMIN] = 1;
|
||||
modmodes.c_cc[VTIME] = 0;
|
||||
|
||||
- return ioctl (fileno (stdin), TCSETAW, &modmodes);
|
||||
+ return ioctl (fileno (stdin), TIOCSETAW, &modmodes);
|
||||
}
|
||||
|
||||
int tty_getchar ()
|
||||
@@ -2882,19 +2882,19 @@ int tty_fix ()
|
||||
{
|
||||
if (!havemodes) return 0;
|
||||
|
||||
- return ioctl (fileno (stdin), TCSETAW, &savemodes);
|
||||
+ return ioctl (fileno (stdin), TIOCSETAW, &savemodes);
|
||||
}
|
||||
|
||||
#else
|
||||
|
||||
-static struct termios savemodes;
|
||||
+static struct termio savemodes;
|
||||
static int havemodes = 0;
|
||||
|
||||
int tty_break ()
|
||||
{
|
||||
- struct termios modmodes;
|
||||
+ struct termio modmodes;
|
||||
|
||||
- if (ioctl (fileno (stdin), TIOCGETA, &savemodes) < 0) return -1;
|
||||
+ if (ioctl (fileno (stdin), TCGETA, &savemodes) < 0) return -1;
|
||||
|
||||
havemodes = 1;
|
||||
|
||||
@@ -2903,7 +2903,7 @@ int tty_break ()
|
||||
modmodes.c_cc[VMIN] = 1;
|
||||
modmodes.c_cc[VTIME] = 0;
|
||||
|
||||
- return ioctl (fileno (stdin), TIOCSETAW, &modmodes);
|
||||
+ return ioctl (fileno (stdin), TCSETAW, &modmodes);
|
||||
}
|
||||
|
||||
int tty_getchar ()
|
||||
@@ -2931,8 +2931,9 @@ int tty_fix ()
|
||||
{
|
||||
if (!havemodes) return 0;
|
||||
|
||||
- return ioctl (fileno (stdin), TIOCSETAW, &savemodes);
|
||||
+ return ioctl (fileno (stdin), TCSETAW, &savemodes);
|
||||
}
|
||||
+
|
||||
#endif
|
||||
#endif
|
||||
|
5
security/hashcat/pkg-descr
Normal file
5
security/hashcat/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
Hashcat is an advanced CPU-based password recovery utility for FreeBSD,
|
||||
Windows 7/8/10, Apple OS X, and GNU/Linux, supporting seven unique modes
|
||||
of attack for over 100 optimized hashing algorithms.
|
||||
|
||||
WWW: https://hashcat.net/hashcat/
|
173
security/hashcat/pkg-plist
Normal file
173
security/hashcat/pkg-plist
Normal file
|
@ -0,0 +1,173 @@
|
|||
bin/hashcat-cli64.bin
|
||||
bin/hashcat-cliXOP.bin
|
||||
%%PORTDOCS%%%%DOCSDIR%%/BUILD.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/changes.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/contact.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/credits.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/license.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rules.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/user_manuals.txt
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M0.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M0.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M10.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M10.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M100.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M100.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1000.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1000.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M101.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M101.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1100.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1100.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1400.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1400.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1410.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1410.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1420.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1420.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1600.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1600.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1700.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1700.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1710.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1710.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1720.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1720.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1731.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1731.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1800.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1800.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M200.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M200.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M300.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M300.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M400.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M400.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M500.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M500.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M800.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M800.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M900.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M900.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A1.M0.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A1.M0.word
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A3.M0.hash
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A3.M0.word
|
||||
%%DATADIR%%/charsets/combined/Bulgarian.hcchr
|
||||
%%DATADIR%%/charsets/combined/Castilian.hcchr
|
||||
%%DATADIR%%/charsets/combined/Catalan.hcchr
|
||||
%%DATADIR%%/charsets/combined/English.hcchr
|
||||
%%DATADIR%%/charsets/combined/French.hcchr
|
||||
%%DATADIR%%/charsets/combined/German.hcchr
|
||||
%%DATADIR%%/charsets/combined/Greek.hcchr
|
||||
%%DATADIR%%/charsets/combined/GreekPolytonic.hcchr
|
||||
%%DATADIR%%/charsets/combined/Italian.hcchr
|
||||
%%DATADIR%%/charsets/combined/Lithuanian.hcchr
|
||||
%%DATADIR%%/charsets/combined/Polish.hcchr
|
||||
%%DATADIR%%/charsets/combined/Portuguese.hcchr
|
||||
%%DATADIR%%/charsets/combined/Russian.hcchr
|
||||
%%DATADIR%%/charsets/combined/Slovak.hcchr
|
||||
%%DATADIR%%/charsets/combined/Spanish.hcchr
|
||||
%%DATADIR%%/charsets/special/Castilian/es-ES_ISO-8859-1-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Castilian/es-ES_ISO-8859-15-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Castilian/es-ES_cp1252-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Catalan/ca_ISO-8859-1-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Catalan/ca_ISO-8859-15-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Catalan/ca_cp1252-special.hcchr
|
||||
%%DATADIR%%/charsets/special/French/fr_ISO-8859-1-special.hcchr
|
||||
%%DATADIR%%/charsets/special/French/fr_ISO-8859-15-special.hcchr
|
||||
%%DATADIR%%/charsets/special/French/fr_ISO-8859-16-special.hcchr
|
||||
%%DATADIR%%/charsets/special/French/fr_cp1252-special.hcchr
|
||||
%%DATADIR%%/charsets/special/German/de_ISO-8859-1-special.hcchr
|
||||
%%DATADIR%%/charsets/special/German/de_ISO-8859-15-special.hcchr
|
||||
%%DATADIR%%/charsets/special/German/de_cp1252-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Greek/el_ISO-8859-7-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Greek/el_cp1253-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Italian/it_ISO-8859-1-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Italian/it_ISO-8859-15-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Italian/it_cp1252-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Polish/pl_cp1250-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Portuguese/pt_ISO-8859-1-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Portuguese/pt_ISO-8859-15-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Portuguese/pt_cp1252-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Russian/ru_ISO-8859-5-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Russian/ru_cp1251-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Slovak/sk_ISO-8859-2-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Slovak/sk_cp1250-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Spanish/es_ISO-8859-1-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Spanish/es_ISO-8859-15-special.hcchr
|
||||
%%DATADIR%%/charsets/special/Spanish/es_cp1252-special.hcchr
|
||||
%%DATADIR%%/charsets/standard/Bulgarian/bg_ISO-8859-5.hcchr
|
||||
%%DATADIR%%/charsets/standard/Bulgarian/bg_KOI8-R.hcchr
|
||||
%%DATADIR%%/charsets/standard/Bulgarian/bg_cp1251.hcchr
|
||||
%%DATADIR%%/charsets/standard/Castilian/es-ES_ISO-8859-1.hcchr
|
||||
%%DATADIR%%/charsets/standard/Castilian/es-ES_ISO-8859-15.hcchr
|
||||
%%DATADIR%%/charsets/standard/Castilian/es-ES_cp1252.hcchr
|
||||
%%DATADIR%%/charsets/standard/Catalan/ca_ISO-8859-1.hcchr
|
||||
%%DATADIR%%/charsets/standard/Catalan/ca_ISO-8859-15.hcchr
|
||||
%%DATADIR%%/charsets/standard/Catalan/ca_cp1252.hcchr
|
||||
%%DATADIR%%/charsets/standard/English/en_ISO-8859-1.hcchr
|
||||
%%DATADIR%%/charsets/standard/English/en_ISO-8859-15.hcchr
|
||||
%%DATADIR%%/charsets/standard/English/en_cp1252.hcchr
|
||||
%%DATADIR%%/charsets/standard/French/fr_ISO-8859-1.hcchr
|
||||
%%DATADIR%%/charsets/standard/French/fr_ISO-8859-15.hcchr
|
||||
%%DATADIR%%/charsets/standard/French/fr_ISO-8859-16.hcchr
|
||||
%%DATADIR%%/charsets/standard/French/fr_cp1252.hcchr
|
||||
%%DATADIR%%/charsets/standard/German/de_ISO-8859-1.hcchr
|
||||
%%DATADIR%%/charsets/standard/German/de_ISO-8859-15.hcchr
|
||||
%%DATADIR%%/charsets/standard/German/de_cp1252.hcchr
|
||||
%%DATADIR%%/charsets/standard/Greek/el_ISO-8859-7.hcchr
|
||||
%%DATADIR%%/charsets/standard/Greek/el_cp1253.hcchr
|
||||
%%DATADIR%%/charsets/standard/GreekPolytonic/el_polytonic_ISO-8859-7.hcchr
|
||||
%%DATADIR%%/charsets/standard/GreekPolytonic/el_polytonic_cp1253.hcchr
|
||||
%%DATADIR%%/charsets/standard/Hungarian/hu_cp1250.hcchr
|
||||
%%DATADIR%%/charsets/standard/Italian/it_ISO-8859-1.hcchr
|
||||
%%DATADIR%%/charsets/standard/Italian/it_ISO-8859-15.hcchr
|
||||
%%DATADIR%%/charsets/standard/Italian/it_cp1252.hcchr
|
||||
%%DATADIR%%/charsets/standard/Lithuanian/lt_ISO-8859-13.hcchr
|
||||
%%DATADIR%%/charsets/standard/Lithuanian/lt_ISO-8859-4.hcchr
|
||||
%%DATADIR%%/charsets/standard/Lithuanian/lt_cp1257.hcchr
|
||||
%%DATADIR%%/charsets/standard/Polish/pl_ISO-8859-2.hcchr
|
||||
%%DATADIR%%/charsets/standard/Polish/pl_cp1250.hcchr
|
||||
%%DATADIR%%/charsets/standard/Portuguese/pt_ISO-8859-1.hcchr
|
||||
%%DATADIR%%/charsets/standard/Portuguese/pt_ISO-8859-15.hcchr
|
||||
%%DATADIR%%/charsets/standard/Portuguese/pt_cp1252.hcchr
|
||||
%%DATADIR%%/charsets/standard/Russian/ru_ISO-8859-5.hcchr
|
||||
%%DATADIR%%/charsets/standard/Russian/ru_KOI8-R.hcchr
|
||||
%%DATADIR%%/charsets/standard/Russian/ru_cp1251.hcchr
|
||||
%%DATADIR%%/charsets/standard/Slovak/sk_ISO-8859-2.hcchr
|
||||
%%DATADIR%%/charsets/standard/Slovak/sk_cp1250.hcchr
|
||||
%%DATADIR%%/charsets/standard/Spanish/es_ISO-8859-1.hcchr
|
||||
%%DATADIR%%/charsets/standard/Spanish/es_ISO-8859-15.hcchr
|
||||
%%DATADIR%%/charsets/standard/Spanish/es_cp1252.hcchr
|
||||
%%DATADIR%%/rules/Incisive-leetspeak.rule
|
||||
%%DATADIR%%/rules/InsidePro-HashManager.rule
|
||||
%%DATADIR%%/rules/InsidePro-PasswordsPro.rule
|
||||
%%DATADIR%%/rules/Ninja-leetspeak.rule
|
||||
%%DATADIR%%/rules/T0XlC-insert_00-99_1950-2050_toprules_0_F.rule
|
||||
%%DATADIR%%/rules/T0XlC-insert_space_and_special_0_F.rule
|
||||
%%DATADIR%%/rules/T0XlC-insert_top_100_passwords_1_G.rule
|
||||
%%DATADIR%%/rules/T0XlC.rule
|
||||
%%DATADIR%%/rules/T0XlCv1.rule
|
||||
%%DATADIR%%/rules/best64.rule
|
||||
%%DATADIR%%/rules/combinator.rule
|
||||
%%DATADIR%%/rules/d3ad0ne.rule
|
||||
%%DATADIR%%/rules/dive.rule
|
||||
%%DATADIR%%/rules/generated.rule
|
||||
%%DATADIR%%/rules/leetspeak.rule
|
||||
%%DATADIR%%/rules/oscommerce.rule
|
||||
%%DATADIR%%/rules/rockyou-30000.rule
|
||||
%%DATADIR%%/rules/specific.rule
|
||||
%%DATADIR%%/rules/toggles1.rule
|
||||
%%DATADIR%%/rules/toggles2.rule
|
||||
%%DATADIR%%/rules/toggles3.rule
|
||||
%%DATADIR%%/rules/toggles4.rule
|
||||
%%DATADIR%%/rules/toggles5.rule
|
||||
%%DATADIR%%/salts/brute-oscommerce.salt
|
||||
%%DATADIR%%/salts/brute-vbulletin.salt
|
||||
%%DATADIR%%/tables/digits.table
|
||||
%%DATADIR%%/tables/keyboard.en_ar1.utf8.table
|
||||
%%DATADIR%%/tables/keyboard.en_ar2.utf8.table
|
||||
%%DATADIR%%/tables/leet.table
|
||||
%%DATADIR%%/tables/toggle_case.table
|
||||
%%DATADIR%%/tables/toggle_case_and_leet.table
|
Loading…
Reference in a new issue