Update to 9.23.

PR:		33597
Submitted by:	KATO Tsuguru <tkato@prontomail.com>
This commit is contained in:
Dmitry Sivachenko 2002-01-07 08:08:02 +00:00
parent 1ca77f0d6e
commit 4b84726859
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=52698
6 changed files with 43 additions and 29 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= netpbm
PORTVERSION= 9.22
PORTVERSION= 9.23
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}

View file

@ -1 +1 @@
MD5 (netpbm-9.22.tgz) = 2699fe6da26b24e78db5327ab4d8b9c6
MD5 (netpbm-9.23.tgz) = 5ee895ffdaaa90cb2f7614ec16d859ff

View file

@ -103,6 +103,7 @@ MAN1+= pngtopnm.1
MAN1+= pnmalias.1
MAN1+= pnmarith.1
MAN1+= pnmcat.1
MAN1+= pnmcolormap.1
MAN1+= pnmcomp.1
MAN1+= pnmconvol.1
MAN1+= pnmcrop.1
@ -123,6 +124,7 @@ MAN1+= pnmpad.1
MAN1+= pnmpaste.1
MAN1+= pnmpsnr.1
MAN1+= pnmquant.1
MAN1+= pnmremap.1
MAN1+= pnmrotate.1
MAN1+= pnmscale.1
MAN1+= pnmscalefixed.1
@ -150,6 +152,7 @@ MAN1+= ppmbrighten.1
MAN1+= ppmchange.1
MAN1+= ppmcie.1
MAN1+= ppmcolormask.1
MAN1+= ppmcolors.1
MAN1+= ppmdim.1
MAN1+= ppmdist.1
MAN1+= ppmdither.1

View file

@ -1,6 +1,6 @@
--- Makefile.common.orig Tue Sep 4 08:29:05 2001
+++ Makefile.common Wed Sep 5 00:00:00 2001
@@ -174,9 +174,12 @@
--- Makefile.common.orig Sat Jan 5 09:10:54 2002
+++ Makefile.common Sun Jan 6 00:00:00 2002
@@ -175,9 +175,12 @@
$(LIBOBJECTS): %.o: $(SRCSUBDIR)/%.c $(HEADERLINKS)
# Note that the user may have configured -I options into CFLAGS.
@ -14,7 +14,7 @@
ifeq ($(NETPBMLIBTYPE),unixshared)
# The libxxx.so link is needed to link the executables.
@@ -186,13 +189,10 @@
@@ -187,13 +190,10 @@
# The $(SONAME) link is only needed to test the programs without
# installing the libraries (in that case, you also need to direct the
# dynamic linker to the source directories, e.g. set LD_LIBRARY_PATH).
@ -32,7 +32,7 @@
endif
ifeq ($(NETPBMLIBTYPE),dll)
@@ -281,7 +281,7 @@
@@ -282,7 +282,7 @@
install.merge.common: $(MERGENAME) $(NOMERGEBINARIES) install.script
cd $(INSTALLBINARIES) ; rm -f $(BINARIES) $(MERGE_ALIASES)
ifneq ($(MERGENAME)x,x)
@ -41,7 +41,7 @@
$(MERGENAME) $(INSTALLBINARIES)
cd $(INSTALLBINARIES) ; \
for i in $(MERGEBINARIES) $(MERGE_ALIASES) ; \
@@ -291,7 +291,7 @@
@@ -292,7 +292,7 @@
ifneq ($(NOMERGEBINARIES)x,x)
for x in $(NOMERGEBINARIES); \
do \
@ -50,7 +50,7 @@
$$x $(INSTALLBINARIES); \
done
endif
@@ -302,7 +302,7 @@
@@ -303,7 +303,7 @@
# Make and Install know that pbmmake.exe counts as pbmmake.
for x in $(BINARIES); \
do \
@ -59,7 +59,7 @@
$$x $(INSTALLBINARIES); \
done
@@ -311,7 +311,7 @@
@@ -312,7 +312,7 @@
ifneq ($(SCRIPTS)x,x)
for x in $(SCRIPTS); \
do \
@ -68,7 +68,7 @@
$(INSTALLSCRIPTS); \
done
endif
@@ -348,7 +348,7 @@
@@ -349,7 +349,7 @@
# directory when you compile your programs.
for x in $(INTERFACE_HEADERS); \
do \
@ -77,29 +77,37 @@
$(INSTALLHDRS); \
done
@@ -356,19 +356,19 @@
@@ -357,7 +357,7 @@
#
.PHONY: install.staticlib
install.staticlib: lib$(LIBROOT).$(STATICLIBSUFFIX)
- $(INSTALL) -c -m $(INSTALL_PERM_LIBS) $< $(INSTALLSTATICLIBS)/$<
+ ${BSD_INSTALL_DATA} $< $(INSTALLSTATICLIBS)/$<
# Install a shared library
#
# Install a shared library stub -- the ".so" file used at link time to
# prepare a program for dynamically linking a library at run time
@@ -367,7 +367,7 @@
install.sharedlibstub:
cd $(INSTALLSTATICLIBS) ; \
rm -f lib$(LIBROOT).$(NETPBMLIBSUFFIX); \
- $(SYMLINK) $(INSTALLLIBS)/lib$(LIBROOT).$(NETPBMLIBSUFFIX).$(MAJ) \
+ $(SYMLINK) $(SONAME) \
lib$(LIBROOT).$(NETPBMLIBSUFFIX)
else
# I have no idea what link-time stuff is required for other library types.
@@ -381,12 +381,9 @@
.PHONY: install.lib.common
ifeq ($(NETPBMLIBTYPE),unixshared)
# install a Unix-style shared library
-install.lib.common: lib$(LIBROOT).$(NETPBMLIBSUFFIX).$(MAJ).$(MIN)
- cd $(INSTALLLIBS) ; rm -f lib$(LIBROOT).$(NETPBMLIBSUFFIX).$(MAJ).*
- $(INSTALL) -c -m $(INSTALL_PERM_LIBD) $< $(INSTALLLIBS)
+install.lib.common: $(SONAME)
+ cd $(INSTALLLIBS) ; rm -f lib$(LIBROOT).$(NETPBMLIBSUFFIX).*
+ ${BSD_INSTALL_DATA} $< $(INSTALLLIBS)
cd $(INSTALLLIBS) ; \
- cd $(INSTALLLIBS) ; \
- rm -f lib$(LIBROOT).$(NETPBMLIBSUFFIX).$(MAJ); \
- $(SYMLINK) $< lib$(LIBROOT).$(NETPBMLIBSUFFIX).$(MAJ)
+ rm -f lib$(LIBROOT).$(NETPBMLIBSUFFIX); \
+ $(SYMLINK) $< lib$(LIBROOT).$(NETPBMLIBSUFFIX)
+install.lib.common: $(SONAME)
+ cd $(INSTALLLIBS) ; rm -f $(SONAME)
+ ${BSD_INSTALL_DATA} $< $(INSTALLLIBS)
endif
ifeq ($(NETPBMLIBTYPE),dll)
#install a Windows DLL shared library

View file

@ -1,6 +1,6 @@
--- pnm/Makefile.orig Mon Nov 12 11:41:18 2001
+++ pnm/Makefile Sat Dec 8 00:00:00 2001
@@ -149,13 +149,14 @@
--- pnm/Makefile.orig Sat Jan 5 06:33:42 2002
+++ pnm/Makefile Sun Jan 6 00:00:00 2002
@@ -146,13 +146,14 @@
# MERGE_ALIASES is additional names to be linked to the merge binary which are
# alternate names for a program whose source is called something else.
# Every name here must be referenced in pnmmerge.c.
@ -16,7 +16,7 @@
MANUALS1 = $(BINARIES) $(SCRIPTS)
MANUALS3 = libpnm
@@ -173,7 +174,7 @@
@@ -170,7 +171,7 @@
$(MAKE) -C jbig all
$(MAKE) -C pnmtopalm all
PHONY: merge
@ -25,15 +25,14 @@
ifneq ($(BUILD_FIASCO), N)
$(MAKE) -C fiasco all
endif
@@ -261,11 +262,6 @@
@@ -260,10 +261,6 @@
.PHONY: install.man
install.man: install.man.common
-# The following are for programs that have been renamed
- rm $(INSTALLMANUALS1)/pnmnowraw.*
- rm $(INSTALLMANUALS1)/gemtopnm.*
- rm $(INSTALLMANUALS1)/pnminterp.*
- rm $(INSTALLMANUALS1)/ppmtojpeg.*
- rm -f $(INSTALLMANUALS1)/pnmnoraw.*
- rm -f $(INSTALLMANUALS1)/gemtopnm.*
- rm -f $(INSTALLMANUALS1)/pnminterp.*
ifneq ($(BUILD_FIASCO), N)
$(MAKE) -C fiasco install.man
endif

View file

@ -104,6 +104,7 @@ bin/pngtopnm
bin/pnmalias
bin/pnmarith
bin/pnmcat
bin/pnmcolormap
bin/pnmcomp
bin/pnmconvol
bin/pnmcrop
@ -125,6 +126,7 @@ bin/pnmpad
bin/pnmpaste
bin/pnmpsnr
bin/pnmquant
bin/pnmremap
bin/pnmrotate
bin/pnmscale
bin/pnmscalefixed
@ -152,6 +154,7 @@ bin/ppmbrighten
bin/ppmchange
bin/ppmcie
bin/ppmcolormask
bin/ppmcolors
bin/ppmdim
bin/ppmdist
bin/ppmdither
@ -230,6 +233,7 @@ bin/ybmtopbm
bin/yuvsplittoppm
bin/yuvtoppm
bin/zeisstopnm
include/pam.h
include/pbm.h
include/pgm.h
include/pm.h