net/zerotier: update 1.2.4 to 1.2.8
- add debugging support to stdout as ports option - fix clang++ 6.0.0 compatibility - add ipfilter to rcorder list Reviewed by: mat Approved by: jrm (mentor) Differential Revision: https://reviews.freebsd.org/D15133
This commit is contained in:
parent
0c0e52f979
commit
4b8535d8f4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=470435
5 changed files with 31 additions and 6 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= zerotier
|
||||
PORTVERSION= 1.2.4
|
||||
PORTREVISION= 2
|
||||
DISTVERSION= 1.2.8
|
||||
CATEGORIES= net
|
||||
|
||||
MAINTAINER= dch@FreeBSD.org
|
||||
|
@ -24,6 +23,10 @@ GH_PROJECT= ZeroTierOne
|
|||
|
||||
CFLAGS+= -flax-vector-conversions
|
||||
|
||||
OPTIONS_DEFINE= DBG
|
||||
DBG_DESC= Enable foreground debugging for zerotier-one daemon
|
||||
DBG_ALL_TARGET= debug
|
||||
|
||||
PLIST_FILES= bin/zerotier-cli bin/zerotier-idtool sbin/zerotier-one
|
||||
|
||||
do-install:
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1493361909
|
||||
SHA256 (zerotier-ZeroTierOne-1.2.4_GH0.tar.gz) = 9f275b3732b721f02cc4b8df75b51e6a8fb56dfe1a542a7bd681538d852b0358
|
||||
SIZE (zerotier-ZeroTierOne-1.2.4_GH0.tar.gz) = 7963254
|
||||
TIMESTAMP = 1525679369
|
||||
SHA256 (zerotier-ZeroTierOne-1.2.8_GH0.tar.gz) = 08e2df34550d6bb68e106eaac48babb481160046818b0944ec41f1e158548a47
|
||||
SIZE (zerotier-ZeroTierOne-1.2.8_GH0.tar.gz) = 6009764
|
||||
|
|
11
net/zerotier/files/patch-make-bsd.mk
Normal file
11
net/zerotier/files/patch-make-bsd.mk
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- make-bsd.mk.orig 2018-05-18 08:50:17 UTC
|
||||
+++ make-bsd.mk
|
||||
@@ -159,7 +159,7 @@ clean:
|
||||
rm -rf *.a *.o node/*.o controller/*.o osdep/*.o service/*.o ext/http-parser/*.o build-* zerotier-one zerotier-idtool zerotier-selftest zerotier-cli $(ONE_OBJS) $(CORE_OBJS)
|
||||
|
||||
debug: FORCE
|
||||
- gmake -j 4 ZT_DEBUG=1
|
||||
+ $(MAKE) -j ZT_DEBUG=1
|
||||
|
||||
install: one
|
||||
rm -f /usr/local/sbin/zerotier-one
|
11
net/zerotier/files/patch-node_Packet.cpp
Normal file
11
net/zerotier/files/patch-node_Packet.cpp
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- node/Packet.cpp.orig 2018-05-18 09:03:14 UTC
|
||||
+++ node/Packet.cpp
|
||||
@@ -332,7 +332,7 @@ static const int LZ4_minLength = (MFLIMIT+1);
|
||||
|
||||
#define LZ4_STATIC_ASSERT(c) { enum { LZ4_static_assert = 1/(int)(!!(c)) }; } /* use only *after* variable declarations */
|
||||
|
||||
-static inline unsigned LZ4_NbCommonBytes (register reg_t val)
|
||||
+static inline unsigned LZ4_NbCommonBytes (reg_t val)
|
||||
{
|
||||
if (LZ4_isLittleEndian()) {
|
||||
if (sizeof(val)==8) {
|
|
@ -4,7 +4,7 @@
|
|||
#
|
||||
# PROVIDE: zerotier
|
||||
# REQUIRE: FILESYSTEMS netif
|
||||
# BEFORE: pf ipfw
|
||||
# BEFORE: pf ipfw ipfilter
|
||||
# KEYWORD: shutdown
|
||||
#
|
||||
# Add these lines to /etc/rc.conf.local or /etc/rc.conf
|
||||
|
|
Loading…
Reference in a new issue