Make portsdb -U use the canonical way to make a ports index file now

that make index has got fast enough.

Suggested by:	kris
This commit is contained in:
Akinori MUSHA 2004-02-07 08:56:58 +00:00
parent d260313719
commit 4bb4e26f2b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=100230
12 changed files with 276 additions and 12 deletions

View file

@ -7,7 +7,7 @@
PORTNAME= portupgrade
PORTVERSION= 20040113
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iDaemons.org/pub/distfiles/ \
${MASTER_SITE_LOCAL}

View file

@ -0,0 +1,68 @@
Index: bin/Makefile
===================================================================
RCS file: /home/cvs/pkgtools/bin/Makefile,v
retrieving revision 1.6
diff -u -u -0 -r1.6 Makefile
--- bin/Makefile 26 Jan 2002 23:57:34 -0000 1.6
+++ bin/Makefile 7 Feb 2004 08:49:02 -0000
@@ -7,3 +7 @@
-SCRIPTS= ${BUILDDIR}/make_describe_pass1 \
- ${BUILDDIR}/make_describe_pass2 \
- ${BUILDDIR}/pkg_fetch \
+SCRIPTS= ${BUILDDIR}/pkg_fetch \
Index: bin/portupgrade
===================================================================
RCS file: /home/cvs/pkgtools/bin/portupgrade,v
retrieving revision 1.220
diff -u -u -0 -r1.220 portupgrade
--- bin/portupgrade 23 Jul 2003 12:23:03 -0000 1.220
+++ bin/portupgrade 22 Aug 2003 07:41:57 -0000
@@ -174,0 +175 @@
+ $new_force = false
@@ -327,2 +328,7 @@
- "packages (default: #{MYNAME == 'portinstall' ? 'on' : 'off'})") {
- |$new|
+ "packages; Specified twice, always install a new" << NEXTLINE <<
+ "one instead of upgrading (default: #{MYNAME == 'portinstall' ? 'on' : 'off'})") {
+ if $new
+ $new_force = true
+ else
+ $new = true
+ end
Index: lib/pkgdb.rb
===================================================================
RCS file: /home/cvs/pkgtools/lib/pkgdb.rb,v
retrieving revision 1.112
diff -u -u -0 -r1.112 pkgdb.rb
--- lib/pkgdb.rb 23 Jul 2003 12:23:05 -0000 1.112
+++ lib/pkgdb.rb 7 Feb 2004 08:52:43 -0000
@@ -45,2 +44,0 @@
- :make_describe_pass1 => "#{PREFIX}/sbin/make_describe_pass1",
- :make_describe_pass2 => "#{PREFIX}/sbin/make_describe_pass2",
Index: lib/portsdb.rb
===================================================================
RCS file: /home/cvs/pkgtools/lib/portsdb.rb,v
retrieving revision 1.78
diff -u -u -0 -r1.78 portsdb.rb
--- lib/portsdb.rb 23 Jul 2003 12:23:05 -0000 1.78
+++ lib/portsdb.rb 7 Feb 2004 08:52:26 -0000
@@ -340,18 +340 @@
- if true
- system %`
- #{PkgDB::command(:make_describe_pass1)} |
- #{PkgDB::command(:make_describe_pass2)} |
- (cd #{abs_ports_dir} && perl Tools/make_index) |
- sed -e 's./.\001.g' |
- sort -t '|' +1 -2 |
- sed -e 's.\001./.g' > #{tmp}
- `
- else
- system %`
- cd #{abs_ports_dir} && (make describe ECHO_MSG='echo > /dev/null' 2> /dev/null |
- perl Tools/make_index) |
- sed -e 's./.\001.g' |
- sort -t '|' +1 -2 |
- sed -e 's.\001./.g' > #{tmp}
- `
- end
+ system "cd #{abs_ports_dir} && make INDEXFILE=INDEX.tmp index && mv INDEX.tmp #{tmp}"

View file

@ -1,8 +1,6 @@
etc/rc.d/000.pkgtools.sh
@exec /bin/mkdir -p %D/lib/compat/pkg
@unexec /bin/rmdir %D/lib/compat/pkg 2>/dev/null || true
sbin/make_describe_pass1
sbin/make_describe_pass2
sbin/pkg_deinstall
sbin/pkg_fetch
sbin/pkg_glob

View file

@ -7,7 +7,7 @@
PORTNAME= portupgrade
PORTVERSION= 20040113
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iDaemons.org/pub/distfiles/ \
${MASTER_SITE_LOCAL}

View file

@ -0,0 +1,68 @@
Index: bin/Makefile
===================================================================
RCS file: /home/cvs/pkgtools/bin/Makefile,v
retrieving revision 1.6
diff -u -u -0 -r1.6 Makefile
--- bin/Makefile 26 Jan 2002 23:57:34 -0000 1.6
+++ bin/Makefile 7 Feb 2004 08:49:02 -0000
@@ -7,3 +7 @@
-SCRIPTS= ${BUILDDIR}/make_describe_pass1 \
- ${BUILDDIR}/make_describe_pass2 \
- ${BUILDDIR}/pkg_fetch \
+SCRIPTS= ${BUILDDIR}/pkg_fetch \
Index: bin/portupgrade
===================================================================
RCS file: /home/cvs/pkgtools/bin/portupgrade,v
retrieving revision 1.220
diff -u -u -0 -r1.220 portupgrade
--- bin/portupgrade 23 Jul 2003 12:23:03 -0000 1.220
+++ bin/portupgrade 22 Aug 2003 07:41:57 -0000
@@ -174,0 +175 @@
+ $new_force = false
@@ -327,2 +328,7 @@
- "packages (default: #{MYNAME == 'portinstall' ? 'on' : 'off'})") {
- |$new|
+ "packages; Specified twice, always install a new" << NEXTLINE <<
+ "one instead of upgrading (default: #{MYNAME == 'portinstall' ? 'on' : 'off'})") {
+ if $new
+ $new_force = true
+ else
+ $new = true
+ end
Index: lib/pkgdb.rb
===================================================================
RCS file: /home/cvs/pkgtools/lib/pkgdb.rb,v
retrieving revision 1.112
diff -u -u -0 -r1.112 pkgdb.rb
--- lib/pkgdb.rb 23 Jul 2003 12:23:05 -0000 1.112
+++ lib/pkgdb.rb 7 Feb 2004 08:52:43 -0000
@@ -45,2 +44,0 @@
- :make_describe_pass1 => "#{PREFIX}/sbin/make_describe_pass1",
- :make_describe_pass2 => "#{PREFIX}/sbin/make_describe_pass2",
Index: lib/portsdb.rb
===================================================================
RCS file: /home/cvs/pkgtools/lib/portsdb.rb,v
retrieving revision 1.78
diff -u -u -0 -r1.78 portsdb.rb
--- lib/portsdb.rb 23 Jul 2003 12:23:05 -0000 1.78
+++ lib/portsdb.rb 7 Feb 2004 08:52:26 -0000
@@ -340,18 +340 @@
- if true
- system %`
- #{PkgDB::command(:make_describe_pass1)} |
- #{PkgDB::command(:make_describe_pass2)} |
- (cd #{abs_ports_dir} && perl Tools/make_index) |
- sed -e 's./.\001.g' |
- sort -t '|' +1 -2 |
- sed -e 's.\001./.g' > #{tmp}
- `
- else
- system %`
- cd #{abs_ports_dir} && (make describe ECHO_MSG='echo > /dev/null' 2> /dev/null |
- perl Tools/make_index) |
- sed -e 's./.\001.g' |
- sort -t '|' +1 -2 |
- sed -e 's.\001./.g' > #{tmp}
- `
- end
+ system "cd #{abs_ports_dir} && make INDEXFILE=INDEX.tmp index && mv INDEX.tmp #{tmp}"

View file

@ -1,8 +1,6 @@
etc/rc.d/000.pkgtools.sh
@exec /bin/mkdir -p %D/lib/compat/pkg
@unexec /bin/rmdir %D/lib/compat/pkg 2>/dev/null || true
sbin/make_describe_pass1
sbin/make_describe_pass2
sbin/pkg_deinstall
sbin/pkg_fetch
sbin/pkg_glob

View file

@ -7,7 +7,7 @@
PORTNAME= portupgrade
PORTVERSION= 20040113
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iDaemons.org/pub/distfiles/ \
${MASTER_SITE_LOCAL}

View file

@ -0,0 +1,68 @@
Index: bin/Makefile
===================================================================
RCS file: /home/cvs/pkgtools/bin/Makefile,v
retrieving revision 1.6
diff -u -u -0 -r1.6 Makefile
--- bin/Makefile 26 Jan 2002 23:57:34 -0000 1.6
+++ bin/Makefile 7 Feb 2004 08:49:02 -0000
@@ -7,3 +7 @@
-SCRIPTS= ${BUILDDIR}/make_describe_pass1 \
- ${BUILDDIR}/make_describe_pass2 \
- ${BUILDDIR}/pkg_fetch \
+SCRIPTS= ${BUILDDIR}/pkg_fetch \
Index: bin/portupgrade
===================================================================
RCS file: /home/cvs/pkgtools/bin/portupgrade,v
retrieving revision 1.220
diff -u -u -0 -r1.220 portupgrade
--- bin/portupgrade 23 Jul 2003 12:23:03 -0000 1.220
+++ bin/portupgrade 22 Aug 2003 07:41:57 -0000
@@ -174,0 +175 @@
+ $new_force = false
@@ -327,2 +328,7 @@
- "packages (default: #{MYNAME == 'portinstall' ? 'on' : 'off'})") {
- |$new|
+ "packages; Specified twice, always install a new" << NEXTLINE <<
+ "one instead of upgrading (default: #{MYNAME == 'portinstall' ? 'on' : 'off'})") {
+ if $new
+ $new_force = true
+ else
+ $new = true
+ end
Index: lib/pkgdb.rb
===================================================================
RCS file: /home/cvs/pkgtools/lib/pkgdb.rb,v
retrieving revision 1.112
diff -u -u -0 -r1.112 pkgdb.rb
--- lib/pkgdb.rb 23 Jul 2003 12:23:05 -0000 1.112
+++ lib/pkgdb.rb 7 Feb 2004 08:52:43 -0000
@@ -45,2 +44,0 @@
- :make_describe_pass1 => "#{PREFIX}/sbin/make_describe_pass1",
- :make_describe_pass2 => "#{PREFIX}/sbin/make_describe_pass2",
Index: lib/portsdb.rb
===================================================================
RCS file: /home/cvs/pkgtools/lib/portsdb.rb,v
retrieving revision 1.78
diff -u -u -0 -r1.78 portsdb.rb
--- lib/portsdb.rb 23 Jul 2003 12:23:05 -0000 1.78
+++ lib/portsdb.rb 7 Feb 2004 08:52:26 -0000
@@ -340,18 +340 @@
- if true
- system %`
- #{PkgDB::command(:make_describe_pass1)} |
- #{PkgDB::command(:make_describe_pass2)} |
- (cd #{abs_ports_dir} && perl Tools/make_index) |
- sed -e 's./.\001.g' |
- sort -t '|' +1 -2 |
- sed -e 's.\001./.g' > #{tmp}
- `
- else
- system %`
- cd #{abs_ports_dir} && (make describe ECHO_MSG='echo > /dev/null' 2> /dev/null |
- perl Tools/make_index) |
- sed -e 's./.\001.g' |
- sort -t '|' +1 -2 |
- sed -e 's.\001./.g' > #{tmp}
- `
- end
+ system "cd #{abs_ports_dir} && make INDEXFILE=INDEX.tmp index && mv INDEX.tmp #{tmp}"

View file

@ -1,8 +1,6 @@
etc/rc.d/000.pkgtools.sh
@exec /bin/mkdir -p %D/lib/compat/pkg
@unexec /bin/rmdir %D/lib/compat/pkg 2>/dev/null || true
sbin/make_describe_pass1
sbin/make_describe_pass2
sbin/pkg_deinstall
sbin/pkg_fetch
sbin/pkg_glob

View file

@ -7,7 +7,7 @@
PORTNAME= portupgrade
PORTVERSION= 20040113
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iDaemons.org/pub/distfiles/ \
${MASTER_SITE_LOCAL}

View file

@ -0,0 +1,68 @@
Index: bin/Makefile
===================================================================
RCS file: /home/cvs/pkgtools/bin/Makefile,v
retrieving revision 1.6
diff -u -u -0 -r1.6 Makefile
--- bin/Makefile 26 Jan 2002 23:57:34 -0000 1.6
+++ bin/Makefile 7 Feb 2004 08:49:02 -0000
@@ -7,3 +7 @@
-SCRIPTS= ${BUILDDIR}/make_describe_pass1 \
- ${BUILDDIR}/make_describe_pass2 \
- ${BUILDDIR}/pkg_fetch \
+SCRIPTS= ${BUILDDIR}/pkg_fetch \
Index: bin/portupgrade
===================================================================
RCS file: /home/cvs/pkgtools/bin/portupgrade,v
retrieving revision 1.220
diff -u -u -0 -r1.220 portupgrade
--- bin/portupgrade 23 Jul 2003 12:23:03 -0000 1.220
+++ bin/portupgrade 22 Aug 2003 07:41:57 -0000
@@ -174,0 +175 @@
+ $new_force = false
@@ -327,2 +328,7 @@
- "packages (default: #{MYNAME == 'portinstall' ? 'on' : 'off'})") {
- |$new|
+ "packages; Specified twice, always install a new" << NEXTLINE <<
+ "one instead of upgrading (default: #{MYNAME == 'portinstall' ? 'on' : 'off'})") {
+ if $new
+ $new_force = true
+ else
+ $new = true
+ end
Index: lib/pkgdb.rb
===================================================================
RCS file: /home/cvs/pkgtools/lib/pkgdb.rb,v
retrieving revision 1.112
diff -u -u -0 -r1.112 pkgdb.rb
--- lib/pkgdb.rb 23 Jul 2003 12:23:05 -0000 1.112
+++ lib/pkgdb.rb 7 Feb 2004 08:52:43 -0000
@@ -45,2 +44,0 @@
- :make_describe_pass1 => "#{PREFIX}/sbin/make_describe_pass1",
- :make_describe_pass2 => "#{PREFIX}/sbin/make_describe_pass2",
Index: lib/portsdb.rb
===================================================================
RCS file: /home/cvs/pkgtools/lib/portsdb.rb,v
retrieving revision 1.78
diff -u -u -0 -r1.78 portsdb.rb
--- lib/portsdb.rb 23 Jul 2003 12:23:05 -0000 1.78
+++ lib/portsdb.rb 7 Feb 2004 08:52:26 -0000
@@ -340,18 +340 @@
- if true
- system %`
- #{PkgDB::command(:make_describe_pass1)} |
- #{PkgDB::command(:make_describe_pass2)} |
- (cd #{abs_ports_dir} && perl Tools/make_index) |
- sed -e 's./.\001.g' |
- sort -t '|' +1 -2 |
- sed -e 's.\001./.g' > #{tmp}
- `
- else
- system %`
- cd #{abs_ports_dir} && (make describe ECHO_MSG='echo > /dev/null' 2> /dev/null |
- perl Tools/make_index) |
- sed -e 's./.\001.g' |
- sort -t '|' +1 -2 |
- sed -e 's.\001./.g' > #{tmp}
- `
- end
+ system "cd #{abs_ports_dir} && make INDEXFILE=INDEX.tmp index && mv INDEX.tmp #{tmp}"

View file

@ -1,8 +1,6 @@
etc/rc.d/000.pkgtools.sh
@exec /bin/mkdir -p %D/lib/compat/pkg
@unexec /bin/rmdir %D/lib/compat/pkg 2>/dev/null || true
sbin/make_describe_pass1
sbin/make_describe_pass2
sbin/pkg_deinstall
sbin/pkg_fetch
sbin/pkg_glob