- Update to 5.3.1.

- Default OCC to OFF.
- Mark broken only if OCC is set.
This commit is contained in:
Stephen Montgomery-Smith 2016-01-18 05:58:09 +00:00
parent 01ab978712
commit 4bdd185116
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=406547
12 changed files with 40 additions and 55 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= netgen
PORTVERSION= 5.0.0
PORTREVISION= 4
PORTVERSION= 5.3.1
CATEGORIES= cad
MASTER_SITES= SF/netgen-mesher/netgen-mesher/${PORTVERSION:S|.0$||}/
@ -13,7 +12,7 @@ COMMENT= Automatic 3D tetrahedral mesh generator
LIB_DEPENDS= libTix8.4.3.so:${PORTSDIR}/x11-toolkits/tix \
libtogl.so:${PORTSDIR}/graphics/togl
BROKEN= Does not compile because of issues with cad/opencascade
OCC_BROKEN= Does not compile because of issues with cad/opencascade
USE_LDCONFIG= yes
USES= gmake jpeg libtool tk
@ -30,7 +29,7 @@ FETCH_BEFORE_ARGS+= -o ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}
OPTIONS_DEFINE= OCC FFMPEG
OCC_DESC= Compile with OpenCascade geometry kernel
FFMPEG_DESC= video recording with FFmpeg
OPTIONS_DEFAULT= OCC
OPTIONS_DEFAULT= # OCC
BROKEN_sparc64= internal gcc error (Bug 23159)

View file

@ -1,2 +1,2 @@
SHA256 (netgen-5.0.0.tar.gz) = c122aa41fe6cc7c491df5df40c1c2a5633ee96a36d363a630ff1c5c4e4921419
SIZE (netgen-5.0.0.tar.gz) = 1835004
SHA256 (netgen-5.3.1.tar.gz) = cb97f79d8f4d55c00506ab334867285cde10873c8a8dc783522b47d2bc128bf9
SIZE (netgen-5.3.1.tar.gz) = 1857185

View file

@ -1,5 +1,5 @@
--- libsrc/occ/Makefile.am.orig 2010-11-08 10:10:46.000000000 +0600
+++ libsrc/occ/Makefile.am 2010-11-08 10:10:57.000000000 +0600
--- libsrc/occ/Makefile.am.orig 2014-08-29 09:54:03 UTC
+++ libsrc/occ/Makefile.am
@@ -1,5 +1,4 @@
-noinst_HEADERS = occgeom.hpp occmeshsurf.hpp \
-Partition_Inter2d.hxx Partition_Loop2d.hxx Partition_Loop.hxx \

View file

@ -1,13 +0,0 @@
--- libsrc/occ/Partition_Inter3d.cxx.orig 2012-11-09 16:15:02.000000000 +0100
+++ libsrc/occ/Partition_Inter3d.cxx 2013-05-12 11:31:45.000000000 +0200
@@ -243,8 +243,8 @@
Standard_Integer i, nbExt = anExtPS.NbExt();
Extrema_POnSurf aPOnSurf;
for (i = 1; i <= nbExt; ++i )
- if (anExtPS.Value( i ) <= TolE) // V6.3
- // if (anExtPS.SquareDistance( i ) <= TolE) // V6.5
+ // if (anExtPS.Value( i ) <= TolE) // V6.3
+ if (anExtPS.SquareDistance( i ) <= TolE) // V6.5
{
aPOnSurf = anExtPS.Point( i );
break;

View file

@ -1,13 +0,0 @@
--- libsrc/occ/Partition_Spliter.cxx.orig 2012-11-09 16:15:02.000000000 +0100
+++ libsrc/occ/Partition_Spliter.cxx 2013-05-12 11:35:38.000000000 +0200
@@ -1169,8 +1169,8 @@
for (; j<=nbj && ok; ++j) {
if (Extrema.IsMin(j)) {
hasMin = Standard_True;
- ok = Extrema.Value(j) <= tol; // V6.3
- // ok = Extrema.SquareDistance(j) <= tol; // V6.5
+ // ok = Extrema.Value(j) <= tol; // V6.3
+ ok = Extrema.SquareDistance(j) <= tol; // V6.5
}
}
}

View file

@ -1,5 +1,5 @@
--- libsrc/occ/Partition_Loop2d.cxx.orig 2012-11-09 16:15:02.000000000 +0100
+++ libsrc/occ/Partition_Loop2d.cxx 2013-05-12 11:41:09.000000000 +0200
--- libsrc/occ/Partition_Loop2d.cxx.orig 2014-08-29 09:54:03 UTC
+++ libsrc/occ/Partition_Loop2d.cxx
@@ -52,6 +52,10 @@
#include <gp_Pnt.hxx>
#include <gp_Pnt2d.hxx>

View file

@ -1,11 +1,11 @@
--- ng/Makefile.am-orig 2012-11-22 00:29:00.000000000 +0000
+++ ng/Makefile.am 2012-11-22 00:29:28.000000000 +0000
@@ -14,7 +14,7 @@
--- ng/Makefile.am.orig 2014-08-29 09:54:01 UTC
+++ ng/Makefile.am
@@ -22,7 +22,7 @@ netgen_LDADD = $(top_builddir)/libsrc/vi
$(top_builddir)/libsrc/csg/libcsg.la \
$(top_builddir)/libsrc/interface/libinterface.la \
$(top_builddir)/libsrc/meshing/libmesh.la \
- -L$(TK_BIN_DIR)/Togl1.7 $(TOGLLIBDIR) -lTogl $(LIBGLU) $(TK_LIB_SPEC) $(TCL_LIB_SPEC) $(MPI_LIBS) $(FFMPEG_LIBS) $(JPEGLIB_LIBS) $(PKG_LIBS)
+ -L$(TK_BIN_DIR)/Togl-1.7 $(TOGLLIBDIR) -ltogl $(LIBGLU) $(TK_LIB_SPEC) $(TCL_LIB_SPEC) $(MPI_LIBS) $(FFMPEG_LIBS) $(JPEGLIB_LIBS) $(PKG_LIBS)
- -L$(TK_BIN_DIR)/Togl1.7 $(TOGLLIBDIR) -lTogl $(LIBGLU) $(TK_LIB_SPEC) $(TCL_LIB_SPEC) $(MPI_LIBS) $(FFMPEG_LIBS) $(JPEGLIB_LIBS) $(PKG_LIBS) $(MKL_LIBS)
+ -ltogl $(LIBGLU) $(TK_LIB_SPEC) $(TCL_LIB_SPEC) $(MPI_LIBS) $(FFMPEG_LIBS) $(JPEGLIB_LIBS) $(PKG_LIBS) $(MKL_LIBS)
#
# $(top_builddir)/libsrc/occ/liboccvis.la
# $(top_builddir)/libsrc/occ/libocc.la

View file

@ -1,11 +1,11 @@
--- ng/Makefile.in-orig 2012-11-22 00:40:30.000000000 +0000
+++ ng/Makefile.in 2012-11-22 00:41:00.000000000 +0000
@@ -303,7 +303,7 @@
--- ng/Makefile.in.orig 2014-10-06 11:04:37 UTC
+++ ng/Makefile.in
@@ -312,7 +312,7 @@ netgen_LDADD = $(top_builddir)/libsrc/vi
$(top_builddir)/libsrc/csg/libcsg.la \
$(top_builddir)/libsrc/interface/libinterface.la \
$(top_builddir)/libsrc/meshing/libmesh.la \
- -L$(TK_BIN_DIR)/Togl1.7 $(TOGLLIBDIR) -lTogl $(LIBGLU) $(TK_LIB_SPEC) $(TCL_LIB_SPEC) $(MPI_LIBS) $(FFMPEG_LIBS) $(JPEGLIB_LIBS) $(PKG_LIBS)
+ -L$(TK_BIN_DIR)/Togl-1.7 $(TOGLLIBDIR) -ltogl $(LIBGLU) $(TK_LIB_SPEC) $(TCL_LIB_SPEC) $(MPI_LIBS) $(FFMPEG_LIBS) $(JPEGLIB_LIBS) $(PKG_LIBS)
- -L$(TK_BIN_DIR)/Togl1.7 $(TOGLLIBDIR) -lTogl $(LIBGLU) $(TK_LIB_SPEC) $(TCL_LIB_SPEC) $(MPI_LIBS) $(FFMPEG_LIBS) $(JPEGLIB_LIBS) $(PKG_LIBS) $(MKL_LIBS)
+ -ltogl $(LIBGLU) $(TK_LIB_SPEC) $(TCL_LIB_SPEC) $(MPI_LIBS) $(FFMPEG_LIBS) $(JPEGLIB_LIBS) $(PKG_LIBS) $(MKL_LIBS)
#
# $(top_builddir)/libsrc/occ/liboccvis.la

View file

@ -1,6 +1,6 @@
--- ng/ng.tcl.orig 2010-06-08 09:33:22.000000000 +0700
+++ ng/ng.tcl 2010-06-08 09:33:39.000000000 +0700
@@ -26,7 +26,7 @@
--- ng/ng.tcl.orig 2014-08-29 09:54:01 UTC
+++ ng/ng.tcl
@@ -32,7 +32,7 @@ if { [lsearch [array names env] NETGENDI
set ngdir $env(NETGENDIR)
}
if { [string length $ngdir] == 0 } {

View file

@ -1,6 +1,6 @@
--- ng/ngappinit.cpp.orig 2010-06-08 09:13:06.000000000 +0700
+++ ng/ngappinit.cpp 2010-06-08 09:13:20.000000000 +0700
@@ -151,7 +151,7 @@
--- ng/ngappinit.cpp.orig 2014-08-29 09:54:01 UTC
+++ ng/ngappinit.cpp
@@ -149,7 +149,7 @@ int main(int argc, char ** argv)
if (getenv ("NETGENDIR") && strlen (getenv ("NETGENDIR")))
ngdir = getenv ("NETGENDIR");
else

View file

@ -0,0 +1,11 @@
--- nglib/Makefile.in.orig 2014-10-06 11:04:37 UTC
+++ nglib/Makefile.in
@@ -129,7 +129,7 @@ LTCXXCOMPILE = $(LIBTOOL) --tag=CXX $(AM
CXXLD = $(CXX)
CXXLINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) \
- $(LDFLAGS) -o $@
+ $(LDFLAGS) -o $@ -pthread
SOURCES = $(libnglib_la_SOURCES) $(ng_stl_SOURCES) $(ng_vol_SOURCES)
DIST_SOURCES = $(libnglib_la_SOURCES) $(ng_stl_SOURCES) \
$(ng_vol_SOURCES)

View file

@ -118,6 +118,7 @@ lib/libstlvis.so.0.0.0
%%DATADIR%%/include/adfront3.hpp
%%DATADIR%%/include/adtree.hpp
%%DATADIR%%/include/algprim.hpp
%%DATADIR%%/include/archive_base.hpp
%%DATADIR%%/include/array.hpp
%%DATADIR%%/include/autodiff.hpp
%%DATADIR%%/include/autoptr.hpp