Add iiimf-gnome-im-switcher.

This port provides two input method utility applications for GNOME desktop
environments.

  GIMLET - GNOME Input Method Language Enabling Tool

As a gnome-panel applet, this UI is used to select input languages for IIIM
client applications (IIIMGCF and IIIMXCF).

  GIMPET - GNOME Input Method Property Edittingggg Tool

As a gnome capplet, this UI is to allow user to customize input methods,
for enabling/disabling input method infrastucuture itself, and
enabling/disabling input method statur bar and candidate choice window.

PR:		ports/72617
Submitted by:	Kuang-che Wu <kcwu@csie.org>
This commit is contained in:
Pav Lucistnik 2004-10-13 22:19:24 +00:00
parent 6851294cd9
commit 4be27411d4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=119318
8 changed files with 137 additions and 0 deletions

View file

@ -151,6 +151,7 @@
SUBDIR += idnits
SUBDIR += iiimf-client-lib
SUBDIR += iiimf-csconv
SUBDIR += iiimf-gnome-im-switcher
SUBDIR += iiimf-gtk
SUBDIR += iiimf-headers
SUBDIR += iiimf-le-unit

View file

@ -0,0 +1,54 @@
# New ports collection makefile for: iiimf-gnome-im-switcher
# Date created: 10 Sep 2004
# Whom: Kuang-che Wu <kcwu@csie.org>
#
# $FreeBSD$
#
PORTNAME= gnome-im-switcher
PORTVERSION= ${IIIMF_VER:S/_/./g:C/-.*//}
CATEGORIES= textproc
MASTER_SITES= http://www.openi18n.org/download/im-sdk/src/
PKGNAMEPREFIX= iiimf-
DISTNAME= im-sdk
DISTFILES= ${DISTNAME}-src-${IIIMF_VER}.tgz
MAINTAINER= kcwu@csie.org
COMMENT= IIIMF gnome input method switcher
IIIMF_VER= r12_0_1-svn1891
WRKSRC= ${WRKDIR}/${DISTNAME}-${IIIMF_VER}/gnome-im-switcher
USE_GNOME= gconf2 libglade2 libgnomeui gnomepanel gnomehack
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_AUTOCONF_VER= 259
USE_AUTOHEADER_VER= 259
USE_AUTOMAKE_VER= 19
USE_LIBTOOL_VER= 15
AUTOMAKE_ARGS= --add-missing --copy --gnu
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
post-patch:
${REINPLACE_CMD} -e "s,/usr/lib/im,${PREFIX}/lib/im,g" \
${WRKSRC}/../acfiles/im_common.m4
${FIND} ${WRKSRC} -name "Makefile.am*" | ${XARGS} ${REINPLACE_CMD} -e \
's|[(]GNOME_datadir[)]/gnome/|(datadir)/|g ; \
s|[(]GNOME_datadir[)]/locale|(prefix)/share/locale|g ; \
s|[(]datadir[)]/locale|(prefix)/share/locale|g ; \
s|[(]libdir[)]/locale|(prefix)/share/locale|g ; \
s|[(]gnomedatadir[)]/gnome|(gnomedatadir)|g ; \
s|[(]datadir[)]/aclocal|(prefix)/share/aclocal|g ; \
s|[(]datadir[)]/gnome/|(datadir)/|g ; \
s|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
s|[$$][(]localstatedir[)]/scrollkeeper|${SCROLLKEEPER_DIR}|g ; \
s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g'
pre-configure:
cd ${WRKSRC} && glib-gettextize --force --copy
cd ${WRKSRC} && intltoolize --copy --force --automake
cd ${WRKSRC} && ${LIBTOOLIZE} --force --copy
cd ${WRKSRC} && ${ACLOCAL} -I ${LOCALBASE}/share/aclocal -I ../acfiles
${TOUCH} ${WRKSRC}/config.h.in
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
MD5 (im-sdk-src-r12_0_1-svn1891.tgz) = 4e51e4fd07391bd957622db0e89aeefe
SIZE (im-sdk-src-r12_0_1-svn1891.tgz) = 18206118

View file

@ -0,0 +1,12 @@
--- src/language.c.orig Thu Apr 29 20:23:29 2004
+++ src/language.c Wed Oct 13 22:52:28 2004
@@ -946,8 +946,8 @@
gimlet_language_get_conversion_mode (char *iiim_lang_name)
{
GSList *tmp;
- tmp = active_languages;
GimletLanguage *lang;
+ tmp = active_languages;
while (tmp != NULL)
{

View file

@ -0,0 +1,13 @@
--- src/quick-access-menu.c.orig Fri Jul 16 00:32:39 2004
+++ src/quick-access-menu.c Wed Oct 13 23:01:48 2004
@@ -279,9 +279,9 @@
GtkWidget *le_submenu;
GtkWidget *le_submenu_item;
GSList *legroup = NULL;
+ int i, len;
le_submenu = gtk_menu_new ();
- int i, len;
len = g_list_length (lelist);
le_submenu_item = gtk_radio_menu_item_new_with_label (legroup, lelist->data);
legroup = gtk_radio_menu_item_get_group (GTK_RADIO_MENU_ITEM (le_submenu_item));

View file

@ -0,0 +1,11 @@
--- src/widgets.c.orig Fri Sep 10 16:41:33 2004
+++ src/widgets.c Fri Sep 10 16:42:03 2004
@@ -29,7 +29,7 @@
#include <gnome.h>
#include <signal.h>
-#include <wait.h>
+#include <sys/wait.h>
#include "gnome-im-switcher.h"
#include "widgets.h"

View file

@ -0,0 +1,21 @@
IIIMF stands for Internet/Intranet Input Method Framework.
IIIMF is designed to be the next generation of input method framework
This port provides two input method utility applications for GNOME desktop
environments.
GIMLET - GNOME Input Method Language Enabling Tool
As a gnome-panel applet, this UI is used to select input languages for IIIM
client applications (IIIMGCF and IIIMXCF).
GIMPET - GNOME Input Method Property Edittingggg Tool
As a gnome capplet, this UI is to allow user to customize input methods,
for enabling/disabling input method infrastucuture itself, and
enabling/disabling input method statur bar and candidate choice window.
WWW: http://www.openi18n.org/subgroups/im/IIIMF/
- Kuang-che Wu
kcwu@csie.org

View file

@ -0,0 +1,23 @@
bin/gnome-im-properties
bin/gnome-im-settings-daemon
@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/gnome-im-properties.schemas >/dev/null || /usr/bin/true
etc/gconf/schemas/gnome-im-properties.schemas
@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/gnome-im-properties.schemas >/dev/null || /usr/bin/true
@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/gnome-im-switcher.schemas >/dev/null || /usr/bin/true
etc/gconf/schemas/gnome-im-switcher.schemas
@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/gnome-im-switcher.schemas >/dev/null || /usr/bin/true
libdata/bonobo/servers/GNOME_IMSwitcherApplet.server
libexec/gnome-im-switcher-applet
share/control-center-2.0/capplets/gnome-im-properties.desktop
share/control-center-2.0/interfaces/gnome-im-properties.glade2
share/gnome-2.0/ui/GNOME_InputMethodSwitcherApplet.xml
share/gnome-im-switcher/glade/gnome-im-switcher.glade2
share/icons/hicolor/48x48/apps/gnome-settings-im.png
share/pixmaps/gnome-settings-im.png
@dirrm share/control-center-2.0/capplets
@dirrm share/control-center-2.0/interfaces
@dirrm share/control-center-2.0
@dirrm share/gnome-2.0/ui
@dirrm share/gnome-2.0
@dirrm share/gnome-im-switcher/glade
@dirrm share/gnome-im-switcher