net/mDNSResponder: Update to 1790.80.10

- Update WWW and clean up pkg-descr

Changes:	https://github.com/apple-oss-distributions/mDNSResponder/commits/main
This commit is contained in:
Po-Chuan Hsieh 2023-04-06 01:13:45 +08:00
parent 65064bce8c
commit 4c0f8d39a1
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
10 changed files with 29 additions and 154 deletions

View file

@ -1,11 +1,12 @@
PORTNAME= mDNSResponder
PORTVERSION= 1310.140.1
PORTVERSION= 1790.80.10
CATEGORIES= net dns
MASTER_SITES= https://opensource.apple.com/tarballs/mDNSResponder/
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Bonjour (zero-configuration networking) by Apple
WWW= https://opensource.apple.com/tarballs/mDNSResponder/
WWW= https://developer.apple.com/bonjour/ \
https://github.com/apple-oss-distributions/mDNSResponder
LICENSE= APACHE20 BSD3CLAUSE
LICENSE_COMB= dual
@ -19,6 +20,7 @@ MAKE_ARGS= LDCONFIG=${TRUE} LOCALBASE=${PREFIX} MAN_PATH=${PREFIX}/share/man STR
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
USE_RC_SUBR= mdnsd mdnsresponderposix
WRKSRC= ${WRKDIR}/mDNSResponder-mDNSResponder-${PORTVERSION}
CPE_VENDOR= apple

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1632227472
SHA256 (mDNSResponder-1310.140.1.tar.gz) = 040f6495c18b9f0557bcf9e00cbcfc82b03405f5ba6963dc147730ca0ca90d6f
SIZE (mDNSResponder-1310.140.1.tar.gz) = 2631247
TIMESTAMP = 1679498540
SHA256 (mDNSResponder-1790.80.10.tar.gz) = ffb990231639dfe8c7f0b15d0665206a9013f1aacfb2cbb934eb87f6a57f38b7
SIZE (mDNSResponder-1790.80.10.tar.gz) = 2989629

View file

@ -1,16 +0,0 @@
--- Clients/dns-sd.c.orig 2021-01-26 20:47:47 UTC
+++ Clients/dns-sd.c
@@ -58,11 +58,13 @@
//#define TEST_NEW_CLIENTSTUB 1
#include <ctype.h>
+#include <stdarg.h> // For va_list
#include <stdio.h> // For stdout, stderr
#include <stdlib.h> // For exit()
#include <string.h> // For strlen(), strcpy()
#include <errno.h> // For errno, EINTR
#include <time.h>
+#include <sys/param.h> // For MIN
#include <sys/types.h> // For u_char
#ifdef APPLE_OSX_mDNSResponder
#include <inttypes.h> // For PRId64

View file

@ -1,10 +0,0 @@
--- mDNSCore/mDNS.c.orig 2019-07-20 09:39:10 UTC
+++ mDNSCore/mDNS.c
@@ -23,6 +23,7 @@
* routines, or types (which may or may not be present on any given platform).
*/
+#include <stddef.h>
#include "DNSCommon.h" // Defines general DNS utility routines
#include "uDNS.h" // Defines entry points into unicast-specific routines
#include "nsec.h"

View file

@ -1,6 +1,6 @@
--- mDNSPosix/Makefile.orig 2020-01-31 03:01:55 UTC
--- mDNSPosix/Makefile.orig 2023-01-24 00:43:17 UTC
+++ mDNSPosix/Makefile
@@ -62,8 +62,8 @@ else ifeq ($(SYSTEM), Linux)
@@ -53,8 +53,8 @@ else ifeq ($(SYSTEM), Linux)
os=linux
endif
@ -11,7 +11,7 @@
FLEX = flex
ST = strip
LD = ld
@@ -144,9 +144,9 @@ else
@@ -135,9 +135,9 @@ else
ifeq ($(os),freebsd)
# If not already defined, set LOCALBASE to /usr/local
@ -24,7 +24,7 @@
# FreeBSD 4 requires threaded code to be compiled and linked using the "-pthread" option,
# and requires that the "-lpthread" link option NOT be used
# This appies only to FreeBSD -- "man cc" on FreeBSD says:
@@ -211,11 +211,12 @@ endif
@@ -202,11 +202,12 @@ endif
endif
# If directory /usr/share/man exists, then we install man pages into that, else /usr/man
@ -42,7 +42,7 @@
# If directories /etc/init.d/rc*.d exist, then we install into that (Suse)
ifeq ($(wildcard /etc/init.d/rc2.d/), /etc/init.d/rc2.d/)
@@ -244,7 +245,7 @@ MDNSCFLAGS = $(CFLAGS) $(CFLAGS_COMMON) $(CFLAGS_OS) $
@@ -235,7 +236,7 @@ MDNSCFLAGS = $(CFLAGS) $(CFLAGS_COMMON) $(CFLAGS_OS) $
all: setup Daemon libdns_sd Clients SAClient SAResponder SAProxyResponder NetMonitor $(OPTIONALTARG)
@ -51,8 +51,8 @@
# 'setup' sets up the build directory structure the way we want
setup:
@@ -286,13 +287,13 @@ libdns_sd: setup $(BUILDDIR)/libdns_sd.$(LDSUFFIX)
CLIENTLIBOBJS = $(OBJDIR)/dnssd_clientlib.c.so.o $(OBJDIR)/dnssd_clientstub.c.so.o $(OBJDIR)/dnssd_ipc.c.so.o
@@ -276,13 +277,13 @@ libdns_sd: setup $(BUILDDIR)/libdns_sd.$(LDSUFFIX)
CLIENTLIBOBJS = $(OBJDIR)/dnssd_clientlib.c.so.o $(OBJDIR)/dnssd_clientstub.c.so.o $(OBJDIR)/dnssd_ipc.c.so.o $(OBJDIR)/dnssd_errstring.c.so.o
$(BUILDDIR)/libdns_sd.$(LDSUFFIX): $(CLIENTLIBOBJS)
- $(LD) $(SOOPTS) $(LINKOPTS) -o $@ $+
@ -68,7 +68,7 @@
$(MAKE) -C ../Clients DEBUG=$(DEBUG) SUPMAKE_CFLAGS="$(MDNSCFLAGS)"
# nss_mdns target builds the Name Service Switch module
@@ -300,7 +301,7 @@ nss_mdns: setup $(BUILDDIR)/$(NSSLIBFILE)
@@ -290,7 +291,7 @@ nss_mdns: setup $(BUILDDIR)/$(NSSLIBFILE)
@echo "Name Service Switch module done"
$(BUILDDIR)/$(NSSLIBFILE): $(CLIENTLIBOBJS) $(OBJDIR)/nss_mdns.c.so.o
@ -77,7 +77,7 @@
$(STRIP) $@
#############################################################################
@@ -325,14 +326,12 @@ InstalledNSS: $(NSSINSTPATH)/$(NSSLINKNAME) /etc/nss_m
@@ -315,14 +316,12 @@ InstalledNSS: $(NSSINSTPATH)/$(NSSLINKNAME) /etc/nss_m
@echo $+ " installed"
# Note: If daemon already installed, we make sure it's stopped before overwriting it
@ -94,7 +94,7 @@
ifdef LDCONFIG
# -m means 'merge into existing database', -R means 'rescan directories'
$(LDCONFIG) -mR
@@ -365,7 +364,7 @@ $(MANPATH)/man8/%.8: %.8
@@ -355,7 +354,7 @@ $(MANPATH)/man8/%.8: %.8
cp $< $@
chmod 444 $@
@ -103,7 +103,7 @@
cp $< $@
chmod 444 $@
@@ -509,6 +508,8 @@ $(OBJDIR)/NetMonitor.c.o: $(COREDIR)/mDNS.c
@@ -500,6 +499,8 @@ $(OBJDIR)/NetMonitor.c.o: $(COREDIR)/mDNS.c
$(BUILDDIR)/dnsextd: $(DNSEXTDOBJ) $(OBJDIR)/dnsextd.c.threadsafe.o
$(CC) $+ -o $@ $(LINKOPTS) $(LINKOPTS_PTHREAD)

View file

@ -1,42 +0,0 @@
--- mDNSPosix/mDNSPosix.c.orig 2019-06-27 09:29:40 UTC
+++ mDNSPosix/mDNSPosix.c
@@ -971,7 +971,7 @@ mDNSlocal int SetupSocket(struct sockaddr *intfAddr, m
// to bind to the socket. Our suggestion was to switch the order in which
// SO_REUSEPORT and SO_REUSEADDR was tested so that SO_REUSEADDR stays on
// top and SO_REUSEPORT to be used only if SO_REUSEADDR doesn't exist.
- #if defined(SO_REUSEADDR) && !defined(__MAC_OS_X_VERSION_MIN_REQUIRED)
+ #if defined(SO_REUSEADDR) && !defined(__MAC_OS_X_VERSION_MIN_REQUIRED) && !defined(__FreeBSD__)
err = setsockopt(*sktPtr, SOL_SOCKET, SO_REUSEADDR, &kOn, sizeof(kOn));
#elif defined(SO_REUSEPORT)
err = setsockopt(*sktPtr, SOL_SOCKET, SO_REUSEPORT, &kOn, sizeof(kOn));
@@ -1074,16 +1074,28 @@ mDNSlocal int SetupSocket(struct sockaddr *intfAddr, m
{
struct ipv6_mreq imr6;
struct sockaddr_in6 bindAddr6;
- #if defined(IPV6_PKTINFO)
+ #if defined(IPV6_RECVPKTINFO)
if (err == 0)
{
+ err = setsockopt(*sktPtr, IPPROTO_IPV6, IPV6_RECVPKTINFO, &kOn, sizeof(kOn));
+ if (err < 0) { err = errno; perror("setsockopt - IPV6_RECVPKTINFO"); }
+ }
+ #elif defined(IPV6_PKTINFO)
+ if (err == 0)
+ {
err = setsockopt(*sktPtr, IPPROTO_IPV6, IPV6_2292_PKTINFO, &kOn, sizeof(kOn));
if (err < 0) { err = errno; perror("setsockopt - IPV6_PKTINFO"); }
}
#else
#warning This platform has no way to get the destination interface information for IPv6 -- will only work for single-homed hosts
#endif
- #if defined(IPV6_HOPLIMIT)
+ #if defined(IPV6_RECVHOPLIMIT)
+ if (err == 0)
+ {
+ err = setsockopt(*sktPtr, IPPROTO_IPV6, IPV6_RECVHOPLIMIT, &kOn, sizeof(kOn));
+ if (err < 0) { err = errno; perror("setsockopt - IPV6_RECVHOPLIMIT"); }
+ }
+ #elif defined(IPV6_HOPLIMIT)
if (err == 0)
{
err = setsockopt(*sktPtr, IPPROTO_IPV6, IPV6_2292_HOPLIMIT, &kOn, sizeof(kOn));

View file

@ -1,53 +0,0 @@
--- mDNSShared/PlatformCommon.c.orig 2019-06-27 09:29:40 UTC
+++ mDNSShared/PlatformCommon.c
@@ -335,7 +335,9 @@ mDNSexport mDNSBool mDNSPosixTCPSocketSetup(int *fd, m
int sa_family = (addrType == mDNSAddrType_IPv4) ? AF_INET : AF_INET6;
int err;
int sock;
+#if !defined(TARGET_OS_FREEBSD)
mDNSu32 lowWater = 15384;
+#endif
sock = socket(sa_family, SOCK_STREAM, IPPROTO_TCP);
if (sock < 3)
@@ -398,12 +400,14 @@ mDNSexport mDNSBool mDNSPosixTCPSocketSetup(int *fd, m
if (port)
port->NotAnInteger = outTcpPort->NotAnInteger;
+#if !defined(TARGET_OS_FREEBSD)
err = setsockopt(sock, IPPROTO_TCP, TCP_NOTSENT_LOWAT, &lowWater, sizeof lowWater);
if (err < 0)
{
LogMsg("mDNSPosixTCPSocketSetup: TCP_NOTSENT_LOWAT failed: %s", strerror(errno));
return mDNSfalse;
}
+#endif
return mDNStrue;
}
@@ -426,7 +430,9 @@ mDNSexport TCPSocket *mDNSPosixDoTCPListenCallback(int
int failed;
char *nbp;
int i;
+#if !defined(TARGET_OS_FREEBSD)
mDNSu32 lowWater = 16384;
+#endif
// When we remember our connection, we remember a name that we can print for logging. But
// since we are the listener in this case, we don't /have/ a name for it. This buffer
// is used to print the IP address into a human readable string which will serve that purpose
@@ -448,6 +454,7 @@ mDNSexport TCPSocket *mDNSPosixDoTCPListenCallback(int
goto out;
}
+#if !defined(TARGET_OS_FREEBSD)
failed = setsockopt(remoteSock, IPPROTO_TCP, TCP_NOTSENT_LOWAT,
&lowWater, sizeof lowWater);
if (failed < 0)
@@ -456,6 +463,7 @@ mDNSexport TCPSocket *mDNSPosixDoTCPListenCallback(int
LogMsg("mDNSPosixDoTCPListenCallback: TCP_NOTSENT_LOWAT returned %d", errno);
goto out;
}
+#endif
if (address.sa.sa_family == AF_INET6)
{

View file

@ -1,15 +0,0 @@
--- mDNSShared/dnsextd_lexer.l.orig 2016-03-11 09:47:07 UTC
+++ mDNSShared/dnsextd_lexer.l
@@ -23,6 +23,12 @@
extern YYSTYPE yylval;
+#if !defined YYSTYPE_yylineno
+#if YY_FLEX_MAJOR_VERSION <= 2 && YY_FLEX_MINOR_VERSION <= 5 && YY_FLEX_SUBMINOR_VERSION <= 4
+int yylineno = 1;
+#endif
+#endif
+
#define YY_NO_INPUT 1
int yylex(void);

View file

@ -0,0 +1,11 @@
--- mDNSShared/uds_daemon.c.orig 2023-01-24 00:43:17 UTC
+++ mDNSShared/uds_daemon.c
@@ -2913,7 +2913,7 @@ exit:
mDNSlocal mStatus add_domain_to_browser(request_state *info, const domainname *d)
{
browser_t *b, *p;
- __block mStatus err;
+ mStatus err;
for (p = info->u.browser.browsers; p; p = p->next)
{

View file

@ -6,5 +6,3 @@ accessible from Cocoa, Ruby, Python, and other languages.
The mDNSResponder project is a component of Bonjour, Apple's ease-of-use IP
networking initiative.
See also: https://developer.apple.com/bonjour/