* upgrade to 0.93.1
* use ncurses port rather than base systems -- window resizing works better (although not perfectly)
This commit is contained in:
parent
1e23be623c
commit
4c20a91b11
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=11937
9 changed files with 42 additions and 45 deletions
|
@ -4,10 +4,10 @@
|
|||
# Date created: Thur July 25, 1996
|
||||
# Whom: David O'Brien (obrien@NUXI.com)
|
||||
#
|
||||
# $Id: Makefile,v 1.43 1998/04/18 11:11:27 obrien Exp $
|
||||
# $Id: Makefile,v 1.44 1998/07/16 05:57:09 obrien Exp $
|
||||
|
||||
DISTNAME= mutt-0.93i
|
||||
PKGNAME= mutt-0.93
|
||||
DISTNAME= mutt-0.93.1i
|
||||
PKGNAME= mutt-0.93.1
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ftp://riemann.iam.uni-bonn.de/pub/mutt/ \
|
||||
ftp://ftp.gbnet.net/pub/mutt-international/ \
|
||||
|
@ -25,6 +25,7 @@ PATCHFILES=
|
|||
|
||||
MAINTAINER= obrien@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= ncurses\\.4\\.:${PORTSDIR}/devel/ncurses
|
||||
.if defined(BATCH)
|
||||
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
|
||||
.endif
|
||||
|
@ -35,7 +36,8 @@ GNU_CONFIGURE= yes
|
|||
CONFIGURE_ARGS= --enable-dsn --enable-pop --enable-imap --enable-flock \
|
||||
--disable-fcntl --enable-hidden-host \
|
||||
--with-sharedir=${PREFIX}/share/misc \
|
||||
--with-docdir=${PREFIX}/share/doc/mutt
|
||||
--with-docdir=${PREFIX}/share/doc/mutt \
|
||||
--with-curses=${PREFIX}
|
||||
MAN1= mutt.1
|
||||
|
||||
post-patch:
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (mutt/mutt-0.93i.tar.gz) = d3998c6791a306eefecb9f2de44a296d
|
||||
MD5 (mutt/mutt-0.93.1i.tar.gz) = 3f66b4c8d380bfec1cae106f719059db
|
||||
|
|
|
@ -1,18 +1,15 @@
|
|||
--- doc/Makefile.in.orig Sun Jun 21 00:13:02 1998
|
||||
+++ doc/Makefile.in Wed Jul 15 01:43:40 1998
|
||||
@@ -18,9 +18,10 @@
|
||||
CFLAGS=@CFLAGS@ -DSHAREDIR=\"$(sharedir)\" $(XCPPFLAGS)
|
||||
LDFLAGS=@LDFLAGS@
|
||||
--- doc/Makefile.in.orig Mon Jul 13 03:50:37 1998
|
||||
+++ doc/Makefile.in Fri Jul 17 11:23:21 1998
|
||||
@@ -21,6 +21,8 @@
|
||||
|
||||
-
|
||||
all: manual.txt mutt.man manual.html
|
||||
all: manual.txt manual.html
|
||||
|
||||
+fbsd: manual.latin1 manual.html
|
||||
+
|
||||
install: mutt.man manual.txt
|
||||
../mkinstalldirs $(mandir)/man1
|
||||
$(INSTALL) -m 644 mutt.man $(mandir)/man1/mutt.1
|
||||
@@ -36,7 +37,11 @@
|
||||
@@ -36,7 +38,11 @@
|
||||
sgml2txt manual
|
||||
|
||||
manual.html: manual.sgml
|
||||
|
@ -23,5 +20,5 @@
|
|||
+manual.latin1: manual.sgml
|
||||
+ sgmlfmt -f latin1 manual.sgml
|
||||
|
||||
mutt.man: mutt.sgml
|
||||
sgml2txt -man mutt
|
||||
clean:
|
||||
rm -f *~ *.html *.orig *.rej
|
||||
|
|
|
@ -4,10 +4,10 @@
|
|||
# Date created: Thur July 25, 1996
|
||||
# Whom: David O'Brien (obrien@NUXI.com)
|
||||
#
|
||||
# $Id: Makefile,v 1.43 1998/04/18 11:11:27 obrien Exp $
|
||||
# $Id: Makefile,v 1.44 1998/07/16 05:57:09 obrien Exp $
|
||||
|
||||
DISTNAME= mutt-0.93i
|
||||
PKGNAME= mutt-0.93
|
||||
DISTNAME= mutt-0.93.1i
|
||||
PKGNAME= mutt-0.93.1
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ftp://riemann.iam.uni-bonn.de/pub/mutt/ \
|
||||
ftp://ftp.gbnet.net/pub/mutt-international/ \
|
||||
|
@ -25,6 +25,7 @@ PATCHFILES=
|
|||
|
||||
MAINTAINER= obrien@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= ncurses\\.4\\.:${PORTSDIR}/devel/ncurses
|
||||
.if defined(BATCH)
|
||||
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
|
||||
.endif
|
||||
|
@ -35,7 +36,8 @@ GNU_CONFIGURE= yes
|
|||
CONFIGURE_ARGS= --enable-dsn --enable-pop --enable-imap --enable-flock \
|
||||
--disable-fcntl --enable-hidden-host \
|
||||
--with-sharedir=${PREFIX}/share/misc \
|
||||
--with-docdir=${PREFIX}/share/doc/mutt
|
||||
--with-docdir=${PREFIX}/share/doc/mutt \
|
||||
--with-curses=${PREFIX}
|
||||
MAN1= mutt.1
|
||||
|
||||
post-patch:
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (mutt/mutt-0.93i.tar.gz) = d3998c6791a306eefecb9f2de44a296d
|
||||
MD5 (mutt/mutt-0.93.1i.tar.gz) = 3f66b4c8d380bfec1cae106f719059db
|
||||
|
|
|
@ -1,18 +1,15 @@
|
|||
--- doc/Makefile.in.orig Sun Jun 21 00:13:02 1998
|
||||
+++ doc/Makefile.in Wed Jul 15 01:43:40 1998
|
||||
@@ -18,9 +18,10 @@
|
||||
CFLAGS=@CFLAGS@ -DSHAREDIR=\"$(sharedir)\" $(XCPPFLAGS)
|
||||
LDFLAGS=@LDFLAGS@
|
||||
--- doc/Makefile.in.orig Mon Jul 13 03:50:37 1998
|
||||
+++ doc/Makefile.in Fri Jul 17 11:23:21 1998
|
||||
@@ -21,6 +21,8 @@
|
||||
|
||||
-
|
||||
all: manual.txt mutt.man manual.html
|
||||
all: manual.txt manual.html
|
||||
|
||||
+fbsd: manual.latin1 manual.html
|
||||
+
|
||||
install: mutt.man manual.txt
|
||||
../mkinstalldirs $(mandir)/man1
|
||||
$(INSTALL) -m 644 mutt.man $(mandir)/man1/mutt.1
|
||||
@@ -36,7 +37,11 @@
|
||||
@@ -36,7 +38,11 @@
|
||||
sgml2txt manual
|
||||
|
||||
manual.html: manual.sgml
|
||||
|
@ -23,5 +20,5 @@
|
|||
+manual.latin1: manual.sgml
|
||||
+ sgmlfmt -f latin1 manual.sgml
|
||||
|
||||
mutt.man: mutt.sgml
|
||||
sgml2txt -man mutt
|
||||
clean:
|
||||
rm -f *~ *.html *.orig *.rej
|
||||
|
|
|
@ -4,10 +4,10 @@
|
|||
# Date created: Thur July 25, 1996
|
||||
# Whom: David O'Brien (obrien@NUXI.com)
|
||||
#
|
||||
# $Id: Makefile,v 1.43 1998/04/18 11:11:27 obrien Exp $
|
||||
# $Id: Makefile,v 1.44 1998/07/16 05:57:09 obrien Exp $
|
||||
|
||||
DISTNAME= mutt-0.93i
|
||||
PKGNAME= mutt-0.93
|
||||
DISTNAME= mutt-0.93.1i
|
||||
PKGNAME= mutt-0.93.1
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ftp://riemann.iam.uni-bonn.de/pub/mutt/ \
|
||||
ftp://ftp.gbnet.net/pub/mutt-international/ \
|
||||
|
@ -25,6 +25,7 @@ PATCHFILES=
|
|||
|
||||
MAINTAINER= obrien@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= ncurses\\.4\\.:${PORTSDIR}/devel/ncurses
|
||||
.if defined(BATCH)
|
||||
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
|
||||
.endif
|
||||
|
@ -35,7 +36,8 @@ GNU_CONFIGURE= yes
|
|||
CONFIGURE_ARGS= --enable-dsn --enable-pop --enable-imap --enable-flock \
|
||||
--disable-fcntl --enable-hidden-host \
|
||||
--with-sharedir=${PREFIX}/share/misc \
|
||||
--with-docdir=${PREFIX}/share/doc/mutt
|
||||
--with-docdir=${PREFIX}/share/doc/mutt \
|
||||
--with-curses=${PREFIX}
|
||||
MAN1= mutt.1
|
||||
|
||||
post-patch:
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (mutt/mutt-0.93i.tar.gz) = d3998c6791a306eefecb9f2de44a296d
|
||||
MD5 (mutt/mutt-0.93.1i.tar.gz) = 3f66b4c8d380bfec1cae106f719059db
|
||||
|
|
|
@ -1,18 +1,15 @@
|
|||
--- doc/Makefile.in.orig Sun Jun 21 00:13:02 1998
|
||||
+++ doc/Makefile.in Wed Jul 15 01:43:40 1998
|
||||
@@ -18,9 +18,10 @@
|
||||
CFLAGS=@CFLAGS@ -DSHAREDIR=\"$(sharedir)\" $(XCPPFLAGS)
|
||||
LDFLAGS=@LDFLAGS@
|
||||
--- doc/Makefile.in.orig Mon Jul 13 03:50:37 1998
|
||||
+++ doc/Makefile.in Fri Jul 17 11:23:21 1998
|
||||
@@ -21,6 +21,8 @@
|
||||
|
||||
-
|
||||
all: manual.txt mutt.man manual.html
|
||||
all: manual.txt manual.html
|
||||
|
||||
+fbsd: manual.latin1 manual.html
|
||||
+
|
||||
install: mutt.man manual.txt
|
||||
../mkinstalldirs $(mandir)/man1
|
||||
$(INSTALL) -m 644 mutt.man $(mandir)/man1/mutt.1
|
||||
@@ -36,7 +37,11 @@
|
||||
@@ -36,7 +38,11 @@
|
||||
sgml2txt manual
|
||||
|
||||
manual.html: manual.sgml
|
||||
|
@ -23,5 +20,5 @@
|
|||
+manual.latin1: manual.sgml
|
||||
+ sgmlfmt -f latin1 manual.sgml
|
||||
|
||||
mutt.man: mutt.sgml
|
||||
sgml2txt -man mutt
|
||||
clean:
|
||||
rm -f *~ *.html *.orig *.rej
|
||||
|
|
Loading…
Reference in a new issue