Update to 1.12

- now respects CFLAGS and LDFLAGS
- submitter takes maintainership

PR:		ports/82600
Submitted by:	Emanuel Haupt <ehaupt@critical.ch>
This commit is contained in:
Sam Lawrance 2005-06-24 11:28:19 +00:00
parent e7b2571b73
commit 4c40074b6d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=137976
7 changed files with 33 additions and 36 deletions

View file

@ -7,17 +7,24 @@
# #
PORTNAME= tardy PORTNAME= tardy
PORTVERSION= 1.11 PORTVERSION= 1.12
CATEGORIES= archivers CATEGORIES= archivers
MASTER_SITES= http://www.canb.auug.org.au/~millerp/ MASTER_SITES= http://tardy.sourceforge.net/
MAINTAINER= ports@FreeBSD.org MAINTAINER= ehaupt@critical.ch
COMMENT= Manipulate the file headers in tar archive files in various ways COMMENT= Manipulate the file headers in tar archive files in various ways
USE_REINPLACE= yes
GNU_CONFIGURE= yes GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL} CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= tardy.1 MAN1= tardy.1
PLIST_FILES= bin/tardy PLIST_FILES= bin/tardy
post-patch:
.for var in CFLAGS LDFLAGS
@${REINPLACE_CMD} -e 's|^\(${var}\)\ =\ \(.*\)|\1 ?= \2|' \
${WRKSRC}/Makefile.in
.endfor
.include <bsd.port.mk> .include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
MD5 (tardy-1.11.tar.gz) = de9d9c6d8634589c0e6567b70054a0a6 MD5 (tardy-1.12.tar.gz) = 7cc18880df66f8e2693e3df210006b6c
SIZE (tardy-1.11.tar.gz) = 163320 SIZE (tardy-1.12.tar.gz) = 185481

View file

@ -0,0 +1,10 @@
--- common/error.cc.orig Fri Jun 24 08:58:42 2005
+++ common/error.cc Fri Jun 24 08:59:00 2005
@@ -23,6 +23,7 @@
#include <ac/assert.h>
#include <ac/ctype.h>
#include <ac/errno.h>
+#include <sys/types.h>
#include <ac/grp.h>
#include <ac/pwd.h>
#include <ac/stdarg.h>

View file

@ -0,0 +1,10 @@
--- common/tar/output/filter/gzip.cc.orig Fri Jun 24 09:17:36 2005
+++ common/tar/output/filter/gzip.cc Fri Jun 24 09:17:57 2005
@@ -26,6 +26,7 @@
#include <ac/stdlib.h>
#include <ac/string.h>
#include <tar/output/filter/gzip.h>
+#include <unistd.h>
#ifndef Z_BUFSIZE
#ifdef MAXSEG_64K

View file

@ -1,10 +0,0 @@
--- common/error.cc.orig Tue Jan 14 00:59:18 2003
+++ common/error.cc Tue Jan 14 00:59:40 2003
@@ -28,6 +28,7 @@
#include <ac/stdlib.h>
#include <ac/string.h>
+#include <sys/types.h>
#include <grp.h>
#include <pwd.h>
#include <ac/unistd.h>

View file

@ -1,10 +0,0 @@
--- common/tar/input/filename.cc.orig Tue Jan 14 01:00:31 2003
+++ common/tar/input/filename.cc Tue Jan 14 01:01:33 2003
@@ -27,7 +27,6 @@
#include <ac/unistd.h>
#include <sys/types.h>
#include <sys/stat.h>
-#include <sys/sysmacros.h>
#include <pwd.h>
#include <grp.h>

View file

@ -1,10 +0,0 @@
--- tardy/tardy.cc.orig Tue Jan 14 00:58:28 2003
+++ tardy/tardy.cc Tue Jan 14 00:58:44 2003
@@ -22,6 +22,7 @@
#include <vector>
#include <ac/stdio.h> /* need for grp.h on OSF/1 */
+#include <sys/types.h>
#include <grp.h>
#include <pwd.h>