(path) databases/p5-DBD-Frontbase update to version 1.39
PR: ports/124661 Submitted by: Mitchell Smith <mjs@bur.st>
This commit is contained in:
parent
ad8f895194
commit
4c85460c08
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=215062
4 changed files with 10 additions and 34 deletions
|
@ -1,19 +1,19 @@
|
|||
# New ports collection makefile for: DBD::FrontBase
|
||||
# Date created: 19 Jul 2007
|
||||
# Whom: Mitchell Smith <mjs@onthenet.com.au>
|
||||
# Whom: Mitchell Smith <mjs@bur.st>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= DBD-FrontBase
|
||||
PORTVERSION= 1.37
|
||||
PORTVERSION= 1.39
|
||||
CATEGORIES= databases perl5
|
||||
MASTER_SITES+= http://www.frontbase.com/download/perl/
|
||||
PKGNAMEPREFIX= p5-
|
||||
DISTNAME= DBD-FB-${PORTVERSION}
|
||||
EXTRACT_SUFX= .tar
|
||||
|
||||
MAINTAINER= q@onthenet.com.au
|
||||
MAINTAINER= mjs@bur.st
|
||||
COMMENT= DBI driver for FrontBase RDBMS server
|
||||
|
||||
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (DBD-FB-1.37.tar) = a45dfdf0c7723b7260fcf83386443874
|
||||
SHA256 (DBD-FB-1.37.tar) = 71afb3e88e630331b1ef78a799a772183b1b2363086b571938cf8d8c06d529cc
|
||||
SIZE (DBD-FB-1.37.tar) = 53557
|
||||
MD5 (DBD-FB-1.39.tar) = 3b65054fc3f5b935fccaaeb41549330c
|
||||
SHA256 (DBD-FB-1.39.tar) = 04eb6e9ad9611b5810c38521f160f8ffebe6c9060571cbdcc93e4a4298618156
|
||||
SIZE (DBD-FB-1.39.tar) = 51828
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
--- ../DBD-FB-1.37.orig/FB.xs Wed Jul 26 16:49:08 2006
|
||||
+++ FB.xs Fri Jul 20 14:30:25 2007
|
||||
@@ -111,10 +111,6 @@
|
||||
XSRETURN_YES;
|
||||
}
|
||||
/* pre-disconnect checks and tidy-ups */
|
||||
- if (DBIc_CACHED_KIDS(imp_dbh)) {
|
||||
- SvREFCNT_dec(DBIc_CACHED_KIDS(imp_dbh));
|
||||
- DBIc_CACHED_KIDS(imp_dbh) = Nullhv;
|
||||
- }
|
||||
/* Check for disconnect() being called whilst refs to cursors */
|
||||
/* still exists. This possibly needs some more thought. */
|
||||
if (DBIc_ACTIVE_KIDS(imp_dbh) && DBIc_WARN(imp_dbh) && !dirty) {
|
||||
@@ -167,10 +163,6 @@
|
||||
}
|
||||
else {
|
||||
/* pre-disconnect checks and tidy-ups */
|
||||
- if (DBIc_CACHED_KIDS(imp_dbh)) {
|
||||
- SvREFCNT_dec(DBIc_CACHED_KIDS(imp_dbh));
|
||||
- DBIc_CACHED_KIDS(imp_dbh) = Nullhv;
|
||||
- }
|
||||
if (DBIc_IADESTROY(imp_dbh)) { /* want's ineffective destroy */
|
||||
DBIc_ACTIVE_off(imp_dbh);
|
||||
}
|
|
@ -1,5 +1,5 @@
|
|||
--- ../DBD-FB-1.37.orig/Makefile.PL Wed Nov 1 19:44:28 2006
|
||||
+++ Makefile.PL Fri Jul 20 14:31:09 2007
|
||||
--- Makefile.PL.orig 2008-05-26 16:19:52.000000000 +1000
|
||||
+++ Makefile.PL 2008-05-26 16:20:12.000000000 +1000
|
||||
@@ -13,37 +13,10 @@
|
||||
|
||||
my $os = $^O;
|
||||
|
@ -36,8 +36,8 @@
|
|||
- die "Unable to find Frontbase\nplease set environment variable FRONTBASE_HOME\n";
|
||||
-}
|
||||
+#
|
||||
+# The FreeBSD port of FrontBase puts the libs in an unexpected location.
|
||||
+# The test for the FrontBase lib dir has been removed.
|
||||
+# The FreeBSD port for FrontBase puts the libraries in an unexpected location and causes the Makefile to die. As we know
|
||||
+# that the package is installed at this point, the test for the libraries has been removed.
|
||||
+#
|
||||
|
||||
print "Configuring for ",$os, "\n";
|
||||
|
|
Loading…
Reference in a new issue