Add fetchconfig, a perl script for retrieving configuration of
various network devices such as: * Cisco IOS * Cisco Catalyst * FortiGate * ProCurve * Parks * Alcatel Ethernet Routers (Riverstone) * Dell PowerConnect switches * Old Terayon 3200/3500 CMTS PR: 120843 Submitted by: salexanov at gmail.com
This commit is contained in:
parent
54549b727d
commit
4c86624fd0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=208024
6 changed files with 98 additions and 0 deletions
|
@ -55,6 +55,7 @@
|
|||
SUBDIR += ehnt
|
||||
SUBDIR += etherape
|
||||
SUBDIR += ettercap
|
||||
SUBDIR += fetchconfig
|
||||
SUBDIR += flow-extract
|
||||
SUBDIR += flow-tools
|
||||
SUBDIR += flowd
|
||||
|
|
46
net-mgmt/fetchconfig/Makefile
Normal file
46
net-mgmt/fetchconfig/Makefile
Normal file
|
@ -0,0 +1,46 @@
|
|||
# New ports collection makefile for: fetchconfig
|
||||
# Date created: 21 December 2008
|
||||
# Whom: salexanov@gmail.com
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= fetchconfig
|
||||
PORTVERSION= 0.13
|
||||
CATEGORIES= net-mgmt
|
||||
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= salexanov@gmail.com
|
||||
COMMENT= Perl script for retrieving configuration of various network devices
|
||||
|
||||
BUILD_DEPENDS= ${SITE_PERL}/Net/Telnet.pm:${PORTSDIR}/net/p5-Net-Telnet
|
||||
RUN_DEPENDS= ${BUILD_DEPENDS}
|
||||
|
||||
USE_PERL5= yes
|
||||
NO_BUILD= yes
|
||||
|
||||
MODULES= model/Abstract.pm model/CiscoCAT.pm model/CiscoIOS.pm \
|
||||
model/Dell.pm model/Detector.pm model/FortiGate.pm \
|
||||
model/Parks.pm model/ProCurve.pm model/Riverstone.pm \
|
||||
model/Terayon.pm Constants.pm Logger.pm
|
||||
PORTDOCS= CHANGES README device_table.example
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '1s|.*|#!${PERL} -w|' ${WRKSRC}/${PORTNAME}.pl
|
||||
|
||||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
|
||||
${MKDIR} ${SITE_PERL}/${PORTNAME}/model
|
||||
.for f in ${MODULES}
|
||||
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/${f} ${SITE_PERL}/${PORTNAME}/${f}
|
||||
.endfor
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
.for i in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
3
net-mgmt/fetchconfig/distinfo
Normal file
3
net-mgmt/fetchconfig/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (fetchconfig-0.13.tar.gz) = 0d9356970b6e4c2a3d45a1439f7ef7d9
|
||||
SHA256 (fetchconfig-0.13.tar.gz) = 84cb7d2de5022048aa8935b78d044f0ad0ca4f22841c9ce69ea9190c11ca522c
|
||||
SIZE (fetchconfig-0.13.tar.gz) = 22957
|
20
net-mgmt/fetchconfig/files/patch-fetchconfig.pl
Normal file
20
net-mgmt/fetchconfig/files/patch-fetchconfig.pl
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- ./fetchconfig.pl.orig 2007-07-20 19:05:39.000000000 +0200
|
||||
+++ ./fetchconfig.pl 2008-02-27 22:58:14.000000000 +0100
|
||||
@@ -21,6 +21,8 @@
|
||||
# $Id: fetchconfig.pl,v 1.7 2007/07/20 17:05:39 evertonm Exp $
|
||||
|
||||
use strict;
|
||||
+use FindBin;
|
||||
+use lib "$FindBin::Bin/../lib";
|
||||
use fetchconfig::Logger;
|
||||
use fetchconfig::Constants;
|
||||
use fetchconfig::model::Detector;
|
||||
@@ -64,7 +66,7 @@
|
||||
if (@device_file_list < 1) {
|
||||
$log->error("at least one device list file is required");
|
||||
&usage;
|
||||
- die;
|
||||
+ exit 0;
|
||||
}
|
||||
|
||||
fetchconfig::model::Detector->init($log);
|
13
net-mgmt/fetchconfig/pkg-descr
Normal file
13
net-mgmt/fetchconfig/pkg-descr
Normal file
|
@ -0,0 +1,13 @@
|
|||
Fetchconfig is a Perl script for retrieving configurations of various network
|
||||
devices. It currently supports a variety of devices, such as:
|
||||
|
||||
* Cisco IOS
|
||||
* Cisco Catalyst
|
||||
* FortiGate
|
||||
* ProCurve
|
||||
* Parks
|
||||
* Alcatel Ethernet Routers (Riverstone)
|
||||
* Dell PowerConnect switches
|
||||
* Old Terayon 3200/3500 CMTS
|
||||
|
||||
WWW: http://www.nongnu.org/fetchconfig/
|
15
net-mgmt/fetchconfig/pkg-plist
Normal file
15
net-mgmt/fetchconfig/pkg-plist
Normal file
|
@ -0,0 +1,15 @@
|
|||
bin/fetchconfig
|
||||
%%SITE_PERL%%/fetchconfig/model/Abstract.pm
|
||||
%%SITE_PERL%%/fetchconfig/model/CiscoCAT.pm
|
||||
%%SITE_PERL%%/fetchconfig/model/CiscoIOS.pm
|
||||
%%SITE_PERL%%/fetchconfig/model/Dell.pm
|
||||
%%SITE_PERL%%/fetchconfig/model/Detector.pm
|
||||
%%SITE_PERL%%/fetchconfig/model/FortiGate.pm
|
||||
%%SITE_PERL%%/fetchconfig/model/Parks.pm
|
||||
%%SITE_PERL%%/fetchconfig/model/ProCurve.pm
|
||||
%%SITE_PERL%%/fetchconfig/model/Riverstone.pm
|
||||
%%SITE_PERL%%/fetchconfig/model/Terayon.pm
|
||||
%%SITE_PERL%%/fetchconfig/Constants.pm
|
||||
%%SITE_PERL%%/fetchconfig/Logger.pm
|
||||
@dirrm %%SITE_PERL%%/fetchconfig/model
|
||||
@dirrm %%SITE_PERL%%/fetchconfig
|
Loading…
Reference in a new issue