www/py-pyjwt: Update to 1.4.0, Modernize

- Update PORTVERSION and distinfo checksum (1.4.0)
- Update run and test dependencies (pycrypto -> cryptography)
- Enable "concurrent" Python installation
- Enable NO_ARCH (architecture independent)
- Update test target
- Patch setup.py not to install non-compulsory tests_requires
- Group OPTIONS_* entries
- Pet portling (DISTNAME order)
- Uncomment LICENSE_FILE

PR:		205443
Reviewed by:	maintainer <terje elde net>
Approved by:	maintainer <terje elde net>
This commit is contained in:
Kubilay Kocak 2016-02-26 10:44:33 +00:00
parent e19decc67a
commit 4c8eccf2bd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=409595
3 changed files with 39 additions and 12 deletions

View file

@ -1,27 +1,35 @@
# $FreeBSD$
PORTNAME= pyjwt
PORTVERSION= 0.2.1
PORTVERSION= 1.4.0
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
DISTNAME= PyJWT-${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= PyJWT-${PORTVERSION}
MAINTAINER= terje@elde.net
COMMENT= JSON Web Token implementation in Python
LICENSE= MIT
# LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_FILE= ${WRKSRC}/LICENSE
RSASSA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>=0:${PORTSDIR}/security/py-pycrypto
OPTIONS_DEFINE= RSASSA
RSASSA_DESC= RSASSA-PKCS1 v1.5 signature support
# Some tests are skipped without pycrypto, but its not
# referenced as a requirement anymore.
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest \
${PYTHON_PKGNAMEPREFIX}cryptography>0:${PORTSDIR}/security/py-cryptography \
${PYTHON_PKGNAMEPREFIX}pycrypto>=0:${PORTSDIR}/security/py-pycrypto
USES= python
USE_PYTHON= distutils autoplist
USE_PYTHON= distutils concurrent autoplist
regression-test: build
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
OPTIONS_DEFINE= RSASSA
RSASSA_DESC= RSASSA-PKCS1 v1.5 signature support
RSASSA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:${PORTSDIR}/security/py-cryptography
NO_ARCH= yes
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -c /dev/null -v -rs
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (PyJWT-0.2.1.tar.gz) = cfd0fad01a9a57fb4b24e59a82ffd50ddc9c2c4344694ec6ef436ae11d5d18aa
SIZE (PyJWT-0.2.1.tar.gz) = 6320
SHA256 (PyJWT-1.4.0.tar.gz) = e1b2386cfad541445b1d43e480b02ca37ec57259fd1a23e79415b57ba5d8a694
SIZE (PyJWT-1.4.0.tar.gz) = 34613

View file

@ -0,0 +1,19 @@
--- setup.py.orig 2016-02-26 09:43:54 UTC
+++ setup.py
@@ -31,8 +31,6 @@ if sys.argv[-1] == 'publish':
tests_require = [
'pytest',
- 'pytest-cov',
- 'pytest-runner',
]
setup(
@@ -61,7 +59,6 @@ setup(
'Topic :: Utilities',
],
test_suite='tests',
- setup_requires=['pytest-runner'],
tests_require=tests_require,
extras_require=dict(
test=tests_require,