Import of abacus sentry v 0.61

Sentry is part of the Abacus Project suite of security tools.
It is a program designed to detect and respond to port scans
against a target host in real-time. There are other port scan
detectors that peform similar detection of scans,but the Sentry
has some unique features that may make it worth looking into.

PR:		ports/5475
Submitted by:	chris@still.whet.org
This commit is contained in:
Justin M. Seger 1998-12-19 16:53:20 +00:00
parent ee7a726c95
commit 4cb8e70952
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=15433
8 changed files with 99 additions and 0 deletions

View file

@ -0,0 +1,18 @@
# Ports collection makefile for: sentry
# Version required: 0.61
# Date created: 3 January 1998
# Whom: chris@still.whet.org
#
# $Id$
#
DISTNAME= sentry-0.61
CATEGORIES= security
MASTER_SITES= http://www.psionic.com/tools/sentry/
MAINTAINER= chris@still.whet.org
WRKSRC= ${WRKDIR}/sentry_beta
ALL_TARGET= bsd
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (sentry-0.61.tar.gz) = 57bf7e0caf99188018ef1ab6131faf4b

View file

@ -0,0 +1,43 @@
--- Makefile.orig Thu May 28 09:24:11 1998
+++ Makefile Sat Dec 19 11:10:10 1998
@@ -25,13 +25,13 @@
#CC = gcc
# Normal systems flags
-CFLAGS = -O
+#CFLAGS = -O
# Debug mode for sentry
#CFLAGS = -Wall -g -DDEBUG
-INSTALLDIR = /usr/local/abacus
+INSTALLDIR = ${PREFIX}
all:
@@ -54,18 +54,13 @@
/bin/rmdir $(INSTALLDIR)
install:
- @echo "Creating abacus directory $(INSTALLDIR)"
- @if [ ! -d $(INSTALLDIR) ]; then /bin/mkdir $(INSTALLDIR); fi
- @echo "Setting directory permissions"
- chmod 700 $(INSTALLDIR)
- @echo "Copying files"
- cp ./sentry.conf $(INSTALLDIR)
- cp ./sentry.ignore $(INSTALLDIR)
- cp ./sentry $(INSTALLDIR)
+ cp ./sentry.conf $(INSTALLDIR)/etc
+ cp ./sentry.ignore $(INSTALLDIR)/etc
+ cp ./sentry $(INSTALLDIR)/bin
@echo "Setting permissions"
- chmod 600 $(INSTALLDIR)/sentry.ignore
- chmod 600 $(INSTALLDIR)/sentry.conf
- chmod 700 $(INSTALLDIR)/sentry
+ chmod 600 $(INSTALLDIR)/etc/sentry.ignore
+ chmod 600 $(INSTALLDIR)/etc/sentry.conf
+ chmod 700 $(INSTALLDIR)/bin/sentry
@echo ""
@echo ""
@echo "Edit $(INSTALLDIR)/sentry.conf and change"

View file

@ -0,0 +1,17 @@
--- sentry.conf.orig Sat Dec 19 11:06:01 1998
+++ sentry.conf Sat Dec 19 11:06:22 1998
@@ -80,11 +80,11 @@
######################
#
# Hosts to ignore
-IGNORE_FILE="/usr/local/abacus/sentry.ignore"
+IGNORE_FILE="/usr/local/etc/sentry.ignore"
# Hosts that have been denied (running history)
-HISTORY_FILE="/usr/local/abacus/sentry.history"
+HISTORY_FILE="/usr/local/etc/sentry.history"
# Hosts that have been denied this session only (temporary until next restart)
-BLOCKED_FILE="/usr/local/abacus/sentry.blocked"
+BLOCKED_FILE="/usr/local/etc/sentry.blocked"
###################
# Response Options#

View file

@ -0,0 +1,11 @@
--- sentry_config.h.orig Sat Dec 19 11:05:40 1998
+++ sentry_config.h Sat Dec 19 11:05:52 1998
@@ -32,7 +32,7 @@
/* These are probably ok. Be sure you change the Makefile if you */
/* change the path */
-#define CONFIG_FILE "/usr/local/abacus/sentry.conf"
+#define CONFIG_FILE "/usr/local/etc/sentry.conf"
/* The location of Wietse Venema's TCP Wrapper hosts.deny file */
#define WRAPPER_HOSTS_DENY "/etc/hosts.deny"

View file

@ -0,0 +1 @@
Port scan detection and active defense

View file

@ -0,0 +1,5 @@
Sentry is part of the Abacus Project suite of security tools.
It is a program designed to detect and respond to port scans
against a target host in real-time. There are other port scan
detectors that peform similar detection of scans,but the Sentry
has some unique features that may make it worth looking into.

View file

@ -0,0 +1,3 @@
bin/sentry
etc/sentry.conf
etc/sentry.ignore