- Add devel/rubygem-travis
CLI and Ruby client library for Travis CI WWW: https://github.com/travis-ci/travis.rb
This commit is contained in:
parent
1db8c76e0e
commit
4cbc7eb25f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=377618
6 changed files with 61 additions and 0 deletions
|
@ -4651,6 +4651,7 @@
|
|||
SUBDIR += rubygem-tins0
|
||||
SUBDIR += rubygem-toml
|
||||
SUBDIR += rubygem-transactionsimple
|
||||
SUBDIR += rubygem-travis
|
||||
SUBDIR += rubygem-treetop
|
||||
SUBDIR += rubygem-trollop
|
||||
SUBDIR += rubygem-turn
|
||||
|
|
32
devel/rubygem-travis/Makefile
Normal file
32
devel/rubygem-travis/Makefile
Normal file
|
@ -0,0 +1,32 @@
|
|||
# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= travis
|
||||
PORTVERSION= 1.7.5
|
||||
CATEGORIES= devel rubygems
|
||||
MASTER_SITES= RG
|
||||
|
||||
MAINTAINER= ruby@FreeBSD.org
|
||||
COMMENT= CLI and Ruby client library for Travis CI
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
RUN_DEPENDS= rubygem-addressable>=2.3:${PORTSDIR}/www/rubygem-addressable \
|
||||
rubygem-backports>=0:${PORTSDIR}/devel/rubygem-backports \
|
||||
rubygem-faraday>=0.9:${PORTSDIR}/www/rubygem-faraday \
|
||||
rubygem-faraday_middleware>=0.9.1:${PORTSDIR}/www/rubygem-faraday_middleware \
|
||||
rubygem-gh>=0.13:${PORTSDIR}/devel/rubygem-gh \
|
||||
rubygem-highline>=1.6:${PORTSDIR}/devel/rubygem-highline \
|
||||
rubygem-launchy>=2.1:${PORTSDIR}/devel/rubygem-launchy \
|
||||
rubygem-pry>=0.9:${PORTSDIR}/devel/rubygem-pry \
|
||||
rubygem-pusher-client>=0.4:${PORTSDIR}/www/rubygem-pusher-client \
|
||||
rubygem-typhoeus>=0.6.8:${PORTSDIR}/www/rubygem-typhoeus
|
||||
|
||||
USE_RUBY= yes
|
||||
USE_RUBYGEMS= yes
|
||||
RUBYGEM_AUTOPLIST= yes
|
||||
|
||||
PLIST_FILES= bin/travis
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/rubygem-travis/distinfo
Normal file
2
devel/rubygem-travis/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (rubygem/travis-1.7.5.gem) = a3b157eab490882420b9cee68913c8f9ae637e4317e088bd74c082c59b310782
|
||||
SIZE (rubygem/travis-1.7.5.gem) = 190976
|
12
devel/rubygem-travis/files/patch-travis-1.7.5.gemspec
Normal file
12
devel/rubygem-travis/files/patch-travis-1.7.5.gemspec
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- travis-1.7.5.gemspec.orig 2015-01-21 16:49:45.809378003 +0300
|
||||
+++ travis-1.7.5.gemspec 2015-01-21 16:51:09.773372219 +0300
|
||||
@@ -142,9 +142,6 @@
|
||||
name: pry
|
||||
requirement: !ruby/object:Gem::Requirement
|
||||
requirements:
|
||||
- - - "<"
|
||||
- - !ruby/object:Gem::Version
|
||||
- version: '0.10'
|
||||
- - "~>"
|
||||
- !ruby/object:Gem::Version
|
||||
version: '0.9'
|
11
devel/rubygem-travis/files/patch-travis.gemspec
Normal file
11
devel/rubygem-travis/files/patch-travis.gemspec
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- travis.gemspec.orig 2015-01-21 16:49:45.798378381 +0300
|
||||
+++ travis.gemspec 2015-01-21 16:50:23.063375806 +0300
|
||||
@@ -286,7 +286,7 @@
|
||||
s.add_dependency "backports"
|
||||
s.add_dependency "gh", "~> 0.13"
|
||||
s.add_dependency "launchy", "~> 2.1"
|
||||
- s.add_dependency "pry", "< 0.10", "~> 0.9"
|
||||
+ s.add_dependency "pry", "~> 0.9"
|
||||
s.add_dependency "typhoeus", "~> 0.6", ">= 0.6.8"
|
||||
s.add_dependency "pusher-client", "~> 0.4"
|
||||
s.add_dependency "addressable", "~> 2.3"
|
3
devel/rubygem-travis/pkg-descr
Normal file
3
devel/rubygem-travis/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
CLI and Ruby client library for Travis CI
|
||||
|
||||
WWW: https://github.com/travis-ci/travis.rb
|
Loading…
Reference in a new issue