- Update of xmame and xmess to 0.61.1
- Update datfiles to latest version - Use master site sorting for WITH_DATFILES - (hopefully) fix pkg-plist issues PR: 45292 Submitted by: mainatiner
This commit is contained in:
parent
a091f24b78
commit
4ce8365160
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=70180
12 changed files with 0 additions and 304 deletions
|
@ -1,15 +0,0 @@
|
|||
--- makefile.unix.orig Fri May 3 02:53:55 2002
|
||||
+++ makefile.unix Thu Oct 31 12:40:33 2002
|
||||
@@ -363,6 +363,12 @@
|
||||
# XINPUT_DEVICES = 1
|
||||
|
||||
##############################################################################
|
||||
+# *** SDL options, only needed for SDL as display method
|
||||
+##############################################################################
|
||||
+# *** The name of your sdl-config executable
|
||||
+SDL_CONFIG = sdl-config
|
||||
+
|
||||
+##############################################################################
|
||||
# *** OpenGL info -- configure if you are using the xgl display option
|
||||
##############################################################################
|
||||
GLLIBS= -ldl
|
|
@ -1,13 +0,0 @@
|
|||
--- src/unix/sysdep/dsp-drivers/oss.c.orig Fri May 3 02:53:54 2002
|
||||
+++ src/unix/sysdep/dsp-drivers/oss.c Thu Oct 31 12:46:35 2002
|
||||
@@ -29,9 +29,7 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
#include <sys/ioctl.h>
|
||||
-#ifdef __ARCH_freebsd
|
||||
-#include <machine/soundcard.h>
|
||||
-#elif defined (__ARCH_openbsd)
|
||||
+#if defined (__ARCH_openbsd)
|
||||
#include <soundcard.h>
|
||||
#else
|
||||
#include <sys/soundcard.h>
|
|
@ -1,38 +0,0 @@
|
|||
--- src/unix/joystick-drivers/joy_usb.c.orig Fri May 3 02:53:54 2002
|
||||
+++ src/unix/joystick-drivers/joy_usb.c Thu Oct 31 13:17:45 2002
|
||||
@@ -27,8 +27,12 @@
|
||||
#include <usb.h>
|
||||
#endif
|
||||
#elif defined(__ARCH_freebsd)
|
||||
+#ifdef HAVE_USBHID_H
|
||||
+#include <libusbhid.h>
|
||||
+#else
|
||||
#include <libusb.h>
|
||||
#endif
|
||||
+#endif
|
||||
#include <dev/usb/usb.h>
|
||||
#include <dev/usb/usbhid.h>
|
||||
|
||||
@@ -87,11 +91,13 @@
|
||||
priv_joy_data[i].hids = NULL;
|
||||
|
||||
#ifdef HAVE_USBHID_H
|
||||
+#if defined(__ARCH_netbsd) || (defined(__ARCH_freebsd) && __FreeBSD_version > 500000)
|
||||
if (ioctl(joy_data[i].fd, USB_GET_REPORT_ID, &report_id) < 0)
|
||||
{
|
||||
fprintf(stderr_file, "error: /dev/uhid%d: %s", i, strerror(errno));
|
||||
return FALSE;
|
||||
}
|
||||
+#endif
|
||||
|
||||
size = hid_report_size(rd, hid_input, report_id);
|
||||
priv_joy_data[i].offset = 0;
|
||||
@@ -108,7 +114,7 @@
|
||||
priv_joy_data[i].dlen = size;
|
||||
|
||||
is_joystick = 0;
|
||||
-#ifdef HAVE_USBHID_H
|
||||
+#if defined(__ARCH_netbsd) && defined(HAVE_USBHID_H)
|
||||
for (d = hid_start_parse(rd, 1 << hid_input, report_id);
|
||||
hid_get_item(d, &h); )
|
||||
#else
|
|
@ -1,13 +0,0 @@
|
|||
--- src/unix/sysdep/mixer-drivers/oss.c.orig Fri May 3 02:53:54 2002
|
||||
+++ src/unix/sysdep/mixer-drivers/oss.c Thu Oct 31 12:46:55 2002
|
||||
@@ -28,9 +28,7 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
#include <sys/ioctl.h>
|
||||
-#ifdef __ARCH_freebsd
|
||||
-#include <machine/soundcard.h>
|
||||
-#elif defined (__ARCH_openbsd)
|
||||
+#if defined (__ARCH_openbsd)
|
||||
#include <soundcard.h>
|
||||
#else
|
||||
#include <sys/soundcard.h>
|
|
@ -1,56 +0,0 @@
|
|||
--- src/unix/unix.mak.orig Fri May 3 02:53:53 2002
|
||||
+++ src/unix/unix.mak Thu Oct 31 13:15:25 2002
|
||||
@@ -56,14 +56,14 @@
|
||||
LIBS.xfx = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext -lglide2x
|
||||
LIBS.svgafx = $(X11LIB) -lvga -lvgagl -lglide2x
|
||||
LIBS.openstep = -framework AppKit
|
||||
-LIBS.SDL = `sdl-config --libs`
|
||||
+LIBS.SDL = $(X11LIB) `$(SDL_CONFIG) --libs`
|
||||
LIBS.photon2 = -L/usr/lib -lph -lphrender
|
||||
|
||||
CFLAGS.x11 = $(X11INC) $(JOY_X11_CFLAGS) $(XINPUT_DEVICES_CFLAGS)
|
||||
CFLAGS.xgl = $(X11INC) $(JOY_X11_CFLAGS) $(GLCFLAGS)
|
||||
CFLAGS.xfx = $(X11INC) $(JOY_X11_CFLAGS) -I/usr/include/glide
|
||||
CFLAGS.svgafx = -I/usr/include/glide
|
||||
-CFLAGS.SDL = -D_REENTRANT
|
||||
+CFLAGS.SDL = $(X11INC) `$(SDL_CONFIG) --cflags` -D_REENTRANT
|
||||
CFLAGS.photon2 =
|
||||
|
||||
INST.x11 = doinstall
|
||||
@@ -235,8 +235,17 @@
|
||||
MY_LIBS += -lusb
|
||||
endif
|
||||
else
|
||||
+ifeq ($(ARCH), freebsd)
|
||||
+ifeq ($(shell test -f /usr/include/libusbhid.h && echo have_usbhid), have_usbhid)
|
||||
+CONFIG += -DHAVE_USBHID_H
|
||||
+MY_LIBS += -lusbhid
|
||||
+else
|
||||
MY_LIBS += -lusb
|
||||
endif
|
||||
+else
|
||||
+MY_LIBS += -lusb
|
||||
+endif
|
||||
+endif
|
||||
endif
|
||||
|
||||
ifdef EFENCE
|
||||
@@ -366,7 +375,7 @@
|
||||
|
||||
doc/x$(TARGET)rc.dist: all src/unix/xmamerc-keybinding-notes.txt
|
||||
./x$(TARGET).$(DISPLAY_METHOD) -noloadconfig -showconfig | \
|
||||
- grep -v loadconfig > doc/x$(TARGET)rc.dist
|
||||
+ grep -v loadconfig | tr "\033" \# > doc/x$(TARGET)rc.dist
|
||||
cat src/unix/xmamerc-keybinding-notes.txt >> doc/x$(TARGET)rc.dist
|
||||
|
||||
doc/gamelist.$(TARGET): all
|
||||
@@ -375,7 +384,8 @@
|
||||
|
||||
doc/x$(TARGET).6: all src/unix/xmame.6-1 src/unix/xmame.6-3
|
||||
cat src/unix/xmame.6-1 > doc/x$(TARGET).6
|
||||
- ./x$(TARGET).$(DISPLAY_METHOD) -manhelp >> doc/x$(TARGET).6
|
||||
+ ./x$(TARGET).$(DISPLAY_METHOD) -noloadconfig -manhelp | \
|
||||
+ tr "\033" \# >> doc/x$(TARGET).6
|
||||
cat src/unix/xmame.6-3 >> doc/x$(TARGET).6
|
||||
|
||||
install: $(INST.$(DISPLAY_METHOD)) install-man
|
|
@ -1,13 +0,0 @@
|
|||
--- src/unix/video-drivers/svgainput.c.orig Fri May 3 02:53:54 2002
|
||||
+++ src/unix/video-drivers/svgainput.c Thu Oct 31 12:46:04 2002
|
||||
@@ -12,6 +12,10 @@
|
||||
#include "devices.h"
|
||||
#include "keyboard.h"
|
||||
|
||||
+#if defined(__ARCH_freebsd)
|
||||
+#define SIGUNUSED SIGUSR2
|
||||
+#endif
|
||||
+
|
||||
static int console_fd = -1;
|
||||
static int mouse_fd = -1;
|
||||
static int leds = 0;
|
|
@ -1,15 +0,0 @@
|
|||
--- makefile.unix.orig Fri May 3 02:53:55 2002
|
||||
+++ makefile.unix Thu Oct 31 12:40:33 2002
|
||||
@@ -363,6 +363,12 @@
|
||||
# XINPUT_DEVICES = 1
|
||||
|
||||
##############################################################################
|
||||
+# *** SDL options, only needed for SDL as display method
|
||||
+##############################################################################
|
||||
+# *** The name of your sdl-config executable
|
||||
+SDL_CONFIG = sdl-config
|
||||
+
|
||||
+##############################################################################
|
||||
# *** OpenGL info -- configure if you are using the xgl display option
|
||||
##############################################################################
|
||||
GLLIBS= -ldl
|
|
@ -1,13 +0,0 @@
|
|||
--- src/unix/sysdep/dsp-drivers/oss.c.orig Fri May 3 02:53:54 2002
|
||||
+++ src/unix/sysdep/dsp-drivers/oss.c Thu Oct 31 12:46:35 2002
|
||||
@@ -29,9 +29,7 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
#include <sys/ioctl.h>
|
||||
-#ifdef __ARCH_freebsd
|
||||
-#include <machine/soundcard.h>
|
||||
-#elif defined (__ARCH_openbsd)
|
||||
+#if defined (__ARCH_openbsd)
|
||||
#include <soundcard.h>
|
||||
#else
|
||||
#include <sys/soundcard.h>
|
|
@ -1,46 +0,0 @@
|
|||
--- src/unix/joystick-drivers/joy_usb.c.orig Sat Nov 3 02:22:56 2001
|
||||
+++ src/unix/joystick-drivers/joy_usb.c Thu Oct 31 15:27:02 2002
|
||||
@@ -23,8 +23,12 @@
|
||||
#if defined(__ARCH_netbsd)
|
||||
#include <usb.h>
|
||||
#elif defined(__ARCH_freebsd)
|
||||
+#ifdef HAVE_USBHID_H
|
||||
+#include <libusbhid.h>
|
||||
+#else
|
||||
#include <libusb.h>
|
||||
#endif
|
||||
+#endif
|
||||
#include <dev/usb/usb.h>
|
||||
#include <dev/usb/usbhid.h>
|
||||
|
||||
@@ -82,7 +86,22 @@
|
||||
|
||||
priv_joy_data[i].hids = NULL;
|
||||
|
||||
+#if defined(__ARCH_freebsd) && __FreeBSD_version > 500000
|
||||
+ if (ioctl(joy_data[i].fd, USB_GET_REPORT_ID, &report_id) < 0)
|
||||
+ {
|
||||
+ fprintf(stderr_file, "error: /dev/uhid%d: %s", i, strerror(errno));
|
||||
+ return FALSE;
|
||||
+ }
|
||||
+#endif
|
||||
+
|
||||
+#if defined(__ARCH_freebsd) && defined(HAVE_USBHID_H)
|
||||
+ size = hid_report_size(rd, hid_input, report_id);
|
||||
+ priv_joy_data[i].offset = 0;
|
||||
+#else
|
||||
size = hid_report_size(rd, hid_input, &report_id);
|
||||
+ priv_joy_data[i].offset = (report_id != 0);
|
||||
+#endif
|
||||
+
|
||||
if ((priv_joy_data[i].data_buf = malloc(size)) == NULL)
|
||||
{
|
||||
fprintf(stderr_file, "error: couldn't malloc %d bytes\n", size);
|
||||
@@ -90,7 +109,6 @@
|
||||
return FALSE;
|
||||
}
|
||||
priv_joy_data[i].dlen = size;
|
||||
- priv_joy_data[i].offset = (report_id != 0);
|
||||
|
||||
is_joystick = 0;
|
||||
for (d = hid_start_parse(rd, 1 << hid_input); hid_get_item(d, &h); )
|
|
@ -1,13 +0,0 @@
|
|||
--- src/unix/sysdep/mixer-drivers/oss.c.orig Fri May 3 02:53:54 2002
|
||||
+++ src/unix/sysdep/mixer-drivers/oss.c Thu Oct 31 12:46:55 2002
|
||||
@@ -28,9 +28,7 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
#include <sys/ioctl.h>
|
||||
-#ifdef __ARCH_freebsd
|
||||
-#include <machine/soundcard.h>
|
||||
-#elif defined (__ARCH_openbsd)
|
||||
+#if defined (__ARCH_openbsd)
|
||||
#include <soundcard.h>
|
||||
#else
|
||||
#include <sys/soundcard.h>
|
|
@ -1,56 +0,0 @@
|
|||
--- src/unix/unix.mak.orig Mon Dec 31 09:19:03 2001
|
||||
+++ src/unix/unix.mak Thu Oct 31 15:25:37 2002
|
||||
@@ -51,14 +51,14 @@
|
||||
LIBS.xfx = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext -lglide2x
|
||||
LIBS.svgafx = $(X11LIB) -lvga -lvgagl -lglide2x
|
||||
LIBS.openstep = -framework AppKit
|
||||
-LIBS.SDL = `sdl-config --libs`
|
||||
+LIBS.SDL = $(X11LIB) `$(SDL_CONFIG) --libs`
|
||||
LIBS.photon2 = -L/usr/lib -lph -lphrender
|
||||
|
||||
CFLAGS.x11 = $(X11INC) $(JOY_X11_CFLAGS)
|
||||
CFLAGS.xgl = $(X11INC) $(JOY_X11_CFLAGS) $(GLCFLAGS)
|
||||
CFLAGS.xfx = $(X11INC) $(JOY_X11_CFLAGS) -I/usr/include/glide
|
||||
CFLAGS.svgafx = -I/usr/include/glide
|
||||
-CFLAGS.SDL = -D_REENTRANT
|
||||
+CFLAGS.SDL = $(X11INC) `$(SDL_CONFIG) --cflags` -D_REENTRANT
|
||||
CFLAGS.photon2 =
|
||||
|
||||
INST.x11 = doinstall
|
||||
@@ -210,8 +210,17 @@
|
||||
endif
|
||||
ifdef JOY_USB
|
||||
CONFIG += -DUSB_JOYSTICK
|
||||
+ifeq ($(ARCH), freebsd)
|
||||
+ifeq ($(shell test -f /usr/include/libusbhid.h && echo have_usbhid), have_usbhid)
|
||||
+CONFIG += -DHAVE_USBHID_H
|
||||
+MY_LIBS += -lusbhid
|
||||
+else
|
||||
MY_LIBS += -lusb
|
||||
endif
|
||||
+else
|
||||
+MY_LIBS += -lusb
|
||||
+endif
|
||||
+endif
|
||||
|
||||
ifdef EFENCE
|
||||
MY_LIBS += -lefence
|
||||
@@ -340,7 +349,7 @@
|
||||
|
||||
doc/x$(TARGET)rc.dist: all src/unix/xmamerc-keybinding-notes.txt
|
||||
./x$(TARGET).$(DISPLAY_METHOD) -noloadconfig -showconfig | \
|
||||
- grep -v loadconfig > doc/x$(TARGET)rc.dist
|
||||
+ grep -v loadconfig | tr "\033" \# > doc/x$(TARGET)rc.dist
|
||||
cat src/unix/xmamerc-keybinding-notes.txt >> doc/x$(TARGET)rc.dist
|
||||
|
||||
doc/gamelist.$(TARGET): all
|
||||
@@ -349,7 +358,8 @@
|
||||
|
||||
doc/x$(TARGET).6: all src/unix/xmame.6-1 src/unix/xmame.6-3
|
||||
cat src/unix/xmame.6-1 > doc/x$(TARGET).6
|
||||
- ./x$(TARGET).$(DISPLAY_METHOD) -manhelp >> doc/x$(TARGET).6
|
||||
+ ./x$(TARGET).$(DISPLAY_METHOD) -noloadconfig -manhelp | \
|
||||
+ tr "\033" \# >> doc/x$(TARGET).6
|
||||
cat src/unix/xmame.6-3 >> doc/x$(TARGET).6
|
||||
|
||||
install: $(INST.$(DISPLAY_METHOD)) install-man
|
|
@ -1,13 +0,0 @@
|
|||
--- src/unix/video-drivers/svgainput.c.orig Fri May 3 02:53:54 2002
|
||||
+++ src/unix/video-drivers/svgainput.c Thu Oct 31 12:46:04 2002
|
||||
@@ -12,6 +12,10 @@
|
||||
#include "devices.h"
|
||||
#include "keyboard.h"
|
||||
|
||||
+#if defined(__ARCH_freebsd)
|
||||
+#define SIGUNUSED SIGUSR2
|
||||
+#endif
|
||||
+
|
||||
static int console_fd = -1;
|
||||
static int mouse_fd = -1;
|
||||
static int leds = 0;
|
Loading…
Reference in a new issue