Update to 2.4.0 and cleanup pkg-descr.
Loosen dependency on curl library. Reset maintainer as old one was bouncing. PR: ports/169722 Submitted by: Kevin Zheng <kevinz5000@gmail.com>
This commit is contained in:
parent
59acc7267c
commit
4cf6cfb784
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=302393
5 changed files with 81 additions and 54 deletions
|
@ -6,15 +6,14 @@
|
|||
#
|
||||
|
||||
PORTNAME= bzflag
|
||||
PORTVERSION= 2.0.16
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 2.4.0
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20source/${PORTVERSION}
|
||||
|
||||
MAINTAINER= chuck@pkix.net
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A multiplayer 3D tank battle game
|
||||
|
||||
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
|
||||
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_SDL= yes
|
||||
|
@ -22,16 +21,10 @@ USE_GL= yes
|
|||
USE_GMAKE= yes
|
||||
USE_PERL5_BUILD=yes
|
||||
GNU_CONFIGURE= yes
|
||||
CPPFLAGS+= ${PTHREAD_CFLAGS}
|
||||
CPPFLAGS+= ${PTHREAD_CFLAGS} -I ${LOCALBASE}/include
|
||||
LDFLAGS+= ${PTHREAD_LIBS}
|
||||
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
|
||||
AUTOHEADER="${TRUE}"
|
||||
|
||||
MAN5= bzw.5
|
||||
MAN6= bzadmin.6 bzflag.6 bzfquery.6 bzfs.6
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|@LINUX_TRUE@||g ; \
|
||||
s|@LINUX_FALSE@|#|g' ${WRKSRC}/src/platform/Makefile.in
|
||||
MAN6= bzadmin.6 bzflag.6 bzfs.6
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (bzflag-2.0.16.tar.bz2) = fe6fa0b89e7f950950111b118ee8534cd54917d2c7f9215c1f3215ece38a608f
|
||||
SIZE (bzflag-2.0.16.tar.bz2) = 11495082
|
||||
SHA256 (bzflag-2.4.0.tar.bz2) = 424cec6fe2b23ce88a9975612799c0e3831bbe85f0b1524faadfb93e7c0ad452
|
||||
SIZE (bzflag-2.4.0.tar.bz2) = 15045931
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
--- configure.orig Sat May 10 13:59:47 2008
|
||||
+++ configure Sat May 10 14:02:42 2008
|
||||
@@ -980,7 +980,7 @@
|
||||
prefix=NONE
|
||||
program_prefix=NONE
|
||||
program_suffix=NONE
|
||||
-program_transform_name=s,x,x,
|
||||
+program_transform_name=
|
||||
silent=
|
||||
site=
|
||||
srcdir=
|
||||
@@ -24625,6 +24625,7 @@
|
||||
beos*)
|
||||
;;
|
||||
*)
|
||||
+ CPPFLAGS="$X_CFLAGS $CPPFLAGS"
|
||||
if test x$no_x = x ; then
|
||||
GLIBS="$X_PRE_LIBS -lX11 $EXTRA_LIBS $GLIBS"
|
||||
fi
|
|
@ -1,18 +1,10 @@
|
|||
BZFlag is a 3D multi-player tank battle game that allows users to play
|
||||
against each other in a networked environment. There are five teams:
|
||||
red, green, blue, purple and rogue (rogue tanks are black). Destroying a
|
||||
player on another team scores a win, while being destroyed or destroying
|
||||
a teammate scores a loss. Rogues have no teammates (not even other
|
||||
rogues), so they cannot shoot teammates and they do not have a team
|
||||
score.
|
||||
BZFlag is a free online multiplayer 3D tank battle game. The name
|
||||
originates from "Battle Zone Capture The Flag". It runs on Windows,
|
||||
Mac OSX, Linux, BSD, and other platforms. It was one of the most
|
||||
popular games ever on Silicon Graphics machines and continues to
|
||||
be developed and improved to this day.
|
||||
|
||||
There are two main styles of play: capture-the-flag and free-for-all. In
|
||||
capture-the-flag, each team (except rogues) has a team base and each
|
||||
team with at least one player has a team flag. The object is to capture
|
||||
an enemy team's flag by bringing it to your team's base. This destroys
|
||||
every player on the captured team, subtracts one from that team's score,
|
||||
and adds one to your team's score. In free-for-all, there are no team
|
||||
flags or team bases. The object is simply to get as high a score as
|
||||
possible.
|
||||
At its heart, the game is a 3D first person tank simulation where
|
||||
opposing teams battle for dominance.
|
||||
|
||||
WWW: http://BZFlag.org/
|
||||
WWW: http://bzflag.org/
|
||||
|
|
|
@ -1,6 +1,3 @@
|
|||
bin/bzadmin
|
||||
bin/bzflag
|
||||
bin/bzfs
|
||||
%%DATADIR%%/automatic_icon.png
|
||||
%%DATADIR%%/blend_flash.png
|
||||
%%DATADIR%%/blue_basetop.png
|
||||
|
@ -33,6 +30,7 @@ bin/bzfs
|
|||
%%DATADIR%%/flag_lost.wav
|
||||
%%DATADIR%%/flag_won.wav
|
||||
%%DATADIR%%/flap.wav
|
||||
%%DATADIR%%/fonts/DejaVu.License
|
||||
%%DATADIR%%/fonts/DejaVuSansCondensedBold_12.fmt
|
||||
%%DATADIR%%/fonts/DejaVuSansCondensedBold_12.png
|
||||
%%DATADIR%%/fonts/DejaVuSansCondensedBold_16.fmt
|
||||
|
@ -67,7 +65,6 @@ bin/bzfs
|
|||
%%DATADIR%%/fonts/DejaVuSerifBold_6.png
|
||||
%%DATADIR%%/fonts/DejaVuSerifBold_8.fmt
|
||||
%%DATADIR%%/fonts/DejaVuSerifBold_8.png
|
||||
%%DATADIR%%/fonts/DejaVu.License
|
||||
%%DATADIR%%/fonts/readme
|
||||
%%DATADIR%%/frog.png
|
||||
%%DATADIR%%/green_basetop.png
|
||||
|
@ -79,6 +76,9 @@ bin/bzfs
|
|||
%%DATADIR%%/green_tank.png
|
||||
%%DATADIR%%/hunt.wav
|
||||
%%DATADIR%%/hunt_select.wav
|
||||
%%DATADIR%%/hunter_bolt.png
|
||||
%%DATADIR%%/hunter_laser.png
|
||||
%%DATADIR%%/hunter_super_bolt.png
|
||||
%%DATADIR%%/hunter_tank.png
|
||||
%%DATADIR%%/jump.wav
|
||||
%%DATADIR%%/jumpjets.png
|
||||
|
@ -112,10 +112,13 @@ bin/bzfs
|
|||
%%DATADIR%%/mountain1.png
|
||||
%%DATADIR%%/mountain2.png
|
||||
%%DATADIR%%/mountain3.png
|
||||
%%DATADIR%%/mountain4.png
|
||||
%%DATADIR%%/mountain5.png
|
||||
%%DATADIR%%/observer_icon.png
|
||||
%%DATADIR%%/phantom.wav
|
||||
%%DATADIR%%/pop.wav
|
||||
%%DATADIR%%/puddle.png
|
||||
%%DATADIR%%/puffs.png
|
||||
%%DATADIR%%/purple_basetop.png
|
||||
%%DATADIR%%/purple_basewall.png
|
||||
%%DATADIR%%/purple_bolt.png
|
||||
|
@ -145,6 +148,7 @@ bin/bzfs
|
|||
%%DATADIR%%/rogue_tank.png
|
||||
%%DATADIR%%/roof.png
|
||||
%%DATADIR%%/shock.wav
|
||||
%%DATADIR%%/shot_tail.png
|
||||
%%DATADIR%%/snowflake.png
|
||||
%%DATADIR%%/spree1.wav
|
||||
%%DATADIR%%/spree2.wav
|
||||
|
@ -159,9 +163,66 @@ bin/bzfs
|
|||
%%DATADIR%%/thief.png
|
||||
%%DATADIR%%/thief.wav
|
||||
%%DATADIR%%/title.png
|
||||
%%DATADIR%%/treads.png
|
||||
%%DATADIR%%/wall.png
|
||||
%%DATADIR%%/water.png
|
||||
%%DATADIR%%/zone_ground.png
|
||||
@dirrm %%DATADIR%%/l10n
|
||||
bin/bzadmin
|
||||
bin/bzflag
|
||||
bin/bzfs
|
||||
lib/bzflag/HoldTheFlag.la
|
||||
lib/bzflag/HoldTheFlag.so
|
||||
lib/bzflag/Phoenix.la
|
||||
lib/bzflag/Phoenix.so
|
||||
lib/bzflag/RogueGenocide.la
|
||||
lib/bzflag/RogueGenocide.so
|
||||
lib/bzflag/SAMPLE_PLUGIN.la
|
||||
lib/bzflag/SAMPLE_PLUGIN.so
|
||||
lib/bzflag/TimeLimit.la
|
||||
lib/bzflag/TimeLimit.so
|
||||
lib/bzflag/airspawn.la
|
||||
lib/bzflag/airspawn.so
|
||||
lib/bzflag/chathistory.la
|
||||
lib/bzflag/chathistory.so
|
||||
lib/bzflag/customflagsample.la
|
||||
lib/bzflag/customflagsample.so
|
||||
lib/bzflag/flagStay.la
|
||||
lib/bzflag/flagStay.so
|
||||
lib/bzflag/hiddenAdmin.la
|
||||
lib/bzflag/hiddenAdmin.so
|
||||
lib/bzflag/keepaway.la
|
||||
lib/bzflag/keepaway.so
|
||||
lib/bzflag/killall.la
|
||||
lib/bzflag/killall.so
|
||||
lib/bzflag/koth.la
|
||||
lib/bzflag/koth.so
|
||||
lib/bzflag/logDetail.la
|
||||
lib/bzflag/logDetail.so
|
||||
lib/bzflag/nagware.la
|
||||
lib/bzflag/nagware.so
|
||||
lib/bzflag/playHistoryTracker.la
|
||||
lib/bzflag/playHistoryTracker.so
|
||||
lib/bzflag/pushstats.la
|
||||
lib/bzflag/pushstats.so
|
||||
lib/bzflag/rabbitTimer.la
|
||||
lib/bzflag/rabbitTimer.so
|
||||
lib/bzflag/rabidRabbit.la
|
||||
lib/bzflag/rabidRabbit.so
|
||||
lib/bzflag/recordmatch.la
|
||||
lib/bzflag/recordmatch.so
|
||||
lib/bzflag/regFlag.la
|
||||
lib/bzflag/regFlag.so
|
||||
lib/bzflag/serverControl.la
|
||||
lib/bzflag/serverControl.so
|
||||
lib/bzflag/shockwaveDeath.la
|
||||
lib/bzflag/shockwaveDeath.so
|
||||
lib/bzflag/teamflagreset.la
|
||||
lib/bzflag/teamflagreset.so
|
||||
lib/bzflag/timedctf.la
|
||||
lib/bzflag/timedctf.so
|
||||
lib/bzflag/wwzones.la
|
||||
lib/bzflag/wwzones.so
|
||||
@dirrm %%DATADIR%%/fonts
|
||||
@dirrm %%DATADIR%%/l10n
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrm lib/bzflag
|
||||
|
|
Loading…
Reference in a new issue