- Update to 1.0.1

This commit is contained in:
Dennis Herrmann 2010-01-05 20:27:26 +00:00
parent 853c0e778f
commit 4cf80ddff4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=247226
10 changed files with 109 additions and 8 deletions

View file

@ -6,9 +6,9 @@
#
PORTNAME= vitunes
PORTVERSION= 0.93
PORTVERSION= 1.0.1
CATEGORIES= audio
MASTER_SITES= http://www.ryanflannery.net/hacking/vitunes/files/ \
MASTER_SITES= http://www.vitunes.org/files/ \
http://mirror.4bit.ws/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= dhn
@ -25,8 +25,6 @@ LIB_DEPENDS= id3tag.0:${PORTSDIR}/audio/libid3tag \
MAKE_ARGS= LDFLAGS_DEPS="-L${LOCALBASE}/lib -lid3tag -lmp4v2 -logg -lvorbis -lvorbisfile" \
CFLAGS_DEPS="-I${LOCALBASE}/include"
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= vitunes
PLIST_FILES= bin/vitunes

View file

@ -1,3 +1,3 @@
MD5 (vitunes-0.93.tgz) = 9eca27cd9b4991703298fd82bd677553
SHA256 (vitunes-0.93.tgz) = a5e02a96f60806d17ae664329733a52c910a100dc9c502bbc3877bebed4d5c6b
SIZE (vitunes-0.93.tgz) = 36201
MD5 (vitunes-1.0.1.tgz) = 4d8250dd3623abff518e5cbc19946ee1
SHA256 (vitunes-1.0.1.tgz) = 31d27da83a25c8084db03d3ae9917ea17cde5ba430645dd2cd898e79788ac8c8
SIZE (vitunes-1.0.1.tgz) = 54274

View file

@ -0,0 +1,11 @@
--- ./Makefile.orig 2010-01-04 03:17:55.000000000 +0100
+++ ./Makefile 2010-01-05 18:32:48.000000000 +0100
@@ -7,7 +7,7 @@
LDEPS=-L/usr/local/lib -lid3tag -lmp4v2 -logg -lvorbis -lvorbisfile
CC=/usr/bin/gcc
-CFLAGS=-c -Wall -ansi -g $(CDEPS)
+CFLAGS=-c -Wall -g $(CDEPS) -std=c99
LDFLAGS=-lutil -lncurses -lm $(LDEPS)

View file

@ -0,0 +1,21 @@
--- ./medialib.c.orig 2010-01-04 03:17:55.000000000 +0100
+++ ./medialib.c 2010-01-05 18:32:53.000000000 +0100
@@ -287,7 +287,8 @@
* last extracted meta-info from it (otherwise we ignore)
*/
- if (sb.st_mtim.tv_sec > mdb.library->files[i]->last_updated) {
+ //if (sb.st_mtim > mdb.library->files[i]->last_updated) {
+ if (sb.st_mtime > mdb.library->files[i]->last_updated) {
mi = meta_extract(filename);
if (mi == NULL) {
@@ -385,7 +386,7 @@
if (idx != -1) {
/* file already exists in library database - update */
- if (ftsent->fts_statp->st_mtim.tv_sec >
+ if (ftsent->fts_statp->st_mtime >
mdb.library->files[idx]->last_updated) {
/* file has been modified since we last extracted info */

View file

@ -0,0 +1,18 @@
--- ./medialib.h.orig 2010-01-04 03:17:55.000000000 +0100
+++ ./medialib.h 2010-01-05 18:32:57.000000000 +0100
@@ -7,9 +7,15 @@
#ifndef MEDIA_LIBRARY_H
#define MEDIA_LIBRARY_H
+#include <limits.h>
+#include <stdlib.h>
#include <sys/errno.h>
#include <sys/types.h>
#include <sys/stat.h>
+#include <unistd.h>
+
+typedef unsigned short u_short;
+
#include <fts.h>
#include "meta_info.h"

View file

@ -0,0 +1,11 @@
--- ./meta_info.c.orig 2010-01-04 03:17:55.000000000 +0100
+++ ./meta_info.c 2010-01-05 18:33:03.000000000 +0100
@@ -678,7 +678,7 @@
const char *errstr = NULL;
/* note that the range is here what libid3tag can handle */
- gindex = strtonum(mi->cinfo[MI_CINFO_GENRE], 0, 147, &errstr);
+ gindex = atoll(mi->cinfo[MI_CINFO_GENRE]);
if (errstr != NULL) { /* check for invalid genre number */
free(mi->cinfo[MI_CINFO_GENRE]);
mi->cinfo[MI_CINFO_GENRE] = NULL;

View file

@ -0,0 +1,10 @@
--- ./meta_info.h.orig 2010-01-04 03:17:55.000000000 +0100
+++ ./meta_info.h 2010-01-05 18:33:09.000000000 +0100
@@ -5,6 +5,7 @@
#include <limits.h>
#include <stdlib.h>
#include <string.h>
+#include <strings.h>
#include <ctype.h>
#include <time.h>
#include <err.h>

View file

@ -0,0 +1,15 @@
--- ./uinterface.h.orig 2010-01-04 03:17:55.000000000 +0100
+++ ./uinterface.h 2010-01-05 18:33:14.000000000 +0100
@@ -17,11 +17,11 @@
#define UINTERFACE_H
#include <sys/ioctl.h>
-#include <sys/ioctl_compat.h>
#include <ncurses.h>
#include <ctype.h>
#include <stdio.h>
#include <stdlib.h>
+#include <stdint.h>
#include <string.h>
#include <stdbool.h>
#include <termios.h>

View file

@ -0,0 +1,17 @@
--- ./vitunes.h.orig 2010-01-04 03:17:55.000000000 +0100
+++ ./vitunes.h 2010-01-05 18:33:18.000000000 +0100
@@ -1,10 +1,13 @@
#ifndef VITUNES_H
#define VITUNES_H
+#include <signal.h>
#include <sys/time.h>
#include <locale.h>
-#include <util.h>
+//#include <util.h>
#include <pwd.h>
+#include <unistd.h>
+#include <getopt.h>
#include "input_handlers.h"
#include "uinterface.h"

View file

@ -3,4 +3,4 @@ systems with vim-like keybinds. It's primary goal is to serve as an index of
"tagged" multimedia files and provide a quick, easy interface for browsing &
searching your files, and creating playlists.
WWW: http://www.ryanflannery.net/hacking/vitunes/
WWW: http://www.vitunes.org/