Fix build under 9.0.

Assume maintainership of this orphan.

Feature safe:	yes
This commit is contained in:
Cy Schubert 2011-12-06 21:19:47 +00:00
parent c708a68edf
commit 4d4091e326
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=286991
2 changed files with 16 additions and 5 deletions

View file

@ -10,7 +10,7 @@ PORTVERSION= 0.93.0
CATEGORIES= net
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
MAINTAINER= cy@FreeBSD.org
COMMENT= A ftp-like client for the FSP service
USE_BZIP2= yes
@ -23,8 +23,4 @@ PLIST_FILES= bin/fsp
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 900007
BROKEN= fails to build with new utmpx
.endif
.include <bsd.port.post.mk>

View file

@ -0,0 +1,15 @@
--- bsd/print.c.orig 2009-09-15 13:34:20.000000000 -0700
+++ bsd/print.c 2011-12-06 13:16:42.300321971 -0800
@@ -27,7 +27,12 @@
#include "client.h"
#include <grp.h>
#include <pwd.h>
+#include <sys/param.h>
+#if defined(__FreeBSD_version) && __FreeBSD_version > 900007
+#include <utmpx.h>
+#else
#include <utmp.h>
+#endif
#include <time.h>
#include "ls.h"