- Update to 1.6.1

- Respect CFLAGS
- Take maintainership

ChangeLog for this version:
  - added feature - the ability to call gl_normal_io() from
    callbacks registered by gl_watch_fd() and
    gl_inactivity_timeout(). This allows these callbacks to cleanly
    suspend line editing before either reading from the terminal, or
    writing to the terminal; and then subsequently causes the input line
    to be automatically redisplayed, and line-editing to be resumed by
    gl_get_line(), as soon as the callback returns.
  - bugfixes

PR:		ports/101929
Submitted by:	Stanislav Sedov <ssedov@mbsd.msk.ru>
This commit is contained in:
Renato Botelho 2006-08-14 15:38:31 +00:00
parent f1d840ea79
commit 4d5cd28705
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=170595
4 changed files with 41 additions and 11 deletions

View file

@ -7,21 +7,21 @@
#
PORTNAME= libtecla
PORTVERSION= 1.6.0
PORTVERSION= 1.6.1
CATEGORIES= devel
MASTER_SITES= http://www.astro.caltech.edu/~mcs/tecla/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= ssedov@mbsd.msk.ru
COMMENT= Interactive command line editing facilities
USE_SUBMAKE= yes
USE_AUTOTOOLS= autoconf:253
WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
USE_SUBMAKE= yes
ALL_TARGET= default
USE_LDCONFIG= yes
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
REALCURDIR="${.CURDIR}" \
PORTNAME="${PORTNAME}"
INSTALLS_SHLIB= yes
REALCURDIR="${.CURDIR}" \
PORTNAME="${PORTNAME}"
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
@ -33,6 +33,10 @@ PLIST_SUB+= THREADS=""
post-extract:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/genmanlist.sh
post-patch:
@${REINPLACE_CMD} -e 's,^OPT = -O,OPT =,' \
${WRKSRC}/Makefile.in
post-clean:
@${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc

View file

@ -1,3 +1,3 @@
MD5 (libtecla-1.6.0.tar.gz) = 4dbfe11c026e20e3e2352ce2b1573363
SHA256 (libtecla-1.6.0.tar.gz) = 39398426a6bd8b023982e392b665810539688553ed9549c09f7d82fe6580497b
SIZE (libtecla-1.6.0.tar.gz) = 513586
MD5 (libtecla-1.6.1.tar.gz) = 1892c8db9fecd38ed686b3ccf72a569b
SHA256 (libtecla-1.6.1.tar.gz) = 21db2947bd1415070e0462673aa9bed04610946e09169fcd63e02557b0d999a1
SIZE (libtecla-1.6.1.tar.gz) = 518995

View file

@ -0,0 +1,26 @@
--- demo3.c.orig Sat Aug 12 19:31:16 2006
+++ demo3.c Sat Aug 12 19:31:29 2006
@@ -37,17 +37,17 @@
#include <locale.h>
#include <setjmp.h>
-#ifdef HAVE_SELECT
-#ifdef HAVE_SYS_SELECT_H
-#include <sys/select.h>
-#endif
-#endif
-
#include <unistd.h>
#include <sys/stat.h>
#include <sys/time.h>
#include <sys/types.h>
#include <signal.h>
+
+#ifdef HAVE_SELECT
+#ifdef HAVE_SYS_SELECT_H
+#include <sys/select.h>
+#endif
+#endif
#include "libtecla.h"

View file

@ -1,8 +1,8 @@
bin/enhance
include/libtecla.h
lib/libtecla.a
lib/libtecla.so
lib/libtecla.so.1
%%THREADS%%lib/libtecla_r.a
%%THREADS%%lib/libtecla_r.so
%%THREADS%%lib/libtecla_r.so.1
include/libtecla.h