- Fix build with gcc 4.2

- Use SF macro

PR:		117760
Submitted by:	pietro cerutti <gahr@gahr.ch>
Approved by:	portmgr (pav)
This commit is contained in:
Martin Wilke 2007-11-05 10:04:24 +00:00
parent 9e988e2e8e
commit 4d5f7f8396
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=202508
2 changed files with 12 additions and 9 deletions

View file

@ -11,8 +11,7 @@ PORTNAME= kaptain
PORTVERSION= 0.72
PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A tool for building/running QT GUIs for commmand line programs
@ -27,12 +26,6 @@ CONFIGURE_ARGS= --enable-mt \
MAN1= kaptain.1
INFO= kaptain
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
BROKEN= Broken with gcc 4.2
.endif
post-extract:
@${RM} -f ${WRKSRC}/doc/*.info*
@ -40,4 +33,4 @@ post-patch:
@${REINPLACE_CMD} -e \
's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/examples/dia2code.kaptn
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -0,0 +1,10 @@
--- kaptain/intermediate.h.orig 2004-09-11 16:07:54.000000000 +0200
+++ kaptain/intermediate.h 2007-11-02 11:23:46.000000000 +0100
@@ -7,6 +7,7 @@
using namespace std;
class Grammar;
+class Kaptain;
class Rule;
class Conjunction;
class Parameter;