comms/snap7: port to armv7

Same pattern as the armv7 patch.

PR:	264780
Approved by:	vova@fbsd.ru (maintainer timeout)
This commit is contained in:
Robert Clausecker 2022-06-20 04:42:56 +02:00 committed by Piotr Kubaj
parent 792d1b893d
commit 4dc727ddf3
2 changed files with 19 additions and 1 deletions

View file

@ -23,7 +23,7 @@ MAKE_ARGS= CC=${CC} CXX=${CXX} LinkerName=${CXX} SharedObjectLinkerName="${CXX}
PLIST_FILES= lib/libsnap7.so include/snap7.h share/examples/snap7/c-cpp/snap7.cpp
SNAP_ARCH= ${ARCH:S/amd64/x86_64/:S/armv6/arm_v6/}
SNAP_ARCH= ${ARCH:S/amd64/x86_64/:S/armv/arm_v/}
MAKEFILE= ${SNAP_ARCH}_bsd.mk
post-install:

View file

@ -0,0 +1,18 @@
--- arm_v7_bsd.mk.orig 2016-12-20 09:52:10 UTC
+++ arm_v7_bsd.mk
@@ -0,0 +1,15 @@
+##
+## ARMHF V7 tested on
+## - Raspberry board -
+##
+## To improve the build speed in small systems disable -pedantic
+## switch in CXXFLAGS
+##
+TargetCPU :=arm_v7
+OS :=bsd
+CXXFLAGS := -O3 -g -fPIC -pedantic
+
+# Standard part
+
+include common.mk
+