archivers/py-zlib-ng: Add new port

PR:		275719
This commit is contained in:
Oleg Sidorkin 2023-12-11 18:57:18 +03:00 committed by Koichiro Iwao
parent 0546dbf944
commit 4e26a09cbb
5 changed files with 44 additions and 0 deletions

View File

@ -207,6 +207,7 @@
SUBDIR += py-warctools
SUBDIR += py-xopen
SUBDIR += py-zipstream-ng
SUBDIR += py-zlib-ng
SUBDIR += py-zopfli
SUBDIR += py-zstandard
SUBDIR += py-zstd

View File

@ -0,0 +1,23 @@
PORTNAME= zlib-ng
DISTVERSION= 0.4.0
CATEGORIES= archivers python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= osidorkin@gmail.com
COMMENT= Python bindings for the zlib-ng library
WWW= https://github.com/pycompression/python-zlib-ng
LICENSE= PSFL
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=51:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR} \
cmake:devel/cmake-core
USES= python:3.7+
USE_PYTHON= autoplist pep517
INSTALL_TARGET=install-strip
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1704480695
SHA256 (zlib-ng-0.4.0.tar.gz) = 3b730881aaeb86f9a4995de5e22499406ccf92f8508b5c017c343d27570a8c0a
SIZE (zlib-ng-0.4.0.tar.gz) = 2458999

View File

@ -0,0 +1,15 @@
--- src/zlib_ng/zlib-ng/CMakeLists.txt.orig 2023-12-25 16:17:33 UTC
+++ src/zlib_ng/zlib-ng/CMakeLists.txt
@@ -74,9 +74,9 @@ option(ZLIB_COMPAT "Compile with zlib compatible API"
#
option(WITH_GZFILEOP "Compile with support for gzFile related functions" ON)
option(ZLIB_COMPAT "Compile with zlib compatible API" OFF)
-option(ZLIB_ENABLE_TESTS "Build test binaries" ON)
-option(ZLIBNG_ENABLE_TESTS "Test zlib-ng specific API" ON)
-option(WITH_GTEST "Build gtest_zlib" ON)
+option(ZLIB_ENABLE_TESTS "Build test binaries" OFF)
+option(ZLIBNG_ENABLE_TESTS "Test zlib-ng specific API" OFF)
+option(WITH_GTEST "Build gtest_zlib" OFF)
option(WITH_FUZZERS "Build test/fuzz" OFF)
option(WITH_BENCHMARKS "Build test/benchmarks" OFF)
option(WITH_BENCHMARK_APPS "Build application benchmarks" OFF)

View File

@ -0,0 +1,2 @@
Faster zlib and gzip compatible compression and decompression by providing
Python bindings for the zlib-ng library.