net-im/{mtxclient,nheko} update to latest upstream releases

These two go together quite closely. Release notes at
	https://github.com/Nheko-Reborn/mtxclient/releases/tag/v0.3.0
	https://github.com/Nheko-Reborn/nheko/releases/tag/v0.7.0
Mostly more features for rich-IM purposes.

Fighting with the nheko build shows me we rather need a port for
lmdb++ and tweeny.

Reported by:	portscout
This commit is contained in:
Adriaan de Groot 2020-04-21 09:35:26 +00:00
parent b726610b3a
commit 4e3bd299a3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=532262
7 changed files with 86 additions and 30 deletions

View file

@ -2,8 +2,7 @@
PORTNAME= mtxclient
DISTVERSIONPREFIX= v
DISTVERSION= 0.2.1
PORTREVISION= 9
DISTVERSION= 0.3.0
CATEGORIES= net-im
MAINTAINER= adridg@FreeBSD.org
@ -19,14 +18,13 @@ LIB_DEPENDS= libsodium.so:security/libsodium \
libboost_date_time.so:devel/boost-libs \
libboost_chrono.so:devel/boost-libs \
libboost_iostreams.so:devel/boost-libs \
libboost_random.so:devel/boost-libs \
libboost_regex.so:devel/boost-libs \
libboost_system.so:devel/boost-libs \
libboost_thread.so:devel/boost-libs \
libolm.so:security/olm
USES= cmake compiler:c++11-lang pkgconfig \
localbase:ldflags tar:xz
USES= cmake compiler:c++17-lang pkgconfig ssl \
tar:xz
USE_GITHUB= yes
GH_ACCOUNT= Nheko-Reborn

View file

@ -1,5 +1,3 @@
TIMESTAMP = 1559832672
SHA256 (Nheko-Reborn-mtxclient-v0.2.1_GH0.tar.gz) = 859217f3ed8fbe5479a6cf77dc15f164c76e593f588990c2acce3fe13c9f845a
SIZE (Nheko-Reborn-mtxclient-v0.2.1_GH0.tar.gz) = 478840
SHA256 (cdbf06f341e9.patch) = a47d051af377b24c06e4802c491548a6957ca428d923d8f14f9d55cf92f21195
SIZE (cdbf06f341e9.patch) = 626
TIMESTAMP = 1587418243
SHA256 (Nheko-Reborn-mtxclient-v0.3.0_GH0.tar.gz) = 0c2930b5861d93bab9a6515adca74ebaa78984119705d9b4372a9deb275dd30c
SIZE (Nheko-Reborn-mtxclient-v0.3.0_GH0.tar.gz) = 507299

View file

@ -26,8 +26,11 @@ include/mtx/events/pinned_events.hpp
include/mtx/events/power_levels.hpp
include/mtx/events/redaction.hpp
include/mtx/events/tag.hpp
include/mtx/events/tombstone.hpp
include/mtx/events/topic.hpp
include/mtx/identifiers.hpp
include/mtx/log.hpp
include/mtx/pushrules.hpp
include/mtx/requests.hpp
include/mtx/responses.hpp
include/mtx/responses/common.hpp
@ -43,9 +46,12 @@ include/mtx/responses/profile.hpp
include/mtx/responses/register.hpp
include/mtx/responses/sync.hpp
include/mtx/responses/version.hpp
include/mtx/responses/well-known.hpp
include/mtx/user_interactive.hpp
include/mtxclient/crypto/client.hpp
include/mtxclient/crypto/objects.hpp
include/mtxclient/crypto/types.hpp
include/mtxclient/crypto/utils.hpp
include/mtxclient/http/client.hpp
include/mtxclient/http/errors.hpp
include/mtxclient/http/session.hpp
@ -55,4 +61,4 @@ lib/cmake/MatrixClient/MatrixClientConfigVersion.cmake
lib/cmake/MatrixClient/MatrixClientTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/MatrixClient/MatrixClientTargets.cmake
lib/libmatrix_client.so
lib/libmatrix_client.so.0.2.1
lib/libmatrix_client.so.0.3.0

View file

@ -2,8 +2,7 @@
PORTNAME= nheko
DISTVERSIONPREFIX=v
DISTVERSION= 0.6.4
PORTREVISION= 9
DISTVERSION= 0.7.0
CATEGORIES= net-im
MAINTAINER= adridg@FreeBSD.org
@ -12,18 +11,27 @@ COMMENT= Matrix IM client based on Qt technologies
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= nlohmann-json>=3:devel/nlohmann-json \
spdlog>=1.4:devel/spdlog
BUILD_DEPENDS= nlohmann-json>=3:devel/nlohmann-json
# All those boost-libs are pulled in through mtxclient, which
# links to them but stage-qa still complains.
LIB_DEPENDS= liblmdb.so:databases/lmdb \
libfmt.so:devel/libfmt \
libmatrix_client.so:net-im/mtxclient \
libsodium.so:security/libsodium \
libolm.so:security/olm \
libcmark.so:textproc/cmark
libcmark.so:textproc/cmark \
libboost_date_time.so:devel/boost-libs \
libboost_chrono.so:devel/boost-libs \
libboost_iostreams.so:devel/boost-libs \
libboost_regex.so:devel/boost-libs \
libboost_system.so:devel/boost-libs \
libboost_thread.so:devel/boost-libs \
libspdlog.so:devel/spdlog
USES= cmake compiler:c++17-lang pkgconfig \
localbase:ldflags qt:5 tar:xz
USE_QT= concurrent core dbus declarative gui multimedia network svg widgets \
localbase:ldflags qt:5 ssl tar:xz
USE_QT= concurrent core dbus declarative gui multimedia network \
quickcontrols2 svg widgets \
buildtools_build linguist_build qmake_build
# There are two external dependencies: lmdb++ and tweeny.
@ -31,15 +39,17 @@ USE_QT= concurrent core dbus declarative gui multimedia network svg widgets \
# - tweeny is a library, but only one header is needed; it is normally
# installed into a tweeny/ subdirectory, but its sources place it
# in include/. Add one more symlink to the build for that.
# We don't actually use the bundled versions, we get them via
# the ports system (see GH_TUPLE, below).
CMAKE_ARGS= -DLMDBXX_INCLUDE_DIR=${WRKSRC}/deps/lmdb \
-DTWEENY_INCLUDE_DIR=${WRKSRC}/deps/tweeny
-DTWEENY_INCLUDE_DIR=${WRKSRC}/deps/tweeny/include \
CFLAGS+= -DSPDLOG_FMT_EXTERNAL=1
LDFLAGS+= -L${LOCALBASE}/lib -lfmt
USE_GITHUB= yes
GH_ACCOUNT= Nheko-Reborn
GH_TUPLE= drycpp:lmdbxx:0b43ca87d8cfabba392dfe884eb1edb83874de02:lmdb/deps/lmdb \
mobius3:tweeny:v3:tweeny/deps/tweeny
mobius3:tweeny:6a5033372fe53c4c731c66c8a2d56261746cd85c:tweeny/deps/tweeny
post-extract:
cd ${WRKSRC}/deps/tweeny && ${LN} -s include tweeny

View file

@ -1,7 +1,7 @@
TIMESTAMP = 1559832663
SHA256 (Nheko-Reborn-nheko-v0.6.4_GH0.tar.gz) = 5dbe32cb8760cfae6f05644568cabf422a368eec62918839a92e182d508f751e
SIZE (Nheko-Reborn-nheko-v0.6.4_GH0.tar.gz) = 4557720
TIMESTAMP = 1587456842
SHA256 (Nheko-Reborn-nheko-v0.7.0_GH0.tar.gz) = 74cf6aad2a09ef88f55444e81d6028e38dc3245dabce4d80d7d4d9d3e4776fe9
SIZE (Nheko-Reborn-nheko-v0.7.0_GH0.tar.gz) = 779702
SHA256 (drycpp-lmdbxx-0b43ca87d8cfabba392dfe884eb1edb83874de02_GH0.tar.gz) = 93721132bbf5045d38ad62de2997655e9984c48ea5c9886746d42128f4b26fbd
SIZE (drycpp-lmdbxx-0b43ca87d8cfabba392dfe884eb1edb83874de02_GH0.tar.gz) = 47524
SHA256 (mobius3-tweeny-v3_GH0.tar.gz) = 699633578f958cbb1363f80164ac063dc40ce08dfc26b0591752ca412e64c941
SIZE (mobius3-tweeny-v3_GH0.tar.gz) = 48997
SHA256 (mobius3-tweeny-6a5033372fe53c4c731c66c8a2d56261746cd85c_GH0.tar.gz) = c9fcabcdbeb89e4236bbb773ddacf6293ca2a8618f2b1a67e689e3edb704ecd3
SIZE (mobius3-tweeny-6a5033372fe53c4c731c66c8a2d56261746cd85c_GH0.tar.gz) = 49038

View file

@ -1,12 +1,55 @@
--- CMakeLists.txt.orig 2019-07-13 12:11:29 UTC
--- CMakeLists.txt.orig 2020-04-21 08:42:46 UTC
+++ CMakeLists.txt
@@ -114,6 +114,9 @@ if(NOT MSVC)
endif()
@@ -171,6 +171,9 @@ if(NOT MSVC)
endif()
endif()
+# Fix build with Qt 5.13
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DQT_NO_DEPRECATED_WARNINGS=Y")
+
if (MSVC)
set(
CMAKE_CXX_FLAGS
set(
CMAKE_CXX_FLAGS
@@ -391,35 +394,14 @@ set_package_properties(nlohmann_json PROPERTIES
TYPE REQUIRED
)
-if(USE_BUNDLED_LMDBXX)
- hunter_add_package(lmdbxx)
- find_package(lmdbxx CONFIG REQUIRED)
-else()
- if(NOT LMDBXX_INCLUDE_DIR)
- find_path(LMDBXX_INCLUDE_DIR
- NAMES lmdb++.h
- PATHS /usr/include
- /usr/local/include
- $ENV{LIB_DIR}/include
- $ENV{LIB_DIR}/include/lmdbxx)
+message(STATUS "Using LMDB: ${LMDBXX_INCLUDE_DIR}")
+add_library(lmdbxx INTERFACE)
+target_include_directories(lmdbxx INTERFACE ${LMDBXX_INCLUDE_DIR})
+add_library(lmdbxx::lmdbxx ALIAS lmdbxx)
- endif()
- add_library(lmdbxx INTERFACE)
- target_include_directories(lmdbxx INTERFACE ${LMDBXX_INCLUDE_DIR})
- add_library(lmdbxx::lmdbxx ALIAS lmdbxx)
-endif()
-
-if(USE_BUNDLED_TWEENY)
- include(FetchContent)
- FetchContent_Declare(
- Tweeny
- GIT_REPOSITORY https://github.com/mobius3/tweeny.git
- GIT_TAG 6a5033372fe53c4c731c66c8a2d56261746cd85c #v3 <- v3 has unfixed warnings
- )
- FetchContent_MakeAvailable(Tweeny)
-else()
- find_package(Tweeny REQUIRED)
-endif()
+message(STATUS "Using Tweeny: ${TWEENY_INCLUDE_DIR}")
+add_library(tweeny INTERFACE)
+target_include_directories(tweeny INTERFACE ${TWEENY_INCLUDE_DIR})
# single instance functionality
set(QAPPLICATION_CLASS QApplication CACHE STRING "Inheritance class for SingleApplication")

View file

@ -7,4 +7,5 @@ share/icons/hicolor/32x32/apps/nheko.png
share/icons/hicolor/48x48/apps/nheko.png
share/icons/hicolor/512x512/apps/nheko.png
share/icons/hicolor/64x64/apps/nheko.png
share/icons/hicolor/scalable/apps/nheko.svg
share/metainfo/nheko.appdata.xml