Update from 0.17 to 0.18
While I'm about it, make this more compatible with the "MH" port WRT locking and the "deleted" files.
This commit is contained in:
parent
92a8cef587
commit
4e5c3cbd2a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=9212
6 changed files with 161 additions and 155 deletions
|
@ -1,12 +1,12 @@
|
|||
# New ports collection makefile for: nmh
|
||||
# Version required: 0.17
|
||||
# Version required: 0.18
|
||||
# Date created: 26 July 1997
|
||||
# Whom: Scott Blachowicz <Scott.Blachowicz@seaslug.org>
|
||||
#
|
||||
# $Id: Makefile,v 1.1.1.1 1997/06/04 04:39:25 asami Exp $
|
||||
# $Id: Makefile,v 1.2 1997/08/04 06:51:28 markm Exp $
|
||||
#
|
||||
|
||||
DISTNAME= nmh-0.17
|
||||
DISTNAME= nmh-0.18
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ftp://ftp.math.gatech.edu/pub/nmh/
|
||||
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (nmh-0.17.tar.gz) = c18643f3bc43c6d0b8fa2e0dd75406d0
|
||||
MD5 (nmh-0.18.tar.gz) = b989391b0a181bc2586525d09840512f
|
||||
|
|
|
@ -1,43 +1,37 @@
|
|||
diff -ur nmh-0.14-dist/acconfig.h nmh-0.14/acconfig.h
|
||||
--- acconfig.h-dist Wed Apr 16 21:25:42 1997
|
||||
+++ acconfig.h Tue May 20 18:59:52 1997
|
||||
@@ -1,3 +1,9 @@
|
||||
+/* Define if you have the <sys/param.h> header file. */
|
||||
+#undef HAVE_SYS_PARAM_H
|
||||
+#ifdef HAVE_SYS_PARAM_H
|
||||
+#include <sys/param.h>
|
||||
+#endif
|
||||
+
|
||||
|
||||
/****** BEGIN USER CONFIGURATION SECTION *****/
|
||||
|
||||
@@ -37,9 +40,11 @@
|
||||
--- ../nmh-0.18.ORIG/acconfig.h Mon Dec 1 07:52:31 1997
|
||||
+++ acconfig.h Sun Dec 28 14:22:34 1997
|
||||
@@ -36,9 +36,9 @@
|
||||
* OpenBSD 2.x
|
||||
* BSD/OS 2.x
|
||||
*/
|
||||
-/* #define BIND 1 */
|
||||
-/* #define BSD42 1 */
|
||||
-/* #define BSD44 1 */
|
||||
+#ifdef BSD4_4
|
||||
+#define BIND 1
|
||||
+#define BSD42 1
|
||||
+#define BSD44 1
|
||||
+#endif
|
||||
+#define BIND 1 /**/
|
||||
+#define BSD42 1 /**/
|
||||
+#define BSD44 1 /**/
|
||||
|
||||
/*
|
||||
* SCO 4.x
|
||||
@@ -72,10 +77,14 @@
|
||||
@@ -71,10 +71,10 @@
|
||||
* other programs which may modify your maildrops.
|
||||
* Currently you can only use one type.
|
||||
*/
|
||||
+#if defined(BSD44)
|
||||
+#define FCNTL_LOCKING 1
|
||||
+#else
|
||||
#define DOT_LOCKING 1
|
||||
-#define DOT_LOCKING 1
|
||||
+/* #define DOT_LOCKING 1 */
|
||||
/* #define FCNTL_LOCKING 1 */
|
||||
/* #define LOCKF_LOCKING 1 */
|
||||
/* #define FLOCK_LOCKING 1 */
|
||||
+#endif
|
||||
-/* #define FLOCK_LOCKING 1 */
|
||||
+#define FLOCK_LOCKING 1
|
||||
|
||||
/*
|
||||
* If you have defined DOT_LOCKING, then the default is to
|
||||
@@ -154,7 +154,7 @@
|
||||
/*
|
||||
* The prefix to use when messages are "removed" by rmm.
|
||||
*/
|
||||
-#define BACKUP_PREFIX ","
|
||||
+#define BACKUP_PREFIX "#"
|
||||
|
||||
/*
|
||||
* Name of link to file to which you are replying.
|
||||
|
|
|
@ -1,13 +1,140 @@
|
|||
--- configure.in-dist Wed Jun 4 19:39:43 1997
|
||||
+++ configure.in Sat Jun 21 10:13:11 1997
|
||||
@@ -424,8 +424,8 @@
|
||||
[test -z "$CONFIG_HEADERS" || echo > stamp-h])
|
||||
diff -udr ../nmh-0.18.ORIG/Makefile.in ./Makefile.in
|
||||
--- ../nmh-0.18.ORIG/Makefile.in Sat Jul 26 06:38:35 1997
|
||||
+++ ./Makefile.in Sun Dec 28 12:23:55 1997
|
||||
@@ -66,6 +66,7 @@
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||
|
||||
eval "nmhbin=${bindir}"; eval "nmhbin2=${nmhbin}"
|
||||
-eval "nmhetc=${etcdir}"; eval "nmhetc2=${nmhetc}"
|
||||
-eval "nmhlib=${libdir}"; eval "nmhlib2=${nmhlib}"
|
||||
+eval "nmhetc=${sysconfdir}"; eval "nmhetc2=${nmhetc}"
|
||||
+eval "nmhlib=${libexecdir}"; eval "nmhlib2=${nmhlib}"
|
||||
.SUFFIXES:
|
||||
|
||||
diff -udr ../nmh-0.18.ORIG/configure ./configure
|
||||
--- ../nmh-0.18.ORIG/configure Thu Dec 18 03:31:57 1997
|
||||
+++ ./configure Sun Dec 28 12:23:55 1997
|
||||
@@ -968,6 +968,8 @@
|
||||
test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='${INSTALL}'
|
||||
|
||||
test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
|
||||
+
|
||||
+test -z "$INSTALL_SCRIPT" && INSTALL_SCRIPT='${INSTALL} -m 555'
|
||||
# Extract the first word of "ranlib", so it can be a program name with args.
|
||||
set dummy ranlib; ac_word=$2
|
||||
echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
|
||||
@@ -3450,6 +3452,7 @@
|
||||
s%@SET_MAKE@%$SET_MAKE%g
|
||||
s%@INSTALL_PROGRAM@%$INSTALL_PROGRAM%g
|
||||
s%@INSTALL_DATA@%$INSTALL_DATA%g
|
||||
+s%@INSTALL_SCRIPT@%$INSTALL_SCRIPT%g
|
||||
s%@RANLIB@%$RANLIB%g
|
||||
s%@AWK@%$AWK%g
|
||||
s%@LEX@%$LEX%g
|
||||
@@ -3692,7 +3695,7 @@
|
||||
|
||||
eval "nmhbin=${bindir}"; eval "nmhbin2=${nmhbin}"
|
||||
eval "nmhsysconf=${sysconfdir}"; eval "nmhsysconf2=${nmhsysconf}"
|
||||
-eval "nmhlib=${libdir}"; eval "nmhlib2=${nmhlib}"
|
||||
+eval "nmhlib=${libexecdir}"; eval "nmhlib2=${nmhlib}"
|
||||
eval "nmhman=${mandir}"
|
||||
|
||||
echo "
|
||||
@@ -3705,7 +3708,7 @@
|
||||
linker flags : ${LDFLAGS}
|
||||
source code location : ${srcdir}
|
||||
binary install path : ${nmhbin2}
|
||||
-libary install path : ${nmhlib2}
|
||||
+libexec install path : ${nmhlib2}
|
||||
config files install path : ${nmhsysconf2}
|
||||
man page install path : ${nmhman}"
|
||||
echo ""
|
||||
diff -udr ../nmh-0.18.ORIG/configure.in ./configure.in
|
||||
--- ../nmh-0.18.ORIG/configure.in Wed Dec 17 01:18:12 1997
|
||||
+++ ./configure.in Sun Dec 28 12:23:55 1997
|
||||
@@ -400,7 +400,7 @@
|
||||
|
||||
eval "nmhbin=${bindir}"; eval "nmhbin2=${nmhbin}"
|
||||
eval "nmhsysconf=${sysconfdir}"; eval "nmhsysconf2=${nmhsysconf}"
|
||||
-eval "nmhlib=${libdir}"; eval "nmhlib2=${nmhlib}"
|
||||
+eval "nmhlib=${libexecdir}"; eval "nmhlib2=${nmhlib}"
|
||||
eval "nmhman=${mandir}"
|
||||
|
||||
echo "
|
||||
@@ -413,7 +413,7 @@
|
||||
linker flags : ${LDFLAGS}
|
||||
source code location : ${srcdir}
|
||||
binary install path : ${nmhbin2}
|
||||
-libary install path : ${nmhlib2}
|
||||
+libexec install path : ${nmhlib2}
|
||||
config files install path : ${nmhsysconf2}
|
||||
man page install path : ${nmhman}"
|
||||
echo ""
|
||||
diff -udr ../nmh-0.18.ORIG/support/general/Makefile.in ./support/general/Makefile.in
|
||||
--- ../nmh-0.18.ORIG/support/general/Makefile.in Sat Jul 26 06:40:55 1997
|
||||
+++ ./support/general/Makefile.in Sun Dec 28 12:23:55 1997
|
||||
@@ -14,11 +14,13 @@
|
||||
exec_prefix = @exec_prefix@
|
||||
bindir = @bindir@
|
||||
libdir = @libdir@
|
||||
+libexecdir = @libexecdir@
|
||||
etcdir = @sysconfdir@
|
||||
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
||||
|
||||
# Path to search for programs to display content
|
||||
# for mhn. Used to create mhn.defaults
|
||||
@@ -77,9 +79,9 @@
|
||||
done
|
||||
|
||||
install-scripts:
|
||||
- $(top_srcdir)/mkinstalldirs $(libdir)
|
||||
+ $(top_srcdir)/mkinstalldirs $(libexecdir)
|
||||
for script in $(SCRIPTS); do \
|
||||
- $(INSTALL_PROGRAM) $(srcdir)/$$script $(libdir)/$$script; \
|
||||
+ $(INSTALL_SCRIPT) $(srcdir)/$$script $(libexecdir)/$$script; \
|
||||
done
|
||||
|
||||
uninstall: uninstall-files uninstall-scripts
|
||||
@@ -91,7 +93,7 @@
|
||||
|
||||
uninstall-scripts:
|
||||
for script in $(SCRIPTS); do \
|
||||
- rm -f $(libdir)/$$script; \
|
||||
+ rm -f $(libexecdir)/$$script; \
|
||||
done
|
||||
|
||||
# ========== DEPENDENCIES FOR CLEANUP ==========
|
||||
diff -udr ../nmh-0.18.ORIG/uip/Makefile.in ./uip/Makefile.in
|
||||
--- ../nmh-0.18.ORIG/uip/Makefile.in Thu Dec 4 02:16:04 1997
|
||||
+++ ./uip/Makefile.in Sun Dec 28 12:29:13 1997
|
||||
@@ -14,6 +14,7 @@
|
||||
exec_prefix = @exec_prefix@
|
||||
bindir = @bindir@
|
||||
libdir = @libdir@
|
||||
+libexecdir = @libexecdir@
|
||||
etcdir = @sysconfdir@
|
||||
|
||||
CC = @CC@
|
||||
@@ -235,9 +236,9 @@
|
||||
|
||||
# install misc support binaries
|
||||
install-misc:
|
||||
- $(top_srcdir)/mkinstalldirs $(libdir)
|
||||
+ $(top_srcdir)/mkinstalldirs $(libexecdir)
|
||||
for misc in $(MISC); do \
|
||||
- $(INSTALL_PROGRAM) $$misc $(libdir)/$$misc; \
|
||||
+ $(INSTALL_PROGRAM) $$misc $(libexecdir)/$$misc; \
|
||||
done
|
||||
|
||||
uninstall:
|
||||
@@ -248,7 +249,7 @@
|
||||
rm -f $(bindir)/$$lcmd; \
|
||||
done
|
||||
for misc in $(MISC); do \
|
||||
- rm -f $(libdir)/$$misc; \
|
||||
+ rm -f $(libexecdir)/$$misc; \
|
||||
done
|
||||
|
||||
# ========== DEPENDENCIES FOR CLEANUP ==========
|
||||
|
|
|
@ -1,116 +0,0 @@
|
|||
diff -ur Makefile.in-dist Makefile.in
|
||||
--- Makefile.in-dist Mon Apr 21 12:02:36 1997
|
||||
+++ Makefile.in Mon May 12 20:54:23 1997
|
||||
@@ -26,10 +26,10 @@
|
||||
bindir = @bindir@
|
||||
|
||||
# location of nmh configuration and formats files
|
||||
-etcdir = @etcdir@
|
||||
+etcdir = @sysconfdir@
|
||||
|
||||
# location of support binaries and scripts
|
||||
-libdir = @libdir@
|
||||
+libdir = @libexecdir@
|
||||
|
||||
# location of man pages
|
||||
mandir = @mandir@
|
||||
diff -ur config/Makefile.in-dist config/Makefile.in
|
||||
--- config/Makefile.in-dist Mon Jan 6 00:44:54 1997
|
||||
+++ config/Makefile.in Fri May 16 07:05:23 1997
|
||||
@@ -16,7 +16,7 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
bindir = @bindir@
|
||||
-etcdir = @etcdir@
|
||||
-libdir = @libdir@
|
||||
+etcdir = @sysconfdir@
|
||||
+libdir = @libexecdir@
|
||||
|
||||
default_editor = @vipath@
|
||||
diff -ur man/Makefile.in-dist man/Makefile.in
|
||||
--- man/Makefile.in-dist Sun Apr 27 18:48:11 1997
|
||||
+++ man/Makefile.in Fri May 16 07:05:24 1997
|
||||
@@ -15,7 +15,7 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
bindir = @bindir@
|
||||
-etcdir = @etcdir@
|
||||
-libdir = @libdir@
|
||||
+etcdir = @sysconfdir@
|
||||
+libdir = @libexecdir@
|
||||
mandir = @mandir@
|
||||
manext1 = 1
|
||||
diff -ur mts/mmdf/Makefile.in-dist mts/mmdf/Makefile.in
|
||||
--- mts/mmdf/Makefile.in-dist Thu Jan 2 15:00:35 1997
|
||||
+++ mts/mmdf/Makefile.in Fri May 16 07:05:23 1997
|
||||
@@ -12,7 +12,7 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
bindir = @bindir@
|
||||
-etcdir = @etcdir@
|
||||
-libdir = @libdir@
|
||||
+etcdir = @sysconfdir@
|
||||
+libdir = @libexecdir@
|
||||
|
||||
.SUFFIXES:
|
||||
diff -ur mts/sendmail/Makefile.in-dist mts/sendmail/Makefile.in
|
||||
--- mts/sendmail/Makefile.in-dist Tue Apr 15 15:59:41 1997
|
||||
+++ mts/sendmail/Makefile.in Fri May 16 07:05:23 1997
|
||||
@@ -13,7 +13,7 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
bindir = @bindir@
|
||||
-etcdir = @etcdir@
|
||||
-libdir = @libdir@
|
||||
+etcdir = @sysconfdir@
|
||||
+libdir = @libexecdir@
|
||||
|
||||
CC = @CC@
|
||||
diff -ur support/general/Makefile.in-dist support/general/Makefile.in
|
||||
--- support/general/Makefile.in-dist Sat Mar 8 00:44:27 1997
|
||||
+++ support/general/Makefile.in Fri May 16 07:05:24 1997
|
||||
@@ -13,7 +13,7 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
bindir = @bindir@
|
||||
-etcdir = @etcdir@
|
||||
-libdir = @libdir@
|
||||
+etcdir = @sysconfdir@
|
||||
+libdir = @libexecdir@
|
||||
|
||||
INSTALL = @INSTALL@
|
||||
@@ -79,7 +79,7 @@
|
||||
install-scripts:
|
||||
$(top_srcdir)/mkinstalldirs $(libdir)
|
||||
for script in $(SCRIPTS); do \
|
||||
- $(INSTALL_PROGRAM) $(srcdir)/$$script $(libdir)/$$script; \
|
||||
+ $(INSTALL) -m 555 $(srcdir)/$$script $(libdir)/$$script; \
|
||||
done
|
||||
|
||||
uninstall: uninstall-files uninstall-scripts
|
||||
diff -ur uip/Makefile.in-dist uip/Makefile.in
|
||||
--- uip/Makefile.in-dist Wed Feb 5 22:28:41 1997
|
||||
+++ uip/Makefile.in Fri May 16 07:05:24 1997
|
||||
@@ -13,7 +13,7 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
bindir = @bindir@
|
||||
-etcdir = @etcdir@
|
||||
-libdir = @libdir@
|
||||
+etcdir = @sysconfdir@
|
||||
+libdir = @libexecdir@
|
||||
|
||||
CC = @CC@
|
||||
diff -ur zotnet/mts/Makefile.in-dist zotnet/mts/Makefile.in
|
||||
--- zotnet/mts/Makefile.in-dist Sat Mar 8 00:48:14 1997
|
||||
+++ zotnet/mts/Makefile.in Fri May 16 07:05:23 1997
|
||||
@@ -13,7 +13,7 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
bindir = @bindir@
|
||||
-etcdir = @etcdir@
|
||||
-libdir = @libdir@
|
||||
+etcdir = @sysconfdir@
|
||||
+libdir = @libdir@
|
||||
|
||||
mailspool = @mailspool@
|
|
@ -4,6 +4,7 @@ bin/burst
|
|||
bin/comp
|
||||
bin/dist
|
||||
bin/flist
|
||||
bin/flists
|
||||
bin/folder
|
||||
bin/folders
|
||||
bin/forw
|
||||
|
|
Loading…
Reference in a new issue