devel/pstreams: Update to 1.0.3
- Update WWW - Update LICENSE - Add LICENSE_FILE - Add NO_ARCH - Update pkg-descr - Take maintainership Changes: https://github.com/jwakely/pstreams/commits/master
This commit is contained in:
parent
95666d6810
commit
4e5c9b4b98
4 changed files with 26 additions and 21 deletions
|
@ -1,18 +1,22 @@
|
|||
PORTNAME= pstreams
|
||||
PORTVERSION= 0.8.1
|
||||
PORTVERSION= 1.0.3
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Release%200.8.x
|
||||
MASTER_SITES= SF/pstreams/pstreams/Release%20${PORTVERSION:R}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= C++ utility for simple IOStream-based IPC
|
||||
WWW= http://pstreams.sourceforge.net/
|
||||
WWW= https://pstreams.sourceforge.net/
|
||||
|
||||
LICENSE= LGPL3
|
||||
LICENSE= BSL
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE_1_0.txt
|
||||
|
||||
USES= gmake
|
||||
MAKE_ENV+= INSTALL_PREFIX=${PREFIX}
|
||||
NO_ARCH= yes
|
||||
NO_BUILD= yes
|
||||
|
||||
PLIST_FILES= include/pstreams/pstream.h
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${STAGEDIR}${PREFIX}/include/pstreams/
|
||||
${INSTALL_DATA} ${WRKSRC}/pstream.h ${STAGEDIR}${PREFIX}/include/pstreams/pstream.h
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (pstreams-0.8.1.tar.gz) = b60d2e9b7466a27c43911de09311ab1936c09b9f48039347b2a430e91871dd7a
|
||||
SIZE (pstreams-0.8.1.tar.gz) = 58588
|
||||
TIMESTAMP = 1695143221
|
||||
SHA256 (pstreams-1.0.3.tar.gz) = e9ca807bc6046840deae63207183f9ac516e67187d035429772a5fc7bd3e8fc8
|
||||
SIZE (pstreams-1.0.3.tar.gz) = 69119
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.orig 2013-03-29 20:06:56.000000000 +0100
|
||||
+++ Makefile 2013-10-18 13:32:23.570564959 +0200
|
||||
@@ -39,7 +39,7 @@
|
||||
|
||||
VERS := $(shell awk -F' ' '/^\#define *PSTREAMS_VERSION/{ print $$NF }' pstream.h)
|
||||
|
||||
-all: docs $(GENERATED_FILES)
|
||||
+all: install
|
||||
|
||||
check: test_pstreams test_minimum | pstreams.wout
|
||||
@for test in $^ ; do echo $$test ; ./$$test >/dev/null 2>&1 || echo "$$test EXITED WITH STATUS $$?" ; done
|
|
@ -1 +1,12 @@
|
|||
C++ utility for simple IOStream-based Inter-Process Communication
|
||||
PStreams allows you to run another program from your C++ application and to
|
||||
transfer data between the two programs similar to shell pipelines.
|
||||
|
||||
In the simplest case, a PStreams class is like a C++ wrapper for the POSIX.2
|
||||
functions popen(3) and pclose(3), using C++ iostreams instead of C's stdio
|
||||
library.
|
||||
|
||||
The library provides class templates in the style of the standard iostreams that
|
||||
can be used with any ISO C++ compiler on a POSIX platform. The classes use a
|
||||
streambuf class that uses fork(2) and the exec(2) family of functions to create
|
||||
a new process and creates up to three pipes to write/read data to/from the
|
||||
process.
|
||||
|
|
Loading…
Reference in a new issue