Switch to use Qt4.

Pass maintainership to submitter.

PR:		based on ports/130925
Submitted by:	Cristiano Rolim Pereira <cristianorolim at hotmail.com>
This commit is contained in:
Max Brazhnikov 2009-03-17 20:00:05 +00:00
parent 97e238eadb
commit 4e5f6ef523
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=230315
3 changed files with 28 additions and 15 deletions

View file

@ -7,23 +7,31 @@
PORTNAME= SoQt
PORTVERSION= 1.4.1
PORTREVISION= 4
PORTREVISION= 5
CATEGORIES= x11-toolkits
MASTER_SITES= http://ftp.coin3d.org/coin/src/all/ \
ftp://ftp.coin3d.org/pub/coin/src/all/
DIST_SUBDIR= KDE
MAINTAINER= ports@FreeBSD.org
COMMENT= Qt toolkit library for Coin
MAINTAINER= cristianorolim@hotmail.com
COMMENT= Qt4 toolkit library for Coin
LIB_DEPENDS= Coin.60:${PORTSDIR}/graphics/Coin
USE_AUTOTOOLS= libtool:15
USE_QT_VER= 3
USE_QT_VER= 4
QT_COMPONENTS= corelib qt3support opengl moc_build
USE_GMAKE= yes
CPPFLAGS+= -I${QT_INCDIR} -I${QT_INCDIR}/Qt -I${LOCALBASE}/include
LDFLAGS+= -L${QT_LIBDIR} -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
CONFIGURE_ENV= QTDIR="${QT_PREFIX}"
CONFIGURE_ARGS= --with-pthread=yes --with-coin=${LOCALBASE}
CONFIGURE_ENV= QTDIR="${QT_PREFIX}" \
CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-pthread=yes --with-coin=${LOCALBASE} \
--with-qt=${QT_LIBDIR}
USE_LDCONFIG= yes
MAN1= soqt-config.1
@ -31,10 +39,4 @@ MAN1= soqt-config.1
post-install:
@${TOUCH} ${PREFIX}/include/Inventor/Qt/engines/.keep_me
.include <bsd.port.pre.mk>
.if ${ARCH} == i386
BROKEN= does not build
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -0,0 +1,11 @@
--- src/Inventor/Qt/SoQtComponent.cpp.orig 2009-03-16 23:36:07.000000000 -0300
+++ src/Inventor/Qt/SoQtComponent.cpp 2009-03-16 23:36:23.000000000 -0300
@@ -100,7 +100,7 @@
this->parent->removeEventFilter(this);
}
-static void delete_dict_value(unsigned long key, void * value)
+static void delete_dict_value(uintptr_t key, void * value)
{
delete (QCursor *)value;
}

View file

@ -1,7 +1,7 @@
From the README:
SoQt is a Qt GUI component toolkit library for Coin. It is also compatible
with SGI and TGS Open Inventor, and the API is based on the API of the
InventorXt GUI component toolkit.
Qt4 is used in this version.
WWW: http://www.coin3d.org/