www/chromium: update to 58.0.3029.96

MFH:		2017Q2
Security:	https://vuxml.freebsd.org/freebsd/92e345d0-304d-11e7-8359-e8e0b747a45a.html
This commit is contained in:
Carlos J. Puga Medina 2017-05-03 23:53:11 +00:00
parent cee04c2058
commit 4e70e14bf5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=440072
13 changed files with 102 additions and 40 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= chromium
PORTVERSION= 58.0.3029.81
PORTREVISION= 1
PORTVERSION= 58.0.3029.96
CATEGORIES= www
MASTER_SITES= http://commondatastorage.googleapis.com/chromium-browser-official/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} # default, but needed to get distinfo correct if TEST is on
@ -246,7 +245,7 @@ test regression-test: build
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_MAN} ${WRKSRC}/out/${BUILDTYPE}/chrome.1 ${STAGEDIR}${MANPREFIX}/man/man1
.for t in font_service ui
.for t in font_service test_ime_driver ui
${INSTALL_DATA} ${WRKSRC}/out/${BUILDTYPE}/${t}.service \
${STAGEDIR}${DATADIR}
.endfor

View file

@ -1,5 +1,5 @@
TIMESTAMP = 1492682402
SHA256 (chromium-58.0.3029.81.tar.xz) = 5ab61b7025a5143fa1b21713479b316ec7a98e262e79e84f9c9a9656179217cb
SIZE (chromium-58.0.3029.81.tar.xz) = 509252204
SHA256 (chromium-58.0.3029.81-testdata.tar.xz) = 8fa8d18c5ccfa8cbb067c4d88a0b8ed0dfd52b5d784c2cf48b91d1cb3a2fb264
SIZE (chromium-58.0.3029.81-testdata.tar.xz) = 124158512
TIMESTAMP = 1493784258
SHA256 (chromium-58.0.3029.96.tar.xz) = 5d38fd7ad3b58bd09da8ff05f12354e94c2ad1bb203527a632b72cc3ff4a5181
SIZE (chromium-58.0.3029.96.tar.xz) = 518160320
SHA256 (chromium-58.0.3029.96-testdata.tar.xz) = 2451cfe8f25f578dbce3b85a00589e4609958db969ad4421f89e780751bf067b
SIZE (chromium-58.0.3029.96-testdata.tar.xz) = 124156492

View file

@ -0,0 +1,11 @@
--- chrome/browser/after_startup_task_utils.cc.orig 2017-05-02 19:02:47 UTC
+++ chrome/browser/after_startup_task_utils.cc
@@ -93,7 +93,7 @@ void QueueTask(std::unique_ptr<AfterStar
void SetBrowserStartupIsComplete() {
DCHECK_CURRENTLY_ON(BrowserThread::UI);
-#if defined(OS_MACOSX) || defined(OS_WIN) || defined(OS_LINUX)
+#if defined(OS_MACOSX) || defined(OS_WIN) || defined(OS_LINUX) || defined(OS_BSD)
// CurrentProcessInfo::CreationTime() is not available on all platforms.
const base::Time process_creation_time =
base::CurrentProcessInfo::CreationTime();

View file

@ -0,0 +1,20 @@
--- chrome/browser/download/download_status_updater.cc.orig 2017-05-02 19:02:47 UTC
+++ chrome/browser/download/download_status_updater.cc
@@ -13,7 +13,7 @@
#include "base/memory/ptr_util.h"
#include "build/build_config.h"
-#if defined(OS_LINUX) && !defined(OS_CHROMEOS)
+#if (defined(OS_LINUX) || defined(OS_BSD)) && !defined(OS_CHROMEOS)
#include "ui/views/linux_ui/linux_ui.h"
#endif
@@ -136,7 +136,7 @@ void DownloadStatusUpdater::OnDownloadUp
#if defined(OS_ANDROID) || (defined(USE_AURA) && !defined(OS_WIN))
void DownloadStatusUpdater::UpdateAppIconDownloadProgress(
content::DownloadItem* download) {
-#if defined(OS_LINUX) && !defined(OS_CHROMEOS)
+#if (defined(OS_LINUX) || defined(OS_BSD)) && !defined(OS_CHROMEOS)
const views::LinuxUI* linux_ui = views::LinuxUI::instance();
if (linux_ui) {
float progress = 0;

View file

@ -1,4 +1,4 @@
--- chrome/browser/extensions/BUILD.gn.orig 2017-04-19 19:06:29 UTC
--- chrome/browser/extensions/BUILD.gn.orig 2017-05-02 19:02:47 UTC
+++ chrome/browser/extensions/BUILD.gn
@@ -1040,7 +1040,7 @@ static_library("extensions") {
sources -= [ "global_shortcut_listener_ozone.cc" ]
@ -9,6 +9,15 @@
deps += [ "//build/linux:fontconfig" ]
if (use_dbus) {
@@ -1100,7 +1100,7 @@ static_library("extensions") {
]
}
- if (is_win || (is_linux && !is_chromeos)) {
+ if (is_win || ((is_linux || is_bsd) && !is_chromeos)) {
sources += [
"api/input_ime/input_ime_api.cc",
"api/input_ime/input_ime_api.h",
@@ -1133,6 +1133,12 @@ static_library("extensions") {
defines += [ "ENABLE_HOTWORDING" ]
}

View file

@ -1,4 +1,4 @@
--- chrome/browser/extensions/browser_context_keyed_service_factories.cc.orig 2017-04-19 19:06:29 UTC
--- chrome/browser/extensions/browser_context_keyed_service_factories.cc.orig 2017-05-02 19:02:47 UTC
+++ chrome/browser/extensions/browser_context_keyed_service_factories.cc
@@ -63,7 +63,7 @@
#include "chrome/browser/chromeos/extensions/media_player_api.h"
@ -14,7 +14,7 @@
extensions::InputImeAPI::GetFactoryInstance();
extensions::InputMethodAPI::GetFactoryInstance();
-#elif defined(OS_LINUX) || defined(OS_WIN)
+#elif defined(OS_LINUX) || defined(OS_WIN) && !defined(OS_BSD)
+#elif defined(OS_LINUX) || defined(OS_WIN) || defined(OS_BSD)
extensions::InputImeAPI::GetFactoryInstance();
#endif
extensions::LanguageSettingsPrivateDelegateFactory::GetInstance();

View file

@ -1,4 +1,4 @@
--- chrome/browser/ui/webui/chrome_web_ui_controller_factory.cc.orig 2017-04-19 19:06:30 UTC
--- chrome/browser/ui/webui/chrome_web_ui_controller_factory.cc.orig 2017-05-02 19:02:48 UTC
+++ chrome/browser/ui/webui/chrome_web_ui_controller_factory.cc
@@ -290,7 +290,7 @@ bool IsAboutUI(const GURL& url) {
#if !defined(OS_ANDROID)
@ -9,3 +9,12 @@
|| url.host_piece() == chrome::kChromeUILinuxProxyConfigHost ||
url.host_piece() == chrome::kChromeUISandboxHost
#endif
@@ -567,7 +567,7 @@ WebUIFactoryFunction GetWebUIFactoryFunc
if (url.host_piece() == chrome::kChromeUINaClHost)
return &NewWebUI<NaClUI>;
#endif
-#if (defined(OS_LINUX) && defined(TOOLKIT_VIEWS)) || defined(USE_AURA)
+#if ((defined(OS_LINUX) || defined(OS_BSD)) && defined(TOOLKIT_VIEWS)) || defined(USE_AURA)
if (url.host_piece() == chrome::kChromeUITabModalConfirmDialogHost) {
return &NewWebUI<ConstrainedWebDialogUI>;
}

View file

@ -0,0 +1,11 @@
--- chrome/common/extensions/api/BUILD.gn.orig 2017-05-02 19:02:48 UTC
+++ chrome/common/extensions/api/BUILD.gn
@@ -116,7 +116,7 @@ if (is_chromeos) {
"wallpaper.json",
"wallpaper_private.json",
]
-} else if (is_linux || is_win) {
+} else if (is_linux || is_bsd || is_win) {
schema_sources += [ "input_ime.json" ]
}
if (enable_service_discovery) {

View file

@ -0,0 +1,20 @@
--- components/filesystem/file_system_app.cc.orig 2017-05-02 19:02:50 UTC
+++ components/filesystem/file_system_app.cc
@@ -23,7 +23,7 @@
#elif defined(OS_ANDROID)
#include "base/base_paths_android.h"
#include "base/path_service.h"
-#elif defined(OS_LINUX)
+#elif defined(OS_LINUX) || defined(OS_BSD)
#include "base/environment.h"
#include "base/nix/xdg_util.h"
#elif defined(OS_MACOSX)
@@ -75,7 +75,7 @@ base::FilePath FileSystemApp::GetUserDat
CHECK(PathService::Get(base::DIR_APP_DATA, &path));
#elif defined(OS_ANDROID)
CHECK(PathService::Get(base::DIR_ANDROID_APP_DATA, &path));
-#elif defined(OS_LINUX)
+#elif defined(OS_LINUX) || defined(OS_BSD)
std::unique_ptr<base::Environment> env(base::Environment::Create());
path = base::nix::GetXDGDirectory(env.get(),
base::nix::kXdgConfigHomeEnvVar,

View file

@ -1,18 +0,0 @@
--- services/ui/BUILD.gn.orig 2017-04-19 19:06:37 UTC
+++ services/ui/BUILD.gn
@@ -12,7 +12,6 @@ group("all") {
testonly = true
deps = [
":ui",
- "//services/ui/ime/test_ime_driver",
"//services/ui/test_wm",
]
}
@@ -32,7 +31,6 @@ service("ui") {
":resources_100",
":resources_200",
":resources_strings",
- "//services/ui/ime/test_ime_driver",
]
}

View file

@ -1,10 +0,0 @@
--- services/ui/ime/BUILD.gn.orig 2017-04-19 19:06:37 UTC
+++ services/ui/ime/BUILD.gn
@@ -51,7 +51,6 @@ service_test("mus_ime_unittests") {
data_deps = [
":lib",
"//services/ui",
- "//services/ui/ime/test_ime_driver",
]
}

View file

@ -0,0 +1,10 @@
--- v8/src/wasm/wasm-result.h.orig 2017-05-02 19:04:10 UTC
+++ v8/src/wasm/wasm-result.h
@@ -5,6 +5,7 @@
#ifndef V8_WASM_RESULT_H_
#define V8_WASM_RESULT_H_
+#include <cstdarg>
#include <memory>
#include "src/base/compiler-specific.h"

View file

@ -223,6 +223,7 @@ share/applications/chromium-browser.desktop
%%DATADIR%%/resources/inspector/unit_test_runner.js
%%DATADIR%%/resources/inspector/utility_shared_worker.js
%%DATADIR%%/snapshot_blob.bin
%%DATADIR%%/test_ime_driver.service
%%DATADIR%%/ui.service
%%DATADIR%%/views_mus_resources.pak
%%DRIVER%%bin/chromedriver