- Fix on amd64 [1]
- Use DOCSDIR in pkg-plist PR: ports/63183 [1] Submitted by: Hendrik Scholz <hendrik@scholz.net> [1]
This commit is contained in:
parent
a69387c6d8
commit
4e7785c79d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=101956
3 changed files with 14 additions and 10 deletions
|
@ -20,8 +20,6 @@ MODULES= ldd_http_module.so
|
|||
DOCS= INSTALL LICENSE README
|
||||
PKGMESSAGE= ${WRKDIR}/pkg-message
|
||||
|
||||
MAKE_ENV+= CPPFLAGS="-DPREFIX=\\\"${PREFIX}\\\""
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -i.bak -e 's|varargs.h|stdarg.h|' \
|
||||
${WRKSRC}/chkmodules.h \
|
||||
|
@ -50,4 +48,10 @@ post-install:
|
|||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
.if ${ARCH} == "amd64"
|
||||
MAKE_ENV+= CPPFLAGS="-DPREFIX=\\\"${PREFIX}\\\" -fPIC"
|
||||
.else
|
||||
MAKE_ENV+= CPPFLAGS="-DPREFIX=\\\"${PREFIX}\\\""
|
||||
.endif
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- modules_check/Makefile.orig Mon Nov 26 07:31:09 2001
|
||||
+++ modules_check/Makefile Tue May 14 14:16:16 2002
|
||||
--- modules_check/Makefile.orig Sun Nov 25 17:31:09 2001
|
||||
+++ modules_check/Makefile Sat Feb 21 14:25:58 2004
|
||||
@@ -1,14 +1,15 @@
|
||||
# If you want to debug lmd comment out this line and recompile it
|
||||
# Launch lmd with -v option to see debug messages
|
||||
|
@ -16,7 +16,7 @@
|
|||
|
||||
socket.o:
|
||||
- gcc -c ../socket.c -o socket.o
|
||||
+ ${CC} -c ../socket.c -o socket.o
|
||||
+ ${CC} ${OPTS} -c ../socket.c -o socket.o
|
||||
|
||||
clean:
|
||||
rm *.so *.o
|
||||
|
|
|
@ -2,7 +2,7 @@ sbin/lmd
|
|||
etc/rc.d/lmd.sh
|
||||
etc/lmd.conf.sample
|
||||
lib/ldd_http_module.so
|
||||
%%PORTDOCS%%share/doc/lmd/README
|
||||
%%PORTDOCS%%share/doc/lmd/INSTALL
|
||||
%%PORTDOCS%%share/doc/lmd/LICENSE
|
||||
%%PORTDOCS%%@dirrm share/doc/lmd
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
|
Loading…
Reference in a new issue