Fix build with clang removing -O4 which means LTO for clang
Feature safe: yes
This commit is contained in:
parent
1c9fd66e3f
commit
4e78d8a135
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=308006
2 changed files with 7 additions and 9 deletions
|
@ -1,9 +1,5 @@
|
|||
# New ports collection makefile for: tycho
|
||||
# Date created: 2008-01-16
|
||||
# Whom: alepulver
|
||||
#
|
||||
# Created by: Alejandro Pulver <alepulver@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= tycho
|
||||
PORTVERSION= 0.1
|
||||
|
|
|
@ -1,12 +1,14 @@
|
|||
--- ./Makefile.orig Thu Sep 4 12:44:24 2003
|
||||
+++ ./Makefile Wed Jan 16 19:36:13 2008
|
||||
@@ -1,7 +1,7 @@
|
||||
--- Makefile.orig 2003-09-04 17:44:24.000000000 +0200
|
||||
+++ Makefile 2012-11-30 13:54:33.684116105 +0100
|
||||
@@ -1,8 +1,8 @@
|
||||
# $Id: Makefile,v 1.3 2003/09/04 15:44:24 varfar Exp $
|
||||
|
||||
-CC = gcc
|
||||
-CFLAGS = ${OPT} ${DBG} -DSIM_STRIP_FLAGS=1
|
||||
-OPT = -O4 -fomit-frame-pointer
|
||||
+CC ?= gcc
|
||||
+CFLAGS += ${OPT} ${DBG} -DSIM_STRIP_FLAGS=1
|
||||
OPT = -O4 -fomit-frame-pointer
|
||||
+OPT = -fomit-frame-pointer
|
||||
#DBG = -g -DDEBUG=2
|
||||
|
||||
# Recommended extra options for gcc:
|
||||
|
|
Loading…
Reference in a new issue