- Update to 0.13.5
PR: 134289 Submitted by: Ports Fury
This commit is contained in:
parent
17054724ba
commit
4edb36c604
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=233514
7 changed files with 13 additions and 73 deletions
|
@ -6,20 +6,27 @@
|
|||
#
|
||||
|
||||
PORTNAME= xaric
|
||||
PORTVERSION= 0.13.2
|
||||
PORTVERSION= 0.13.5
|
||||
CATEGORIES= irc
|
||||
MASTER_SITES= http://rf.cx/software/xaric/releases/
|
||||
MASTER_SITES= http://xaric.org/software/xaric/releases/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= IRC Client similer to BitchX or ircII
|
||||
|
||||
USE_GNOME= gnomehack
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
MAN1= xaric.1
|
||||
PLIST_FILES= bin/xaric \
|
||||
%%DATADIR%%/help/copying \
|
||||
%%DATADIR%%/help/help \
|
||||
%%DATADIR%%/help/warranty
|
||||
PLIST_DIRS= %%DATADIR%%/help \
|
||||
%%DATADIR%%
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e "s,-Werror,," ${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|-ggdb3||g' ${WRKSRC}/Makefile.in
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/xaric ${PREFIX}/bin
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (xaric-0.13.2.tar.gz) = aa345a3bbd8cfffdbb933fc27d868937
|
||||
SHA256 (xaric-0.13.2.tar.gz) = 9447b99ac4474d5d40b08f37c30ccdd5632e23fd991978473e5844f1c824a66d
|
||||
SIZE (xaric-0.13.2.tar.gz) = 449916
|
||||
MD5 (xaric-0.13.5.tar.gz) = 2c6ac8e3f3fe2ec2e6d4ffc076784a09
|
||||
SHA256 (xaric-0.13.5.tar.gz) = 36fb68e0c01b85e7613bd7ca68abd9023c05bef41a195192ea3648d27c95e4ba
|
||||
SIZE (xaric-0.13.5.tar.gz) = 454516
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- iflist.c.orig Sun Jan 8 08:18:32 2006
|
||||
+++ iflist.c Sun Jan 8 08:18:36 2006
|
||||
@@ -184,7 +184,7 @@
|
||||
c->thr_ifcb = callback;
|
||||
c->thr_data = data;
|
||||
|
||||
- return THR_CREATE(ifaces_r, c);
|
||||
+ return (int)THR_CREATE(ifaces_r, c);
|
||||
}
|
||||
|
||||
/**
|
|
@ -1,20 +0,0 @@
|
|||
--- misc.c.orig Wed Nov 30 11:06:26 2005
|
||||
+++ misc.c Sun Jan 8 21:45:27 2006
|
||||
@@ -104,7 +104,7 @@
|
||||
|
||||
char *convert_time(time_t ltime)
|
||||
{
|
||||
- time_t days = 0, hours = 0, minutes = 0, seconds = 0;
|
||||
+ unsigned int days = 0, hours = 0, minutes = 0, seconds = 0;
|
||||
static char buffer[100];
|
||||
|
||||
*buffer = '\0';
|
||||
@@ -114,7 +114,7 @@
|
||||
ltime = (ltime - minutes) / 60;
|
||||
hours = ltime % 24;
|
||||
days = (ltime - hours) / 24;
|
||||
- sprintf(buffer, "%2ldd %2ldh %2ldm %2lds", days, hours, minutes, seconds);
|
||||
+ sprintf(buffer, "%2ud %2uh %2um %2us", days, hours, minutes, seconds);
|
||||
return (*buffer ? buffer : empty_str);
|
||||
}
|
||||
|
|
@ -1,19 +0,0 @@
|
|||
--- numbers.c.orig Wed Nov 30 11:06:26 2005
|
||||
+++ numbers.c Sun Jan 8 22:22:04 2006
|
||||
@@ -980,14 +980,14 @@
|
||||
|
||||
case 329: /* #define CREATION_TIME 329 */
|
||||
{
|
||||
- time_t tme;
|
||||
+ unsigned long tme;
|
||||
char *this_sucks;
|
||||
struct channel *chan = NULL;
|
||||
|
||||
if (!ArgList[1] || !*ArgList[1])
|
||||
break;
|
||||
sscanf(ArgList[1], "%lu", &tme);
|
||||
- this_sucks = ctime(&tme);
|
||||
+ this_sucks = ctime((time_t *)&tme);
|
||||
this_sucks[strlen(this_sucks) - 1] = '\0';
|
||||
|
||||
message_from(ArgList[0], LOG_CRAP);
|
|
@ -1,11 +0,0 @@
|
|||
--- xscandir.c.orig Sun Jan 8 07:58:21 2006
|
||||
+++ xscandir.c Sun Jan 8 08:00:46 2006
|
||||
@@ -84,7 +84,7 @@
|
||||
static int the_longest;
|
||||
|
||||
/* used by scandir to select entries */
|
||||
-static int dselect(const struct dirent *d)
|
||||
+static int dselect(struct dirent *d)
|
||||
{
|
||||
int t;
|
||||
|
|
@ -1,6 +0,0 @@
|
|||
bin/xaric
|
||||
%%DATADIR%%/help/copying
|
||||
%%DATADIR%%/help/help
|
||||
%%DATADIR%%/help/warranty
|
||||
@dirrm %%DATADIR%%/help
|
||||
@dirrm %%DATADIR%%
|
Loading…
Reference in a new issue