Add wmget 0.5.0,
wmget is a dock app for the GNU Window Maker window manager which makes it more convenient to perform long downloads in the background. PR: ports/61736 Submitted by: Ulrich Spoerlein <q@uni.de>
This commit is contained in:
parent
dcbed75aab
commit
4ef07d396e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=99276
8 changed files with 118 additions and 0 deletions
|
@ -81,6 +81,7 @@
|
|||
SUBDIR += wget
|
||||
SUBDIR += wget+ipv6
|
||||
SUBDIR += wget-devel
|
||||
SUBDIR += wmget
|
||||
SUBDIR += wput
|
||||
SUBDIR += wu-ftpd
|
||||
SUBDIR += wu-ftpd+ipv6
|
||||
|
|
33
ftp/wmget/Makefile
Normal file
33
ftp/wmget/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
# New ports collection makefile for: wmget
|
||||
# Date created: 05.01.2004
|
||||
# Whom: Ulrich Spoerlein <q@uni.de>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= wmget
|
||||
PORTVERSION= 0.5.0
|
||||
CATEGORIES= ftp
|
||||
MASTER_SITES= http://amtrickey.net/download/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
|
||||
|
||||
MAINTAINER= q@uni.de
|
||||
COMMENT= Dock app for Window Maker providing wget functionality
|
||||
|
||||
LIB_DEPENDS= curl.2:${PORTSDIR}/ftp/curl
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GETOPT_LONG= yes
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
MAKE_ENV+= ${CONFIGURE_ENV}
|
||||
|
||||
MAN1= wmget.1
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/wmget ${PREFIX}/bin
|
||||
.if !defined(NO_INSTALL_MANPAGES)
|
||||
${INSTALL_MAN} ${WRKSRC}/wmget.1 ${PREFIX}/man/man1
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
ftp/wmget/distinfo
Normal file
1
ftp/wmget/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (wmget-0.5.0-src.tar.gz) = 7d0b169c5bb51a7ad13325583f674be1
|
45
ftp/wmget/files/patch-Makefile
Normal file
45
ftp/wmget/files/patch-Makefile
Normal file
|
@ -0,0 +1,45 @@
|
|||
--- Makefile.orig Sun Feb 9 05:04:20 2003
|
||||
+++ Makefile Tue Jan 27 16:34:31 2004
|
||||
@@ -46,16 +46,18 @@
|
||||
|
||||
# To specify a different prefix, you can override this on the command line
|
||||
# make PREFIX=/opt/dockapps install
|
||||
-PREFIX= /usr/local
|
||||
+X11BASE?= /usr/X11R6
|
||||
+PREFIX?= ${X11BASE}
|
||||
|
||||
INSTALLDIR= install -d -m 755
|
||||
-INSTALLBIN= install -m 555
|
||||
-INSTALLMAN= install -m 444
|
||||
-CC= gcc
|
||||
-CFLAGS= -ansi -Wall -W -I/usr/X11R6/include -D_GNU_SOURCE
|
||||
+INSTALLBIN= $(INSTALL_PROGRAM)
|
||||
+INSTALLMAN= $(INSTALL_MAN)
|
||||
+CC?= gcc
|
||||
+CFLAGS?= -ansi -Wall -W
|
||||
+CFLAGS+= -I${X11BASE}/include -I${LOCALBASE}/include -D_GNU_SOURCE
|
||||
# The following line is what I use during development
|
||||
#CFLAGS:= $(CFLAGS) -Werror -g
|
||||
-LDFLAGS= -L/usr/X11R6/lib -lXpm -lXext -lX11 -lm -lcurl
|
||||
+LDFLAGS+= -L${X11BASE}/lib -L${LOCALBASE}/lib -lXpm -lXext -lX11 -lm -lcurl
|
||||
DOCS= wmget.1
|
||||
|
||||
VERSION:= $(shell grep '\#define WMGET_VERSION ' wmget.h \
|
||||
@@ -107,7 +109,7 @@
|
||||
##### LIBRARY ##########################################################
|
||||
|
||||
dockapplib:
|
||||
- make -C $(DALIBDIR)
|
||||
+ ${MAKE} -C $(DALIBDIR)
|
||||
|
||||
|
||||
|
||||
@@ -130,7 +132,7 @@
|
||||
wmget.html
|
||||
sed -e '/^# DO NOT/q' < Makefile > Makefile.clean \
|
||||
&& mv -f Makefile.clean Makefile
|
||||
- make -C dockapp clean
|
||||
+ ${MAKE} -C dockapp clean
|
||||
|
||||
docclean:
|
||||
rm -f $(DOCS)
|
10
ftp/wmget/files/patch-configure.c
Normal file
10
ftp/wmget/files/patch-configure.c
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- configure.c.orig Mon Jan 5 18:16:22 2004
|
||||
+++ configure.c Mon Jan 5 18:16:32 2004
|
||||
@@ -30,7 +30,6 @@
|
||||
*/
|
||||
|
||||
#include <string.h>
|
||||
-#include <malloc.h>
|
||||
#include <ctype.h>
|
||||
#include <getopt.h>
|
||||
#include <stdlib.h>
|
17
ftp/wmget/files/patch-dockapp::Makefile
Normal file
17
ftp/wmget/files/patch-dockapp::Makefile
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- dockapp/Makefile.orig Sun Feb 9 04:08:07 2003
|
||||
+++ dockapp/Makefile Mon Jan 5 18:11:28 2004
|
||||
@@ -19,11 +19,11 @@
|
||||
|
||||
# Makefile for the dockapp library packaged in the ``wmget'' application.
|
||||
|
||||
-
|
||||
DAOBJS= da_run.o da_x.o da_mouse.o
|
||||
|
||||
-CFLAGS= -ansi -Wall -W -Werror -g
|
||||
-LDFLAGS= -L/usr/X11R6/lib -lXpm -lXext -lX11
|
||||
+CFLAGS?= -ansi -Wall -W -Werror -g
|
||||
+CFLAGS+= -I${X11BASE}/include
|
||||
+LDFLAGS= -L${X11BASE}/lib -lXpm -lXext -lX11
|
||||
|
||||
dockapp.a: $(DAOBJS)
|
||||
ar rcsv dockapp.a $(DAOBJS)
|
10
ftp/wmget/pkg-descr
Normal file
10
ftp/wmget/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
wmget is a dock app for the GNU Window Maker window manager which makes it more
|
||||
convenient to perform long downloads in the background.
|
||||
|
||||
This is useful if you tend to have dozens of windows open at a time and tend to
|
||||
do a lot of routine downloading. Just copy the link from your browser, middle-
|
||||
click on the wmget dockapp, and the download will start. No download windows or
|
||||
terminals required, and you can monitor the progress and stop the transfer if
|
||||
desired without opening or raising any windows or even changing desktops.
|
||||
|
||||
WWW: http://amtrickey.net/wmget/
|
1
ftp/wmget/pkg-plist
Normal file
1
ftp/wmget/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
bin/wmget
|
Loading…
Reference in a new issue